summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-27 23:36:45 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-27 23:36:45 -0400
commitdd3ad295b1a9f48c00617a7c53c6699168f62523 (patch)
tree4283de4b504877baa5a7090ea181274d39427812 /gnome-base/gnome-settings-daemon/files
parentdev-util/anjuta: 3.2.0 → 3.2.1 (diff)
downloadgnome-dd3ad295b1a9f48c00617a7c53c6699168f62523.tar.gz
gnome-dd3ad295b1a9f48c00617a7c53c6699168f62523.tar.bz2
gnome-dd3ad295b1a9f48c00617a7c53c6699168f62523.zip
gnome-base/gnome-settings-daemon: make colord optional
As discussed on IRC with Nirbheek. This will make gnome-3.2 easier to unmask.
Diffstat (limited to 'gnome-base/gnome-settings-daemon/files')
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch95
1 files changed, 95 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch
new file mode 100644
index 00000000..98afbec6
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.2.1-optional-colord.patch
@@ -0,0 +1,95 @@
+From e1e0584cec966dc58a51efaf534f129b4830399f Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Thu, 27 Oct 2011 23:30:41 -0400
+Subject: [PATCH] Make colord optional
+
+---
+ configure.ac | 20 +++++++++++++++++++-
+ data/Makefile.am | 7 ++++++-
+ plugins/Makefile.am | 7 ++++++-
+ 3 files changed, 31 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fe74674..f1a8547 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -107,7 +107,25 @@ PKG_CHECK_MODULES(GNOME_DESKTOP, gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VE
+ dnl ---------------------------------------------------------------------------
+ dnl - Check for colord
+ dnl ---------------------------------------------------------------------------
+-PKG_CHECK_MODULES(COLORD, colord >= 0.1.12)
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [turn off color plugin]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLORD, colord >= 0.1.12)
++ build_color=true
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++
++AC_SUBST(COLORD_CFLAGS)
++AC_SUBST(COLORD_LIBS)
+
+ dnl ---------------------------------------------------------------------------
+ dnl - Check for libcanberra
+diff --git a/data/Makefile.am b/data/Makefile.am
+index 43ba27c..1f3bbef 100644
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -11,7 +11,6 @@ gsettings_SCHEMAS = \
+ org.gnome.settings-daemon.plugins.gschema.xml \
+ org.gnome.settings-daemon.plugins.keyboard.gschema.xml \
+ org.gnome.settings-daemon.plugins.power.gschema.xml \
+- org.gnome.settings-daemon.plugins.color.gschema.xml \
+ org.gnome.settings-daemon.plugins.media-keys.gschema.xml \
+ org.gnome.settings-daemon.plugins.xsettings.gschema.xml \
+ org.gnome.settings-daemon.plugins.housekeeping.gschema.xml \
+@@ -21,6 +20,12 @@ gsettings_SCHEMAS = \
+
+ all_schemas = $(gsettings_SCHEMAS)
+
++if BUILD_COLOR
++gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.color.gschema.xml
++else
++all_schemas += org.gnome.settings-daemon.plugins.color.gschema.xml
++endif
++
+ if HAVE_PACKAGEKIT
+ gsettings_SCHEMAS += org.gnome.settings-daemon.plugins.updates.gschema.xml
+ else
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index 5e26811..d2404ab 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -6,7 +6,6 @@ enabled_plugins = \
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ datetime \
+ dummy \
+@@ -24,6 +23,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if BUILD_GCONF_BRIDGE
+ enabled_plugins += gconf
+ else
+--
+1.7.7.1
+