aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-03 18:02:43 -0400
committerAnthony G. Basile <blueness@gentoo.org>2012-11-03 18:02:43 -0400
commite3394b1dd8ba0b6cdf4c39d8e6542dcdc816ff8a (patch)
treeca11aeb96704c5eb2e4e47f54d76a8280464299d /x11-libs/gtk+/files/gtk+-3.4.4-dont-fallback-c89-uclibc.patch
parentAvoid name collision with unshare in uclibc's <bits/sched.h>. (diff)
downloadhardened-dev-e3394b1dd8ba0b6cdf4c39d8e6542dcdc816ff8a.tar.gz
hardened-dev-e3394b1dd8ba0b6cdf4c39d8e6542dcdc816ff8a.tar.bz2
hardened-dev-e3394b1dd8ba0b6cdf4c39d8e6542dcdc816ff8a.zip
Don't fallback on C89's isnan/isinf on uclibc which already has them
On a uclibc system, HAVE_ISNAN and HAVE_ISINF are left undefined by gtk+'s configure.ac's AC_CHECK_FUNCS(isnan isinf), even though uclibc provides these functions, possibly because autoconf's AC_CHECK_FUNCS misses testing a build with -lm which is needed on a uclibc system but not on a glibc system. This hits gtk+ which tries to fall back to C89 standards and include its own definitions of isnan() and isifn() in gdk/gdkrgba.c. This patch avoids that inclusion. X-Gentoo-Bug: 441634 X-Gentoo-Bug-URL: https://bugs.gentoo.org/441634 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'x11-libs/gtk+/files/gtk+-3.4.4-dont-fallback-c89-uclibc.patch')
-rw-r--r--x11-libs/gtk+/files/gtk+-3.4.4-dont-fallback-c89-uclibc.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/x11-libs/gtk+/files/gtk+-3.4.4-dont-fallback-c89-uclibc.patch b/x11-libs/gtk+/files/gtk+-3.4.4-dont-fallback-c89-uclibc.patch
new file mode 100644
index 00000000..79eda021
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.4.4-dont-fallback-c89-uclibc.patch
@@ -0,0 +1,13 @@
+diff -Naur gtk+-3.4.4.orig/gdk/gdkrgba.c gtk+-3.4.4/gdk/gdkrgba.c
+--- gtk+-3.4.4.orig/gdk/gdkrgba.c 2012-07-15 04:52:45.000000000 +0000
++++ gtk+-3.4.4/gdk/gdkrgba.c 2012-11-03 21:25:04.842187979 +0000
+@@ -28,7 +28,9 @@
+ #include <errno.h>
+ #include <math.h>
+
++#ifndef __UCLIBC__
+ #include "fallback-c89.c"
++#endif
+
+ /**
+ * SECTION:rgba_colors