aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gobject-introspection/gobject-introspection-1.36.0-r99.ebuild')
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.36.0-r99.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r99.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r99.ebuild
deleted file mode 100644
index b46aab72..00000000
--- a/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r99.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.36.0-r1.ebuild,v 1.2 2013/11/30 18:48:21 pacho Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="xml"
-
-inherit eutils gnome2 python-single-r1 toolchain-funcs
-
-DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
-HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
-
-LICENSE="LGPL-2+ GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-IUSE="cairo doctool test"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- test? ( cairo )
-"
-
-RDEPEND="
- >=dev-libs/gobject-introspection-common-${PV}
- >=dev-libs/glib-2.36:2
- doctool? ( dev-python/mako )
- virtual/libffi:=
- !<dev-lang/vala-0.20.0
-"
-# Wants real bison, not virtual/yacc
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.15
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-# PDEPEND to avoid circular dependencies, bug #391213
-PDEPEND="cairo? ( x11-libs/cairo[glib] )"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Do not misdetect clang as the Microsoft C compiler (from 'master)
- epatch "${FILESDIR}/${PN}-1.36.0-detect-clang.patch"
-
- # To prevent crosscompiling problems, bug #414105
- CC=$(tc-getCC)
-
- DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
- gnome2_src_prepare
-
- # avoid GNU-isms
- sed -i -e 's/\(if test .* \)==/\1=/' configure || die
-
- if ! has_version "x11-libs/cairo[glib]"; then
- # Bug #391213: enable cairo-gobject support even if it's not installed
- # We only PDEPEND on cairo to avoid circular dependencies
- export CAIRO_LIBS="-lcairo -lcairo-gobject"
- export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
- fi
-}
-
-src_configure(){
- gnome2_src_configure \
- --disable-static \
- YACC=$(type -p yacc) \
- $(use_with cairo) \
- $(use_enable doctool)
-}
-
-src_install() {
- gnome2_src_install
-
- # Prevent collision with gobject-introspection-common
- rm -v "${ED}"usr/share/aclocal/introspection.m4 \
- "${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
- rmdir "${ED}"usr/share/aclocal || die
-}