aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-28 14:04:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-28 14:07:36 +0200
commit1c9fe9b96f7e510523bf915a45567ec2a80320f8 (patch)
treef5885eb7991527bb68931dd9b57254d81034c089
parentkde-apps/kmbox: Add missing KFMIN (diff)
downloadkde-HEAD.tar.gz
kde-HEAD.tar.bz2
kde-HEAD.zip
kde-apps/okular: Rebase tests.patch on top of (24.05) HEADHEADmaster
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/okular/files/okular-21.11.80-tests.patch101
-rw-r--r--kde-apps/okular/files/okular-24.01.80-tests.patch98
-rw-r--r--kde-apps/okular/files/okular-24.04.80-tests.patch46
-rw-r--r--kde-apps/okular/okular-24.05.49.9999.ebuild2
-rw-r--r--kde-apps/okular/okular-9999.ebuild2
5 files changed, 48 insertions, 201 deletions
diff --git a/kde-apps/okular/files/okular-21.11.80-tests.patch b/kde-apps/okular/files/okular-21.11.80-tests.patch
deleted file mode 100644
index a0babcad1c..0000000000
--- a/kde-apps/okular/files/okular-21.11.80-tests.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From 323fed918995fe2e01036c74c1498446b4d2f122 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Thu, 12 Oct 2017 14:09:09 +0200
-Subject: [PATCH] Move tests into existing (auto)tests subdirectories
-
----
- generators/chm/CMakeLists.txt | 12 +++---------
- generators/chm/autotests/CMakeLists.txt | 8 ++++++++
- generators/chm/autotests/chmgeneratortest.cpp | 2 +-
- generators/comicbook/CMakeLists.txt | 10 +++-------
- generators/comicbook/autotests/CMakeLists.txt | 6 ++++++
- 8 files changed, 27 insertions(+), 18 deletions(-)
- create mode 100644 generators/chm/autotests/CMakeLists.txt
- create mode 100644 generators/comicbook/autotests/CMakeLists.txt
-
-diff --git a/generators/chm/CMakeLists.txt b/generators/chm/CMakeLists.txt
-index 0d7452cba..3adb3fd54 100644
---- a/generators/chm/CMakeLists.txt
-+++ b/generators/chm/CMakeLists.txt
-@@ -23,15 +23,9 @@ okular_add_generator(okularGenerator_chmlib ${okularGenerator_chmlib_SRCS})
- target_include_directories(okularGenerator_chmlib PRIVATE ${CHM_INCLUDE_DIR} ${LIBZIP_INCLUDE_DIR})
- target_link_libraries(okularGenerator_chmlib okularcore ${CHM_LIBRARY} ${LIBZIP_LIBRARY} KF5::KHtml)
-
--########### autotests ###############
--
--add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
--ecm_add_test(autotests/chmgeneratortest.cpp
-- TEST_NAME "chmgeneratortest"
-- LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore
--)
--
--target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
-+if(BUILD_TESTING)
-+ add_subdirectory(autotests)
-+endif()
-
- ########### install files ###############
- install( FILES okularChm.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
-diff --git a/generators/chm/autotests/CMakeLists.txt b/generators/chm/autotests/CMakeLists.txt
-new file mode 100644
-index 000000000..59753ca45
---- /dev/null
-+++ b/generators/chm/autotests/CMakeLists.txt
-@@ -0,0 +1,8 @@
-+add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
-+
-+ecm_add_test(chmgeneratortest.cpp
-+ TEST_NAME "chmgeneratortest"
-+ LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore
-+)
-+
-+target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
-diff --git a/generators/chm/autotests/chmgeneratortest.cpp b/generators/chm/autotests/chmgeneratortest.cpp
-index c428fa1b3..68f7a5821 100644
---- a/generators/chm/autotests/chmgeneratortest.cpp
-+++ b/generators/chm/autotests/chmgeneratortest.cpp
-@@ -30,7 +30,7 @@ void ChmGeneratorTest::initTestCase()
- {
- Okular::SettingsCore::instance(QStringLiteral("ChmGeneratorTest"));
- m_document = new Okular::Document(nullptr);
-- const QString testFile = QStringLiteral(KDESRCDIR "autotests/data/test.chm");
-+ const QString testFile = QStringLiteral(KDESRCDIR "data/test.chm");
- QMimeDatabase db;
- const QMimeType mime = db.mimeTypeForFile(testFile);
- QCOMPARE(m_document->openDocument(testFile, QUrl(), mime), Okular::Document::OpenSuccess);
-diff --git a/generators/comicbook/CMakeLists.txt b/generators/comicbook/CMakeLists.txt
-index a0e7569a2..91bcc6ec7 100644
---- a/generators/comicbook/CMakeLists.txt
-+++ b/generators/comicbook/CMakeLists.txt
-@@ -25,13 +25,9 @@ if (KArchive_HAVE_LZMA)
- target_compile_definitions(okular_comicbook PRIVATE -DWITH_K7ZIP=1)
- endif()
-
--########### autotests ###############
--
--add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
--ecm_add_test(autotests/comicbooktest.cpp
-- TEST_NAME "comicbooktest"
-- LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore okular_comicbook
--)
-+if(BUILD_TESTING)
-+ add_subdirectory(autotests)
-+endif()
-
- ########### install files ###############
- install( FILES okularComicbook.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
-diff --git a/generators/comicbook/autotests/CMakeLists.txt b/generators/comicbook/autotests/CMakeLists.txt
-new file mode 100644
-index 000000000..aaacb341a
---- /dev/null
-+++ b/generators/comicbook/autotests/CMakeLists.txt
-@@ -0,0 +1,6 @@
-+add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
-+
-+ecm_add_test(comicbooktest.cpp
-+ TEST_NAME "comicbooktest"
-+ LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore okular_comicbook
-+)
---
-2.33.0
-
diff --git a/kde-apps/okular/files/okular-24.01.80-tests.patch b/kde-apps/okular/files/okular-24.01.80-tests.patch
deleted file mode 100644
index 1ae19277b5..0000000000
--- a/kde-apps/okular/files/okular-24.01.80-tests.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From 7e5c4aa3760db4dbb76af47e173be3dff229bff7 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Tue, 19 Dec 2023 10:13:52 +0100
-Subject: [PATCH] Move tests into existing (auto)tests subdirectories
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- generators/chm/CMakeLists.txt | 11 +++--------
- generators/chm/autotests/CMakeLists.txt | 7 +++++++
- generators/chm/autotests/chmgeneratortest.cpp | 2 +-
- generators/comicbook/CMakeLists.txt | 9 +++------
- generators/comicbook/autotests/CMakeLists.txt | 5 +++++
- 5 files changed, 19 insertions(+), 15 deletions(-)
- create mode 100644 generators/chm/autotests/CMakeLists.txt
- create mode 100644 generators/comicbook/autotests/CMakeLists.txt
-
-diff --git a/generators/chm/CMakeLists.txt b/generators/chm/CMakeLists.txt
-index 5d569499f..2784f75fc 100644
---- a/generators/chm/CMakeLists.txt
-+++ b/generators/chm/CMakeLists.txt
-@@ -24,14 +24,9 @@ target_include_directories(okularGenerator_chmlib PRIVATE ${CHM_INCLUDE_DIR} ${L
- target_link_libraries(okularGenerator_chmlib okularcore ${CHM_LIBRARY} ${LIBZIP_LIBRARY} KF6::KHtml)
-
- ########### autotests ###############
--
--add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
--ecm_add_test(autotests/chmgeneratortest.cpp
-- TEST_NAME "chmgeneratortest"
-- LINK_LIBRARIES Qt6::Test KF6::CoreAddons okularcore
--)
--
--target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
-+if(BUILD_TESTING)
-+ add_subdirectory(autotests)
-+endif()
-
- ########### install files ###############
- install( PROGRAMS okularApplication_chm.desktop org.kde.mobile.okular_chm.desktop DESTINATION ${KDE_INSTALL_APPDIR} )
-diff --git a/generators/chm/autotests/CMakeLists.txt b/generators/chm/autotests/CMakeLists.txt
-new file mode 100644
-index 000000000..36c468156
---- /dev/null
-+++ b/generators/chm/autotests/CMakeLists.txt
-@@ -0,0 +1,7 @@
-+add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
-+ecm_add_test(chmgeneratortest.cpp
-+ TEST_NAME "chmgeneratortest"
-+ LINK_LIBRARIES Qt6::Test KF6::CoreAddons okularcore
-+)
-+
-+target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
-diff --git a/generators/chm/autotests/chmgeneratortest.cpp b/generators/chm/autotests/chmgeneratortest.cpp
-index 2c7696ab1..24742248b 100644
---- a/generators/chm/autotests/chmgeneratortest.cpp
-+++ b/generators/chm/autotests/chmgeneratortest.cpp
-@@ -30,7 +30,7 @@ void ChmGeneratorTest::initTestCase()
- {
- Okular::SettingsCore::instance(QStringLiteral("ChmGeneratorTest"));
- m_document = new Okular::Document(nullptr);
-- const QString testFile = QStringLiteral(KDESRCDIR "autotests/data/test.chm");
-+ const QString testFile = QStringLiteral(KDESRCDIR "data/test.chm");
- QMimeDatabase db;
- const QMimeType mime = db.mimeTypeForFile(testFile);
- QCOMPARE(m_document->openDocument(testFile, QUrl(), mime), Okular::Document::OpenSuccess);
-diff --git a/generators/comicbook/CMakeLists.txt b/generators/comicbook/CMakeLists.txt
-index 2fc8ff710..d92c75905 100644
---- a/generators/comicbook/CMakeLists.txt
-+++ b/generators/comicbook/CMakeLists.txt
-@@ -27,12 +27,9 @@ if (KArchive_HAVE_LZMA)
- endif()
-
- ########### autotests ###############
--
--add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
--ecm_add_test(autotests/comicbooktest.cpp
-- TEST_NAME "comicbooktest"
-- LINK_LIBRARIES Qt6::Test KF6::CoreAddons okularcore okular_comicbook
--)
-+if(BUILD_TESTING)
-+ add_subdirectory(autotests)
-+endif()
-
- ########### install files ###############
- install( PROGRAMS okularApplication_comicbook.desktop org.kde.mobile.okular_comicbook.desktop DESTINATION ${KDE_INSTALL_APPDIR} )
-diff --git a/generators/comicbook/autotests/CMakeLists.txt b/generators/comicbook/autotests/CMakeLists.txt
-new file mode 100644
-index 000000000..6426105e4
---- /dev/null
-+++ b/generators/comicbook/autotests/CMakeLists.txt
-@@ -0,0 +1,5 @@
-+add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
-+ecm_add_test(comicbooktest.cpp
-+ TEST_NAME "comicbooktest"
-+ LINK_LIBRARIES Qt6::Test KF6::CoreAddons okularcore okular_comicbook
-+)
---
-2.43.0
-
diff --git a/kde-apps/okular/files/okular-24.04.80-tests.patch b/kde-apps/okular/files/okular-24.04.80-tests.patch
new file mode 100644
index 0000000000..b36ab68432
--- /dev/null
+++ b/kde-apps/okular/files/okular-24.04.80-tests.patch
@@ -0,0 +1,46 @@
+From 3f90abab39233c2fb56b7cb3b95d552c0ca1146d Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 19 Dec 2023 10:13:52 +0100
+Subject: [PATCH] Move tests into existing (auto)tests subdirectories
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ generators/comicbook/CMakeLists.txt | 9 +++------
+ generators/comicbook/autotests/CMakeLists.txt | 5 +++++
+ 2 files changed, 8 insertions(+), 6 deletions(-)
+ create mode 100644 generators/comicbook/autotests/CMakeLists.txt
+
+diff --git a/generators/comicbook/CMakeLists.txt b/generators/comicbook/CMakeLists.txt
+index 53075836d..c601e9d7b 100644
+--- a/generators/comicbook/CMakeLists.txt
++++ b/generators/comicbook/CMakeLists.txt
+@@ -29,12 +29,9 @@ else()
+ endif()
+
+ ########### autotests ###############
+-
+-add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
+-ecm_add_test(autotests/comicbooktest.cpp
+- TEST_NAME "comicbooktest"
+- LINK_LIBRARIES Qt6::Test KF6::CoreAddons okularcore okular_comicbook
+-)
++if(BUILD_TESTING)
++ add_subdirectory(autotests)
++endif()
+
+ ########### install files ###############
+ install( PROGRAMS okularApplication_comicbook.desktop org.kde.mobile.okular_comicbook.desktop DESTINATION ${KDE_INSTALL_APPDIR} )
+diff --git a/generators/comicbook/autotests/CMakeLists.txt b/generators/comicbook/autotests/CMakeLists.txt
+new file mode 100644
+index 000000000..6426105e4
+--- /dev/null
++++ b/generators/comicbook/autotests/CMakeLists.txt
+@@ -0,0 +1,5 @@
++add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
++ecm_add_test(comicbooktest.cpp
++ TEST_NAME "comicbooktest"
++ LINK_LIBRARIES Qt6::Test KF6::CoreAddons okularcore okular_comicbook
++)
+--
+2.44.0
+
diff --git a/kde-apps/okular/okular-24.05.49.9999.ebuild b/kde-apps/okular/okular-24.05.49.9999.ebuild
index c24fb5da1a..be9e5bbd77 100644
--- a/kde-apps/okular/okular-24.05.49.9999.ebuild
+++ b/kde-apps/okular/okular-24.05.49.9999.ebuild
@@ -63,7 +63,7 @@ RDEPEND="${DEPEND}
"
PATCHES=(
- "${FILESDIR}/${PN}-24.01.80-tests.patch" # bug 734138
+ "${FILESDIR}/${PN}-24.04.80-tests.patch" # bug 734138
"${FILESDIR}/${PN}-20.08.2-hide-mobile-app.patch" # avoid same-name entry
)
diff --git a/kde-apps/okular/okular-9999.ebuild b/kde-apps/okular/okular-9999.ebuild
index c24fb5da1a..be9e5bbd77 100644
--- a/kde-apps/okular/okular-9999.ebuild
+++ b/kde-apps/okular/okular-9999.ebuild
@@ -63,7 +63,7 @@ RDEPEND="${DEPEND}
"
PATCHES=(
- "${FILESDIR}/${PN}-24.01.80-tests.patch" # bug 734138
+ "${FILESDIR}/${PN}-24.04.80-tests.patch" # bug 734138
"${FILESDIR}/${PN}-20.08.2-hide-mobile-app.patch" # avoid same-name entry
)