aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-15 01:33:11 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-10-15 01:36:50 +1100
commita757f8181d00bc126eb63f1a410e3484a15a47a1 (patch)
treef402fb7a89110d0158925e7e0877419e637ab448 /kde-base/kdelibs
parentapp-text/kbibtex: Add KDE_DOXYGEN and KDE_HANDBOOK (diff)
downloadkde-a757f8181d00bc126eb63f1a410e3484a15a47a1.tar.gz
kde-a757f8181d00bc126eb63f1a410e3484a15a47a1.tar.bz2
kde-a757f8181d00bc126eb63f1a410e3484a15a47a1.zip
kde-base/kdelibs: add patch to ensure the correct version of Qt is always used
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/files/kdelibs-4.14.13-FindQt4.patch28
-rw-r--r--kde-base/kdelibs/kdelibs-4.9999.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/kdelibs/files/kdelibs-4.14.13-FindQt4.patch b/kde-base/kdelibs/files/kdelibs-4.14.13-FindQt4.patch
new file mode 100644
index 0000000000..2e8c2d9e4c
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-4.14.13-FindQt4.patch
@@ -0,0 +1,28 @@
+Ensure that the correct version of Qt is always used.
+
+With the introduction qt-4.8.6, Qt binaries were moved from /usr/bin to
+/usr/$(get_libdir)/qt4/bin, leaving behind in their place symlinks to qtchooser.
+
+There is no guarantee to which version of Qt these symlinks might point, so it
+is necessary to find the correct version explicitly.
+
+Once qmake is found, it is queried for the correct location of all other items.
+
+Gentoo-bug: 562746
+
+--- cmake/modules/FindQt4.cmake
++++ cmake/modules/FindQt4.cmake
+@@ -447,10 +447,9 @@ GET_FILENAME_COMPONENT(qt_install_version "[HKEY_CURRENT_USER\\Software\\trollte
+ # Debian uses qmake-qt4
+ # macports' Qt uses qmake-mac
+ FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake qmake4 qmake-qt4 qmake-mac PATHS
+- "[HKEY_CURRENT_USER\\Software\\Trolltech\\Qt3Versions\\4.0.0;InstallDir]/bin"
+- "[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\4.0.0;InstallDir]/bin"
+- "[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\${qt_install_version};InstallDir]/bin"
+- $ENV{QTDIR}/bin
++ /usr/${CMAKE_INSTALL_LIBDIR}/qt4/bin
++ /usr/bin
++ NO_DEFAULT_PATH
+ DOC "The qmake executable for the Qt installation to use"
+ )
+
diff --git a/kde-base/kdelibs/kdelibs-4.9999.ebuild b/kde-base/kdelibs/kdelibs-4.9999.ebuild
index 75792aec4d..2b88052137 100644
--- a/kde-base/kdelibs/kdelibs-4.9999.ebuild
+++ b/kde-base/kdelibs/kdelibs-4.9999.ebuild
@@ -133,6 +133,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.8.1-norpath.patch"
"${FILESDIR}/${PN}-4.9.3-werror.patch"
"${FILESDIR}/${PN}-4.10.0-udisks.patch"
+ "${FILESDIR}/${PN}-4.14.13-FindQt4.patch"
)
pkg_pretend() {