aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski (reavertm) <reavertm@poczta.fm>2009-03-30 03:53:24 +0200
committerMaciej Mrozowski (reavertm) <reavertm@poczta.fm>2009-03-30 03:53:24 +0200
commitbd6142155236a4da86f3e5335b63d7f90ee0b812 (patch)
tree6df72cf2bdc1d6aaf5a64c6e0ec4795d0dc2c68c /kde-misc/todo-list
parentFixed RDEPEND, added debug IUSE in some plasmoids, nuked kde-plasmoids (diff)
downloadkde-bd6142155236a4da86f3e5335b63d7f90ee0b812.tar.gz
kde-bd6142155236a4da86f3e5335b63d7f90ee0b812.tar.bz2
kde-bd6142155236a4da86f3e5335b63d7f90ee0b812.zip
Fixed RDEPEND of remaining plasmoids, added missing debug to IUSE, fixed raptormenu live ebuild
Diffstat (limited to 'kde-misc/todo-list')
-rw-r--r--kde-misc/todo-list/ChangeLog5
-rw-r--r--kde-misc/todo-list/Manifest4
-rw-r--r--kde-misc/todo-list/todo-list-0.2.1.ebuild16
3 files changed, 16 insertions, 9 deletions
diff --git a/kde-misc/todo-list/ChangeLog b/kde-misc/todo-list/ChangeLog
index 675a276802..9319aa9a54 100644
--- a/kde-misc/todo-list/ChangeLog
+++ b/kde-misc/todo-list/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 30 Mar 2009; Maciej Mrozowski (reavertm) <reavertm@poczta.fm>
+ todo-list-0.2.1.ebuild:
+ Added debug IUSE, moved plasma-workspace to RDEPEND, sorted deps and
+ variables (SLOT between KEYWORDS and IUSE as it's usually invariant)
+
29 Mar 2009; Alex Alexander (wired) <alex.alexander@gmail.com>
todo-list-0.2.1.ebuild:
added plasma-workspace dependency
diff --git a/kde-misc/todo-list/Manifest b/kde-misc/todo-list/Manifest
index f7674ab41e..cb7acdc4a6 100644
--- a/kde-misc/todo-list/Manifest
+++ b/kde-misc/todo-list/Manifest
@@ -1,5 +1,5 @@
AUX todo-list-0.2.1-patch_kde42.diff 3494 RMD160 cae50c674952dda31f269187d1c4bcd3331343a0 SHA1 ffca587657977260ff563236b00d38920f33423c SHA256 a7d7a1915ea0e7fbd9123e1f2c8eb98fdd9d6e7e9e5a53c29c1cce62ca06a548
DIST 90706-todo_plasmoid-0.2.1.tar.bz 16960 RMD160 f8dd52474178cfa67ce2e2a83615648dbee35344 SHA1 5c22873b0ea59e7e196b40a230c03350a7093c9c SHA256 24c7116dbfef78126a5c905a0c36b721b12d122b9d31e23eeed2e01ca173a082
-EBUILD todo-list-0.2.1.ebuild 681 RMD160 65e5e23dc9bf0c0735e672454761366a6172528c SHA1 b9d8aa7e94c0bdb809a8651a33bae61311b2728c SHA256 9b474a964cd5b606900df38f6f1f36ea968fbe5cf572c9b2f77537e218fddd90
-MISC ChangeLog 897 RMD160 b80574173f79b9b5c984538ed78432370ed2cafe SHA1 dab85a7834019ebe04a0ea855e78f1ee644e825f SHA256 37e1609cf769aad741f10bd13f72c497dee92dc3b59070e81d63a0e5c7dd8bb1
+EBUILD todo-list-0.2.1.ebuild 671 RMD160 7fb30c3591fbe4f9a617a7f1e006b14af981bf47 SHA1 248bdab0a9e5f22654200f441f8793e0045a3763 SHA256 320b34197d664d98e1f9f1e2ef4e9e2869126e7d832887648cd65f3899790101
+MISC ChangeLog 1130 RMD160 d7e27fdfbd013c85c23caae0f47aa8e484d14ee9 SHA1 edad1655d45ead3b9c1b620b9531f7e6a1096d2d SHA256 0c42b46c3f85ce643e1aac3f4a0e200069347c826d2ba30a23c93df865e1d345
MISC metadata.xml 156 RMD160 ecce3b981f150c45ae1e84e2d208e678d6124259 SHA1 b64f7c0b4e5db816d82ad19848f72118af129d35 SHA256 2f4da28506b9d4185f320f67a6191d30c7a921217ed4447ed46ea0bc4aefc79a
diff --git a/kde-misc/todo-list/todo-list-0.2.1.ebuild b/kde-misc/todo-list/todo-list-0.2.1.ebuild
index ad64effb23..f0dd75a03b 100644
--- a/kde-misc/todo-list/todo-list-0.2.1.ebuild
+++ b/kde-misc/todo-list/todo-list-0.2.1.ebuild
@@ -8,19 +8,21 @@ inherit kde4-base
MY_PN="todo_plasmoid"
MY_P="${MY_PN}-${PV}"
+
DESCRIPTION="KDE4 plasmoid that shows a 'todo' list, using the korganizer 'Active calendar' resource file."
HOMEPAGE="http://kde-look.org/content/show.php/todo+list?content=90706"
SRC_URI="http://kde-look.org/CONTENT/content-files/90706-${MY_P}.tar.bz"
LICENSE="GPL-3"
-SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+SLOT="0"
+IUSE="debug"
-DEPEND=">=kde-base/plasma-workspace-${KDE_MINIMAL}"
-RDEPEND="${DEPEND}
- !kde-plasmoids/todo_plasmoid"
-
-PATCHES=( "${FILESDIR}/${P}-patch_kde42.diff" )
+RDEPEND="
+ !kde-plasmoids/todo_plasmoid
+ >=kde-base/plasma-workspace-${KDE_MINIMAL}
+"
S="${WORKDIR}/${MY_PN}"
+
+PATCHES=( "${FILESDIR}/${P}-patch_kde42.diff" )