aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLocke Shinseiko <wizzleby@gmail.com>2010-05-11 18:12:22 -0400
committerLocke Shinseiko <wizzleby@gmail.com>2010-05-11 18:20:25 -0400
commit81ef4fb921c4d5874778b7c0b64be9ffccfc81da (patch)
treed66ab6a3507c4a98fe10520438f5b3dc7c6d8f63 /net-p2p
parent[kde-base/kdebindings-ruby] Update ebuild (patch not yet in svn, be patient) (diff)
downloadkde-81ef4fb921c4d5874778b7c0b64be9ffccfc81da.tar.gz
kde-81ef4fb921c4d5874778b7c0b64be9ffccfc81da.tar.bz2
kde-81ef4fb921c4d5874778b7c0b64be9ffccfc81da.zip
[net-p2p/ktorrent] New ebuild: ktorrent-4.0_rc1, ported changes to -9999
New dependencies: >=net-p2p/libktorrent-1.0_rc1 >=kde-base/libkworkspace-${KDE_MINIMAL} [net-p2p/libktorrent] New ebuilds: libktorrent-1.0_rc1, -9999 Split from ktorrent. This, plus above changes fixes bug #314151
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Manifest4
-rw-r--r--net-p2p/ktorrent/ktorrent-4.0_rc1.ebuild94
-rw-r--r--net-p2p/ktorrent/ktorrent-9999.ebuild2
-rw-r--r--net-p2p/libktorrent/Manifest4
-rw-r--r--net-p2p/libktorrent/libktorrent-1.0_rc1.ebuild40
-rw-r--r--net-p2p/libktorrent/libktorrent-9999.ebuild40
-rw-r--r--net-p2p/libktorrent/metadata.xml6
7 files changed, 189 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
index 17b306d195..6d7d93ac3e 100644
--- a/net-p2p/ktorrent/Manifest
+++ b/net-p2p/ktorrent/Manifest
@@ -1,2 +1,4 @@
-EBUILD ktorrent-9999.ebuild 2627 RMD160 eb9448c40eeb0e7391541194849d2f26cd4e2e7f SHA1 0b8ca5aa654022d9c5aa484954a851a59f13d31a SHA256 c284b3825afb71824ed20b3aa736933fc024dc5caf72fe9beb2bc383a337c41b
+DIST ktorrent-4.0rc1.tar.bz2 2827064 RMD160 316e84ba3d003dfbd8976c413d27e600cfc69ba6 SHA1 77241aea5e94c0023870f6aadd031737a400d503 SHA256 c90793cd5508156ccf1e5250698e58f480626938d190eae211403db1975ae1de
+EBUILD ktorrent-4.0_rc1.ebuild 2706 RMD160 d577f77f84b8e90dc10479f1eefe110df5fea403 SHA1 3695fd22bd3b36ccf482ce3fcbee3e6f3a767e21 SHA256 ad92f9b85ff3e794ef798038d88fd80e99f5160fde687762caf121140c4c4b86
+EBUILD ktorrent-9999.ebuild 2700 RMD160 ce564017e798ce49c7c21a8698eb450f19f3fd23 SHA1 4745a8e18530e64c2271bc0f0f9d724edfb25e65 SHA256 086bf70fc29c530f6b89ec86950c7aca10bc22f14cfc4b190b710dc9c7d5fd9c
MISC metadata.xml 1425 RMD160 57a8dc4f1f121a577f042faea242dcb4bada8f7a SHA1 85f5015342bc1ffbedc1da1171260c05ee6b4eb8 SHA256 589714ec7f93ed39929de5c133b7aa98714b4223298d98b7c0585e6263258c30
diff --git a/net-p2p/ktorrent/ktorrent-4.0_rc1.ebuild b/net-p2p/ktorrent/ktorrent-4.0_rc1.ebuild
new file mode 100644
index 0000000000..6371ab3ccd
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-4.0_rc1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+if [[ ${PV} == *9999* ]] ; then
+ KMNAME="extragear/network"
+else
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ MY_P="${PN}-${MY_PV}"
+
+ KDE_LINGUAS="ar be bg ca cs da de el en_GB es et eu fr ga gl hi hne hr hu is it
+ ja km lt lv mai ms nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
+ tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+fi
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+SLOT="4"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
++magnetgenerator +mediaplayer plasma rss +scanfolder +search +shutdown +stats
++upnp webinterface +zeroconf"
+
+COMMONDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+ mediaplayer? ( >=media-libs/taglib-1.5 )
+ plasma? ( >=kde-base/libtaskmanager-${KDE_MINIMAL} )
+ rss? (
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ )
+ shutdown? (
+ >=kde-base/solid-${KDE_MINIMAL}
+ >=kde-base/libkworkspace-${KDE_MINIMAL}
+ )
+"
+DEPEND="${COMMONDEPEND}
+ >=net-p2p/libktorrent-1.0_rc1
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ >=kde-base/kdebase-kioslaves-${KDE_MINIMAL}
+ )
+ kross? ( >=kde-base/krosspython-${KDE_MINIMAL} )
+"
+
+src_prepare() {
+ if ! use plasma; then
+ sed -i \
+ -e "s:add_subdirectory(plasma):#nada:g" \
+ CMakeLists.txt || die "Failed to make plasmoid optional"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_DHT_SUPPORT=ON
+ -DWITH_SYSTEM_GEOIP=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable magnetgenerator MAGNETGENERATOR_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
+ )
+ kde4-base_src_configure
+}
diff --git a/net-p2p/ktorrent/ktorrent-9999.ebuild b/net-p2p/ktorrent/ktorrent-9999.ebuild
index 31f13df762..80b6d5f4f5 100644
--- a/net-p2p/ktorrent/ktorrent-9999.ebuild
+++ b/net-p2p/ktorrent/ktorrent-9999.ebuild
@@ -40,9 +40,11 @@ COMMONDEPEND="
)
shutdown? (
>=kde-base/solid-${KDE_MINIMAL}
+ >=kde-base/libkworkspace-${KDE_MINIMAL}
)
"
DEPEND="${COMMONDEPEND}
+ >=net-p2p/libktorrent-1.0_rc1
dev-libs/boost
sys-devel/gettext
"
diff --git a/net-p2p/libktorrent/Manifest b/net-p2p/libktorrent/Manifest
new file mode 100644
index 0000000000..996c7dc2a3
--- /dev/null
+++ b/net-p2p/libktorrent/Manifest
@@ -0,0 +1,4 @@
+DIST libktorrent-1.0rc1.tar.bz2 994289 RMD160 ed8d3957b39fa65e7da5ff404a8ddf9c73c2b1fc SHA1 84086ba6b29be8e508f35273f7431a4c572255c2 SHA256 79d1fa83e483d5263c5fb3ee6486f5340c9644eedd0d010ba46008a9fad2f181
+EBUILD libktorrent-1.0_rc1.ebuild 881 RMD160 a7576f3766158062555ab1cc0d49112d39e2ddd7 SHA1 a44f8cfdca1e39e0b9040be4706d7cec74408262 SHA256 e3702ff3bfca7e494d48f49178144381321877371bbdfd1fb345337ec78427ef
+EBUILD libktorrent-9999.ebuild 875 RMD160 b026115015cd3d5f1a2c5566e01b22ed64f00bff SHA1 bf3188a13699f21bd8e8546f949965ae435123b0 SHA256 ba5f992e796cdd7bd4a21839e246f4eaa7a983a581e8beedccbdff0e4f9108e3
+MISC metadata.xml 179 RMD160 c229e47ac67cab1a04f332ad5ee62c9007077023 SHA1 233d4bb9e84af7d4b746f23e5515d6106b87b7ac SHA256 301873fe6958c2332e538724ccb77ab9104f54aec2f388709971a159e4a6618a
diff --git a/net-p2p/libktorrent/libktorrent-1.0_rc1.ebuild b/net-p2p/libktorrent/libktorrent-1.0_rc1.ebuild
new file mode 100644
index 0000000000..fb34c842ae
--- /dev/null
+++ b/net-p2p/libktorrent/libktorrent-1.0_rc1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+if [[ ${PV} == *9999* ]] ; then
+ KMNAME="extragear/network"
+else
+ # upstream likes to skip that _ in beta releases
+ KTORRENT_VERSION="4.0rc1"
+ MY_PV="${PV/_/}"
+ MY_P="${PN}-${MY_PV}"
+
+ KDE_LINGUAS="ar be bg ca cs da de el en_GB es et eu fr ga gl hi hne hr hu is it
+ ja km lt lv mai ms nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
+ tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${KTORRENT_VERSION}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+fi
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+SLOT="4"
+IUSE="debug"
+
+COMMONDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}" \ No newline at end of file
diff --git a/net-p2p/libktorrent/libktorrent-9999.ebuild b/net-p2p/libktorrent/libktorrent-9999.ebuild
new file mode 100644
index 0000000000..ac8b6c7822
--- /dev/null
+++ b/net-p2p/libktorrent/libktorrent-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+if [[ ${PV} == *9999* ]] ; then
+ KMNAME="extragear/network"
+else
+ # upstream likes to skip that _ in beta releases
+ KTORRENT_VERSION="4.0rc1"
+ MY_PV="${PV/_/}"
+ MY_P="${PN}-${MY_PV}"
+
+ KDE_LINGUAS="ar be bg ca cs da de el en_GB es et eu fr ga gl hi hne hr hu is it
+ ja km lt lv mai ms nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
+ tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${KTORRENT_VERSION}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+fi
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+KEYWORDS=""
+SLOT="4"
+IUSE="debug"
+
+COMMONDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}" \ No newline at end of file
diff --git a/net-p2p/libktorrent/metadata.xml b/net-p2p/libktorrent/metadata.xml
new file mode 100644
index 0000000000..637dbc4033
--- /dev/null
+++ b/net-p2p/libktorrent/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <herd>net-p2p</herd>
+</pkgmetadata>