aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavlos Ratis <dastergon@gmail.com>2012-03-13 17:03:33 +0000
committerPavlos Ratis <dastergon@gmail.com>2012-05-18 17:06:47 +0300
commit96b43d196598c5b350d27730c8d829400fe9e8f8 (patch)
tree7c64617673844e0c9615a151b122e78421f809fa /net-p2p
parent[dev-libs/libdbusmenu-qt] Moved to tree. (diff)
downloadkde-96b43d196598c5b350d27730c8d829400fe9e8f8.tar.gz
kde-96b43d196598c5b350d27730c8d829400fe9e8f8.tar.bz2
kde-96b43d196598c5b350d27730c8d829400fe9e8f8.zip
[net-p2p/ktorrent] version bump
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Manifest1
-rw-r--r--net-p2p/ktorrent/ktorrent-4.2.0.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
new file mode 100644
index 0000000000..7bb59760b7
--- /dev/null
+++ b/net-p2p/ktorrent/Manifest
@@ -0,0 +1 @@
+DIST ktorrent-4.2.0.tar.bz2 3083219 SHA256 f625b1dc116c94d97ce3b56a7a259b07d95f6592b709596319bf16bb06cf6422 SHA512 248b70e537059092ced1cf408586df40feb10be4e4fe6aee5b18bdf046c42eff008c65628423728c98f9000eab1ea24942085576231827de5c209406f2d590b8 WHIRLPOOL 7251bfbd891a41a4b5c17f1eda8de24196ce497e6050107d5f6b9903722383fe99075845775fb6cdaf5107d43033d233ba5e4e5e57cba9b2d055e5fb984161dd
diff --git a/net-p2p/ktorrent/ktorrent-4.2.0.ebuild b/net-p2p/ktorrent/ktorrent-4.2.0.ebuild
new file mode 100644
index 0000000000..0b391111ee
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-4.2.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+KDE_SCM="git"
+KDE_MINIMAL="4.5"
+LIBKT_VERSION_MIN="${PV}"
+LIBKT_VERSION_MAX="99999999"
+if [[ ${PV} != 9999* ]]; then
+ inherit versionator
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ LIBKT_VERSION_MIN=$(($(get_major_version)-3)).$(get_version_component_range 2-3 ${PV})
+ LIBKT_VERSION_MAX=$(($(get_major_version)-3)).$(($(get_version_component_range 2)+1))
+ MY_P="${PN}-${MY_PV}"
+ KDE_HANDBOOK="optional"
+ KDE_DOC_DIRS="doc"
+
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km lt lv mai ms nb nds nl nn oc
+ pl pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+else
+ LIBKT_VERSION_MIN="${PV}"
+ LIBKT_VERSION_MAX="99999999"
+ KEYWORDS=""
+fi
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
++magnetgenerator +mediaplayer plasma rss +scanfolder +search +shutdown +stats
++upnp webinterface +zeroconf"
+
+COMMONDEPEND="
+ <net-libs/libktorrent-${LIBKT_VERSION_MAX}
+ >=net-libs/libktorrent-${LIBKT_VERSION_MIN}
+ infowidget? ( dev-libs/geoip )
+ mediaplayer? ( >=media-libs/taglib-1.5 )
+ plasma? ( $(add_kdebase_dep libtaskmanager) )
+ rss? ( $(add_kdebase_dep kdepimlibs) )
+ shutdown? (
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep solid)
+ )
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ $(add_kdebase_dep kdebase-kioslaves)
+ )
+ kross? ( $(add_kdebase_dep krosspython) )
+"
+
+src_prepare() {
+ if ! use plasma; then
+ sed -i \
+ -e "s:add_subdirectory(plasma):#nada:g" \
+ CMakeLists.txt || die "Failed to make plasmoid optional"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable magnetgenerator MAGNETGENERATOR_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
+ )
+ kde4-base_src_configure
+}