aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLocke Shinseiko <wizzleby@gmail.com>2010-07-09 01:42:57 -0400
committerLocke Shinseiko <wizzleby@gmail.com>2010-07-09 01:44:06 -0400
commitee43df136723349fc8e5d8c9d307ac7eadd0c418 (patch)
treedaf4bdd13b34acedebe6b9618b113cd7fd5cc202 /net-p2p
parent[net-libs/libktorrent] Cleaned up LINGUAS, fixed KTORRENT_VER in -9999, bump ... (diff)
downloadkde-ee43df136723349fc8e5d8c9d307ac7eadd0c418.tar.gz
kde-ee43df136723349fc8e5d8c9d307ac7eadd0c418.tar.bz2
kde-ee43df136723349fc8e5d8c9d307ac7eadd0c418.zip
[net-p2p/ktorrent] Clean up LINGUAS, bump 4.0.2 off of -9999 wrt #327553.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Manifest4
-rw-r--r--net-p2p/ktorrent/ktorrent-4.0.2.ebuild93
-rw-r--r--net-p2p/ktorrent/ktorrent-9999.ebuild7
3 files changed, 100 insertions, 4 deletions
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
index 2d2fbdbba1..b4c33e8c6b 100644
--- a/net-p2p/ktorrent/Manifest
+++ b/net-p2p/ktorrent/Manifest
@@ -1,2 +1,4 @@
-EBUILD ktorrent-9999.ebuild 2670 RMD160 f8c36da1bff522f7a3c07553cf3f758ed995c506 SHA1 e3be15453da1b77ca3e14ed1432cfc6a1da1cd4e SHA256 bcad2a5e01734451d582cfaf3f42e310997a379c04199057f63df5df4ceea19a
+DIST ktorrent-4.0.2.tar.bz2 2819309 RMD160 e643e43a8958c032cabb5c29aa10bb31c46e7756 SHA1 40ee3b7b9face22d229344572f9542b4570e7411 SHA256 f2f3e659c16afb2f94f4be5f84d147b34592b2c39a1e5d3bb23462a631947c5d
+EBUILD ktorrent-4.0.2.ebuild 2760 RMD160 ec17b58be4a2d1ca7a239abca78324f269d46892 SHA1 4989644d8c40e0f6652ddfd7e4188ff7e573de8a SHA256 c15d3528df3a498d0dac8cc45c78197af4f13da03201b5ad5e2005481adbc832
+EBUILD ktorrent-9999.ebuild 2737 RMD160 46746be45bc34728be86a0c4dfcf81d91b956d75 SHA1 a5599bcb894d6405a9108321b9a185f3a7ffd234 SHA256 68debb3cd4b00c4b1ce85d629abd56eb02326d6c73b0f5f471ce264439674b14
MISC metadata.xml 1425 RMD160 57a8dc4f1f121a577f042faea242dcb4bada8f7a SHA1 85f5015342bc1ffbedc1da1171260c05ee6b4eb8 SHA256 589714ec7f93ed39929de5c133b7aa98714b4223298d98b7c0585e6263258c30
diff --git a/net-p2p/ktorrent/ktorrent-4.0.2.ebuild b/net-p2p/ktorrent/ktorrent-4.0.2.ebuild
new file mode 100644
index 0000000000..72e4a90882
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-4.0.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+if [[ ${PV} == *9999* ]] ; then
+ KMNAME="extragear/network"
+else
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ MY_P="${PN}-${MY_PV}"
+
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km lt lv mai ms nb nds nl nn oc
+ pl pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+fi
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
++magnetgenerator +mediaplayer plasma rss +scanfolder +search +shutdown +stats
++upnp webinterface +zeroconf"
+
+COMMONDEPEND="
+ >=net-libs/libktorrent-1.0_rc1
+ mediaplayer? ( >=media-libs/taglib-1.5 )
+ plasma? ( >=kde-base/libtaskmanager-${KDE_MINIMAL} )
+ rss? (
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ )
+ shutdown? (
+ >=kde-base/solid-${KDE_MINIMAL}
+ >=kde-base/libkworkspace-${KDE_MINIMAL}
+ )
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ >=kde-base/kdebase-kioslaves-${KDE_MINIMAL}
+ )
+ kross? ( >=kde-base/krosspython-${KDE_MINIMAL} )
+"
+
+src_prepare() {
+ if ! use plasma; then
+ sed -i \
+ -e "s:add_subdirectory(plasma):#nada:g" \
+ CMakeLists.txt || die "Failed to make plasmoid optional"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_DHT_SUPPORT=ON
+ -DWITH_SYSTEM_GEOIP=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable magnetgenerator MAGNETGENERATOR_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
+ )
+ kde4-base_src_configure
+}
diff --git a/net-p2p/ktorrent/ktorrent-9999.ebuild b/net-p2p/ktorrent/ktorrent-9999.ebuild
index d3a32d2692..bdbd0efeaf 100644
--- a/net-p2p/ktorrent/ktorrent-9999.ebuild
+++ b/net-p2p/ktorrent/ktorrent-9999.ebuild
@@ -11,9 +11,10 @@ else
MY_PV="${PV/_/}"
MY_P="${PN}-${MY_PV}"
- KDE_LINGUAS="ar be bg ca cs da de el en_GB es et eu fr ga gl hi hne hr hu is it
- ja km lt lv mai ms nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
- tr uk zh_CN zh_TW"
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km lt lv mai ms nb nds nl nn oc
+ pl pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
S="${WORKDIR}"/"${MY_P}"
fi