aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwired <wired@gentoo.org>2009-08-13 02:17:01 +0300
committerwired <wired@gentoo.org>2009-08-13 02:17:01 +0300
commitf68587f6a420b091e4c8faf959bcac8a93aaf32a (patch)
treeefce25dfed10748928f937efc8cebc14634891cc /net-p2p
parent[dev-libs/soprano] drop version which is in tree (diff)
downloadkde-f68587f6a420b091e4c8faf959bcac8a93aaf32a.tar.gz
kde-f68587f6a420b091e4c8faf959bcac8a93aaf32a.tar.bz2
kde-f68587f6a420b091e4c8faf959bcac8a93aaf32a.zip
[net-p2p/ktorrent] added new shutdown plugin use, added if for versioned ebuilds
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Manifest4
-rw-r--r--net-p2p/ktorrent/ktorrent-9999.ebuild31
-rw-r--r--net-p2p/ktorrent/metadata.xml1
3 files changed, 26 insertions, 10 deletions
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
index 43d4d8da5f..acc92249a2 100644
--- a/net-p2p/ktorrent/Manifest
+++ b/net-p2p/ktorrent/Manifest
@@ -1,2 +1,2 @@
-EBUILD ktorrent-9999.ebuild 2351 RMD160 98b9a957a82dad7e332e7bd7e6cee4bbcd79083d SHA1 71406742abb48a8062ddeff052c432c42b28ce47 SHA256 b24312d2b310baec843e94ef11f3a41d9a4ea9c2d7c172b2940379b62b30a9f9
-MISC metadata.xml 1316 RMD160 ebab5f7e686bc42aad936e4c0cc17e8102564502 SHA1 e78a5b62d7ac2181d4b6dd5f951f36442ccd841c SHA256 78fd475d8646e7a5fc595c768af448992a32e264d0dfa9b7ef33d7a5667c3652
+EBUILD ktorrent-9999.ebuild 2663 RMD160 cac1fcc02d7fc5146e9454655a4ec301c71fc664 SHA1 3ab97eff44375488dbb263a340b9a8521eff7de0 SHA256 2e9e609a8505e47ed6876c0b2f70b1ed74cf754938713dabaeb36367d3bf5f21
+MISC metadata.xml 1365 RMD160 db3a5ec0aa6a1fa18653ac4154221f075be220c7 SHA1 25dc5ef1520da4dbb48748e4244aae4292a023ed SHA256 19f892a388658ef43d2bf00a987d4df8a36092e2c10087197ae9926fc4058322
diff --git a/net-p2p/ktorrent/ktorrent-9999.ebuild b/net-p2p/ktorrent/ktorrent-9999.ebuild
index 290e294206..0fd4b173e1 100644
--- a/net-p2p/ktorrent/ktorrent-9999.ebuild
+++ b/net-p2p/ktorrent/ktorrent-9999.ebuild
@@ -4,20 +4,30 @@
EAPI="2"
-#KDE_LINGUAS="ar be bg ca cs da de el en_GB es et fr ga gl hi it ja
-# km lt lv nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
-# tr uk zh_CN zh_TW"
-KMNAME="extragear/network"
+if [[ ${PV} == "9999" ]] ; then
+ KEYWORDS=""
+ KMNAME="extragear/network"
+else
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ MY_P="${PN}-${MY_PV}"
+ KDE_LINGUAS="ar be bg ca cs da de el en_GB es et fr ga gl hi it ja
+ km lt lv nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
+ tr uk zh_CN zh_TW"
+ KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+ SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+fi
+
inherit kde4-base
DESCRIPTION="A BitTorrent program for KDE."
HOMEPAGE="http://ktorrent.org/"
-#SRC_URI="http://ktorrent.org/downloads/${PV}/${P}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS=""
SLOT="4"
-IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer +mediaplayer plasma rss +scanfolder +search +stats +upnp webinterface +zeroconf"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
++mediaplayer plasma rss +scanfolder +search +shutdown +stats +upnp webinterface +zeroconf"
COMMONDEPEND="
app-crypt/qca:2
@@ -35,7 +45,11 @@ DEPEND="${COMMONDEPEND}
RDEPEND="${COMMONDEPEND}
!kdeprefix? ( !net-p2p/ktorrent:0 )
infowidget? ( >=dev-libs/geoip-1.4.4 )
- ipfilter? ( >=kde-base/kdebase-kioslaves-${KDE_MINIMAL} )
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ >=kde-base/kdebase-kioslaves-${KDE_MINIMAL}
+ )
kross? ( >=kde-base/krosspython-${KDE_MINIMAL} )
"
@@ -64,6 +78,7 @@ src_configure() {
$(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
$(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
$(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
$(cmake-utils_use_enable stats STATS_PLUGIN)
$(cmake-utils_use_enable upnp UPNP_PLUGIN)
$(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
diff --git a/net-p2p/ktorrent/metadata.xml b/net-p2p/ktorrent/metadata.xml
index 7b991ca3b8..a0e3fd7a06 100644
--- a/net-p2p/ktorrent/metadata.xml
+++ b/net-p2p/ktorrent/metadata.xml
@@ -18,6 +18,7 @@
<flag name="rss">Syndication plugin for KTorrent, supporting RSS and Atom feeds</flag>
<flag name="scanfolder">Scan folders for torrent files and load them</flag>
<flag name="search">Search for torrents</flag>
+ <flag name="shutdown">Shutdown when done</flag>
<flag name="stats">Shows statistics about torrents in several graphs</flag>
<flag name="upnp">Forward ports using UPnP</flag>
<flag name="webinterface">Allows control of KTorrent via a web interface</flag>