aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-07 16:16:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-07 16:36:05 +0100
commit5e564243facc8aa263854c3079d2678e6d4acfbd (patch)
tree06245584d2e26f8266f28896bddfc688120cf7e2 /www-client
parentkde-apps/konqueror: 23.08.3 version bump (diff)
downloadkde-5e564243facc8aa263854c3079d2678e6d4acfbd.tar.gz
kde-5e564243facc8aa263854c3079d2678e6d4acfbd.tar.bz2
kde-5e564243facc8aa263854c3079d2678e6d4acfbd.zip
www-client/falkon: 23.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/falkon/Manifest1
-rw-r--r--www-client/falkon/falkon-23.08.3.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
new file mode 100644
index 0000000000..45b0bfdb23
--- /dev/null
+++ b/www-client/falkon/Manifest
@@ -0,0 +1 @@
+DIST falkon-23.08.3.tar.xz 2573748 BLAKE2B 4205809eae03b47da1510ff29e208f771879ae40488fd1bd814ff3425c49a50f6cfa30a8094c768922ca1392e439535f6b647e35236e580f13a1b57abfcca0ee SHA512 c83883e15e71206a8a42cacd50d8433efbe25e3d893005d97a1a333e8125fc5a4a54f51370cc9dfbe93101a592da84bcf79a6d8fb8131e317d34f6c31d62ab68
diff --git a/www-client/falkon/falkon-23.08.3.ebuild b/www-client/falkon/falkon-23.08.3.ebuild
new file mode 100644
index 0000000000..3928b72439
--- /dev/null
+++ b/www-client/falkon/falkon-23.08.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.106.0
+QTMIN=5.15.9
+PYTHON_COMPAT=( python3_{10..11} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.falkon.org/ https://apps.kde.org/falkon/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="dbus kde python +X"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="test" # bug 653046
+
+COMMON_DEPEND="
+ dev-libs/openssl:0=
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5[sqlite]
+ >=dev-qt/qtwebchannel-${QTMIN}:5
+ >=dev-qt/qtwebengine-${QTMIN}:5=[widgets]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ virtual/libintl
+ dbus? ( >=dev-qt/qtdbus-${QTMIN}:5 )
+ kde? (
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/purpose-${KFMIN}:5
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep "
+ >=dev-python/pyside2-${QTMIN}[designer,gui,webengine,widgets,\${PYTHON_USEDEP}] \
+ >=dev-python/shiboken2-${QTMIN}[\${PYTHON_USEDEP}]
+ ")
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ DEPEND+=" >=kde-frameworks/ki18n-${KFMIN}:5"
+fi
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtsvg-${QTMIN}:5
+"
+BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
+
+PATCHES=( "${FILESDIR}/${PN}-23.07.80-python3.patch" )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_KEYRING=OFF
+ -DDISABLE_DBUS=$(usex !dbus)
+ $(cmake_use_find_package kde KF5Wallet)
+ $(cmake_use_find_package kde KF5KIO)
+ -DBUILD_PYTHON_SUPPORT=$(usex python)
+ -DNO_X11=$(usex !X)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}" # shiboken_helpers.cmake quirk
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ ecm_src_configure
+}