summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2012-11-21 21:01:52 +0100
committerWim Muskee <wimmuskee@gmail.com>2012-11-21 21:01:52 +0100
commitfca71162b9c2cb2b2d14c558d77b7f92d31121aa (patch)
tree27edf4e535d1da991de80decfac018872e904ac9 /sys-apps/kicktoo/kicktoo-0.4.4-r2.ebuild
parentSome overlay maintanance. (diff)
downloadltsp-fca71162b9c2cb2b2d14c558d77b7f92d31121aa.tar.gz
ltsp-fca71162b9c2cb2b2d14c558d77b7f92d31121aa.tar.bz2
ltsp-fca71162b9c2cb2b2d14c558d77b7f92d31121aa.zip
kicktoo: release to stable 0.4.4-r2
Diffstat (limited to 'sys-apps/kicktoo/kicktoo-0.4.4-r2.ebuild')
-rw-r--r--sys-apps/kicktoo/kicktoo-0.4.4-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/kicktoo/kicktoo-0.4.4-r2.ebuild b/sys-apps/kicktoo/kicktoo-0.4.4-r2.ebuild
new file mode 100644
index 0000000..1e60be6
--- /dev/null
+++ b/sys-apps/kicktoo/kicktoo-0.4.4-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils git-2
+
+EGIT_REPO_URI="git://github.com/r1k0/kicktoo.git"
+
+EGIT_COMMIT="a49b8f0b0584a84bc17f2fb2816d48c2f06be6e5"
+DESCRIPTION="A Portage based installer/profiler for Gentoo/Funtoo (/Exherbo RIP)"
+HOMEPAGE="https://github.com/r1k0/kicktoo"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+# making the profiles optional, included by default
+# they are not required for the tool
+IUSE="crypt doc +examples server"
+RDEPEND="sys-block/parted
+ net-misc/curl
+ crypt? (
+ dev-libs/libgcrypt
+ dev-libs/popt
+ dev-libs/libgpg-error
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ )
+ server? (
+ dev-perl/HTTP-Daemon
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makeconf.patch"
+}
+
+src_install() {
+ ktdir=/usr/share/kicktoo
+
+ insinto ${ktdir}/modules
+ doins modules/*
+
+ dobin kicktoo
+
+ if use server; then
+ dobin daemon/kicktood
+
+ insinto /etc/kicktoo
+ doins daemon/kicktood.conf
+ fi
+
+ if use doc; then
+ dodoc README
+ dodoc TODO
+ newdoc profiles/config.txt profile-config.txt
+ fi
+
+ if use examples; then
+ insinto ${ktdir}/kbin
+ doins kbin/*
+ insinto ${ktdir}/kconfig
+ doins kconfig/*
+ insinto ${ktdir}/profiles
+ rm profiles/config.txt
+ doins -r profiles/*
+ fi
+}