aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/xulrunner/xulrunner-2.0.1.ebuild')
-rw-r--r--net-libs/xulrunner/xulrunner-2.0.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/xulrunner/xulrunner-2.0.1.ebuild b/net-libs/xulrunner/xulrunner-2.0.1.ebuild
index 7eb392e1..3e5fe5ca 100644
--- a/net-libs/xulrunner/xulrunner-2.0.1.ebuild
+++ b/net-libs/xulrunner/xulrunner-2.0.1.ebuild
@@ -28,6 +28,8 @@ REL_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases"
# More URIs appended below...
SRC_URI="http://dev.gentoo.org/~anarchy/mozilla/patchsets/${PATCH}.tar.bz2"
+ASM_DEPEND=">=dev-lang/yasm-1.1.0"
+
RDEPEND="
>=sys-devel/binutils-2.16.1
>=dev-libs/nss-3.12.9
@@ -38,12 +40,14 @@ RDEPEND="
media-libs/libpng[apng]
system-sqlite? ( >=dev-db/sqlite-3.7.4[fts3,secure-delete,unlock-notify,debug=] )
webm? ( media-libs/libvpx
- media-libs/alsa-lib )
+ media-libs/alsa-lib
+ media-libs/mesa )
!www-plugins/weave"
DEPEND="${RDEPEND}
dev-util/pkgconfig
- dev-lang/yasm"
+ amd64? ( ${ASM_DEPEND} )
+ x86? ( ${ASM_DEPEND} ) "
if [[ ${PV} =~ alpha|beta ]]; then
# hg snapshot tarball
@@ -136,6 +140,9 @@ src_configure() {
append-flags -fno-stack-protector
fi
+ # Ensure we do not fail on i{3,5,7} processors that support -mavx
+ append-flags -mno-avx
+
####################################
#
# Configure and build