aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>1999-03-25 11:40:23 +0000
committerPhil Blundell <philb@gnu.org>1999-03-25 11:40:23 +0000
commit3bacf06d3d34b5b40c667aba697b7cc62279cf7e (patch)
tree88d4a75a9f2216b74dc1da9d302e683eacfde77a
parentFix filename in error message. (diff)
downloadnet-tools-3bacf06d3d34b5b40c667aba697b7cc62279cf7e.tar.gz
net-tools-3bacf06d3d34b5b40c667aba697b7cc62279cf7e.tar.bz2
net-tools-3bacf06d3d34b5b40c667aba697b7cc62279cf7e.zip
From Philip Chong <pchong@r-491a.ihouse.berkeley.edu>
- don't try to install ipmaddr/iptunnel if they weren't built - make i18n-disabled builds work better
-rw-r--r--Makefile2
-rw-r--r--man/Makefile9
-rw-r--r--po/Makefile8
3 files changed, 17 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 5498d3f..5cd801d 100644
--- a/Makefile
+++ b/Makefile
@@ -215,8 +215,10 @@ installbin:
install -m 0755 hostname ${BASEDIR}/bin
install -m 0755 slattach $(BASEDIR)/sbin
install -m 0755 plipconfig $(BASEDIR)/sbin
+ifeq ($(HAVE_IP_TOOLS),1)
install -m 0755 ipmaddr $(BASEDIR)/sbin
install -m 0755 iptunnel $(BASEDIR)/sbin
+endif
ln -fs hostname $(BASEDIR)/bin/dnsdomainname
ln -fs hostname $(BASEDIR)/bin/ypdomainname
ln -fs hostname $(BASEDIR)/bin/nisdomainname
diff --git a/man/Makefile b/man/Makefile
index 6d76872..ebf04df 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -24,6 +24,13 @@
INSTALL=install
+-include ../config.make
+ifeq ($(I18N),1)
+LANGS=`ls -d * | grep -v Makefile`
+else
+LANGS=en_US
+endif
+
all:
clean:
@@ -33,7 +40,7 @@ clean:
clobber: clean
install:
- LANGS=`ls -d * | grep -v Makefile` ; \
+ LANGS=$(LANGS) ; \
for LANG in $$LANGS; do \
cd $$LANG; \
for SECTION in 1 5 8; do \
diff --git a/po/Makefile b/po/Makefile
index 8253c24..da58db5 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -7,7 +7,12 @@ TUPDATE = tupdate
NLSPACKAGE = net-tools
+-include ../config.make
+ifeq ($(I18N),1)
CATALOGS = de.mo pt_BR.mo
+else
+CATALOGS =
+endif
POTFILES=../arp.c ../hostname.c ../ifconfig.c ../netstat.c ../rarp.c \
../route.c ../plipconfig.c ../iptunnel.c ../statistics.c \
@@ -62,7 +67,8 @@ distclean: clean
depend:
install: $(CATALOGS)
- for n in $(CATALOGS); do \
+ catalogs='$(CATALOGS)'; \
+ for n in $$catalogs; do \
l=`basename $$n .mo`; \
$(INSTALL) -m 755 -d $(INSTALLNLSDIR)/$$l; \
$(INSTALL) -m 755 -d $(INSTALLNLSDIR)/$$l/LC_MESSAGES; \