aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndi Kleen <andi@firstfloor.org>2000-10-18 17:27:08 +0000
committerAndi Kleen <andi@firstfloor.org>2000-10-18 17:27:08 +0000
commit7e8833ee19b78e75ebcc72bd4d8ed3a885171959 (patch)
tree068fae9f276612fd4c4961558f8d53eea33eae25 /Makefile
parentAdd nameif, a small tool for logical network interface naming. (diff)
downloadnet-tools-7e8833ee19b78e75ebcc72bd4d8ed3a885171959.tar.gz
net-tools-7e8833ee19b78e75ebcc72bd4d8ed3a885171959.tar.bz2
net-tools-7e8833ee19b78e75ebcc72bd4d8ed3a885171959.zip
Also add nameif to the Makefile.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8700608..a12d216 100644
--- a/Makefile
+++ b/Makefile
@@ -76,7 +76,7 @@
NET_LIB_PATH = lib
NET_LIB_NAME = net-tools
-PROGS := ifconfig hostname arp netstat route rarp slattach plipconfig
+PROGS := ifconfig hostname arp netstat route rarp slattach plipconfig nameif
-include config.make
ifeq ($(HAVE_IP_TOOLS),1)
@@ -186,6 +186,9 @@ subdirs:
ifconfig: $(NET_LIB) ifconfig.o
$(CC) $(LDFLAGS) -o ifconfig ifconfig.o $(NLIB) $(RESLIB)
+
+nameif: nameif.o
+ $(CC) $(LDFLAGS) -o nameif nameif.o
hostname: hostname.o
$(CC) $(LDFLAGS) -o hostname hostname.o $(DNLIB)