aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>1998-03-02 22:02:22 +0000
committerPhil Blundell <philb@gnu.org>1998-03-02 22:02:22 +0000
commitb612eddf20531cb51380746df765055b89092f38 (patch)
treee4ff00c4f0cc6b74b48a817dde782e03726cfdc2 /Makefile
parentMerge more changes from my private tree, mostly ifconfig tidyups. (diff)
downloadnet-tools-b612eddf20531cb51380746df765055b89092f38.tar.gz
net-tools-b612eddf20531cb51380746df765055b89092f38.tar.bz2
net-tools-b612eddf20531cb51380746df765055b89092f38.zip
Update for new kernel, plus more changes.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 14911af..13ab7c7 100644
--- a/Makefile
+++ b/Makefile
@@ -172,8 +172,8 @@ nlsdir:
subdirs:
@for i in $(SUBDIRS); do $(MAKE) -C $$i $(MDEFINES) ; done
-ifconfig: $(NET-LIB) ifconfig.o
- $(CC) $(LDFLAGS) -o ifconfig ifconfig.o $(NLIB) $(RESLIB)
+ifconfig: $(NET-LIB) ifconfig.o interface.o sockets.o
+ $(CC) $(LDFLAGS) -o ifconfig ifconfig.o interface.o sockets.o $(NLIB) $(RESLIB)
hostname: hostname.o
$(CC) $(LDFLAGS) -o hostname hostname.o
@@ -187,8 +187,8 @@ arp: $(NET-LIB) arp.o
rarp: $(NET-LIB) rarp.o
$(CC) $(LDFLAGS) -o rarp rarp.o $(NLIB)
-netstat: $(NET-LIB) netstat.o statistics.o
- $(CC) $(LDFLAGS) -o netstat netstat.o statistics.o $(NLIB) $(RESLIB)
+netstat: $(NET-LIB) netstat.o statistics.o interface.o sockets.o
+ $(CC) $(LDFLAGS) -o netstat netstat.o statistics.o interface.o sockets.o $(NLIB) $(RESLIB)
installbin:
install -o root -g root -m 0755 arp ${BASEDIR}/sbin