aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile6
-rw-r--r--po/Makefile5
2 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1065945..798509d 100644
--- a/Makefile
+++ b/Makefile
@@ -154,8 +154,12 @@ clobber: clean
dist: clobber
+ @$(MAKE) -C po $@
@echo Creating net-tools-$(RELEASE) in ..
- @tar -cvz -f ../net-tools-$(RELEASE).tar.gz -C .. net-tools
+ @tar -cvz -f ../net-tools-$(RELEASE).tar.gz . \
+ --transform='s,^[.],net-tools-$(RELEASE),' \
+ --exclude=CVS --exclude=.cvsignore \
+ --exclude='.git*'
config.h: config.in Makefile
diff --git a/po/Makefile b/po/Makefile
index 155fdbb..25cf972 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -8,8 +8,9 @@ TUPDATE = msgmerge
NLSPACKAGE = net-tools
-include ../config.make
+ALL_CATALOGS = de.mo fr.mo pt_BR.mo et_EE.mo cs.mo
ifeq ($(I18N),1)
-CATALOGS = de.mo fr.mo pt_BR.mo et_EE.mo cs.mo
+CATALOGS = $(ALL_CATALOGS)
else
CATALOGS =
endif
@@ -61,6 +62,8 @@ update-po: Makefile
clean:
rm -f *mo
+dist: $(ALL_CATALOGS)
+
distclean: clean
rm -f .depend Makefile