aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--README2
-rw-r--r--ifconfig.c6
3 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 4b593a8..abbeaa9 100644
--- a/Makefile
+++ b/Makefile
@@ -101,7 +101,7 @@ endif
# -------- end of user definitions --------
MAINTAINER = Philip.Blundell@pobox.com
-RELEASE = 1.58
+RELEASE = 1.59
.EXPORT_ALL_VARIABLES:
diff --git a/README b/README
index be63692..c2848e3 100644
--- a/README
+++ b/README
@@ -32,7 +32,7 @@ Contents:
Notes
-----
-This is net-tools 1.58.
+This is net-tools 1.59.
You need kernel 2.0 or later to use these programs. These programs
should compile cleanly with both glibc (version 2.0 or 2.1) and libc5,
diff --git a/ifconfig.c b/ifconfig.c
index fc83bbd..74b9e9c 100644
--- a/ifconfig.c
+++ b/ifconfig.c
@@ -3,7 +3,7 @@
* that either displays or sets the characteristics of
* one or more of the system's networking interfaces.
*
- * Version: $Id: ifconfig.c,v 1.43 2000/10/26 03:19:06 ak Exp $
+ * Version: $Id: ifconfig.c,v 1.44 2001/02/12 21:06:47 pb Exp $
*
* Author: Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
* and others. Copyright 1993 MicroWalt Corporation
@@ -312,13 +312,13 @@ int main(int argc, char **argv)
else
ap = get_aftype(DFLT_AF);
- if(ap) {
+ if (ap) {
addr_family = ap->af;
if ((fd=sockets_open(addr_family)) < 0) {
perror("family socket");
exit(1);
} else {
- if (skfd) close(skfd);
+ if (skfd > 0 && skfd != fd) close(skfd);
skfd = fd;
}
}