aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile18
-rw-r--r--man/Makefile7
2 files changed, 13 insertions, 12 deletions
diff --git a/Makefile b/Makefile
index af443f6..204359f 100644
--- a/Makefile
+++ b/Makefile
@@ -87,7 +87,7 @@ RESLIB = # -L/usr/inet6/lib -linet6
# -------- end of user definitions --------
MAINTAINER = Philip.Blundell@pobox.com
-RELEASE = 981118
+RELEASE = 1.48
.EXPORT_ALL_VARIABLES:
@@ -183,14 +183,14 @@ netstat: $(NET-LIB) netstat.o statistics.o interface.o sockets.o
$(CC) $(LDFLAGS) -o netstat netstat.o statistics.o interface.o sockets.o $(NLIB) $(RESLIB)
installbin:
- install -o 0 -g 0 -m 0755 -d ${BASEDIR}/sbin
- install -o 0 -g 0 -m 0755 -d ${BASEDIR}/bin
- install -o 0 -g 0 -m 0755 arp ${BASEDIR}/sbin
- install -o 0 -g 0 -m 0755 ifconfig ${BASEDIR}/sbin
- install -o 0 -g 0 -m 0755 netstat ${BASEDIR}/bin
- install -o 0 -g 0 -m 0755 rarp ${BASEDIR}/sbin
- install -o 0 -g 0 -m 0755 route ${BASEDIR}/sbin
- install -o 0 -g 0 -m 0755 hostname ${BASEDIR}/bin
+ install -m 0755 -d ${BASEDIR}/sbin
+ install -m 0755 -d ${BASEDIR}/bin
+ install -m 0755 arp ${BASEDIR}/sbin
+ install -m 0755 ifconfig ${BASEDIR}/sbin
+ install -m 0755 netstat ${BASEDIR}/bin
+ install -m 0755 rarp ${BASEDIR}/sbin
+ install -m 0755 route ${BASEDIR}/sbin
+ install -m 0755 hostname ${BASEDIR}/bin
ln -fs hostname $(BASEDIR)/bin/dnsdomainname
ln -fs hostname $(BASEDIR)/bin/ypdomainname
ln -fs hostname $(BASEDIR)/bin/nisdomainname
diff --git a/man/Makefile b/man/Makefile
index e4ec7cd..6d76872 100644
--- a/man/Makefile
+++ b/man/Makefile
@@ -36,16 +36,17 @@ install:
LANGS=`ls -d * | grep -v Makefile` ; \
for LANG in $$LANGS; do \
cd $$LANG; \
- for SECTION in 1 8; do \
+ for SECTION in 1 5 8; do \
if [ "$$LANG" = "en_US" ] ; then \
MAN_DIR=${BASEDIR}/usr/man/man$$SECTION; \
else \
MAN_DIR=${BASEDIR}/usr/man/$$LANG/man$$SECTION; \
fi ; \
- $(INSTALL) -d -m 755 -o 0 -g 0 $$MAN_DIR; \
CMDS=`ls *.$$SECTION`; \
+ [ -z "$$CMDS" ] && continue; \
+ $(INSTALL) -d -m 755 $$MAN_DIR; \
for CMD in $$CMDS; do \
- $(INSTALL) -m 644 -o 0 -g 0 $$CMD $$MAN_DIR; \
+ $(INSTALL) -m 644 $$CMD $$MAN_DIR; \
done; \
done; \
cd ..; \