summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild')
-rw-r--r--net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild b/net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild
new file mode 100644
index 0000000..8251104
--- /dev/null
+++ b/net-wireless/tiwlan-wl1271/tiwlan-wl1271-0.24.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/zd1211-firmware/zd1211-firmware-1.4.ebuild,v 1.2 2007/11/03 12:03:19 dsd Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Texas Instruments WiLinkTM solution (WL1271) applications"
+HOMEPAGE="https://gforge.ti.com/gf/project/wilink_drivers/"
+BASE_URI="https://launchpad.net/~tiomap-dev/+archive/release/+files"
+SRC_URI="${BASE_URI}/${MY_P}.orig.tar.gz"
+SRC_URI="${SRC_URI} ${BASE_URI}/${MY_P}-0ubuntu6.diff.gz"
+
+
+
+LICENSE="TI-TSPA-v1"
+SLOT="0"
+KEYWORDS="arm"
+
+IUSE=""
+RDEPEND="net-wireless/tiwlan-wl1271-firmware"
+DEPEND="${RDEPEND}"
+
+
+src_prepare() {
+ cd ${WORKDIR}
+
+ epatch ${MY_P}*.diff
+ cd "${S}"
+ epatch "${S}"/debian/patches/*.patch
+}
+
+src_compile() {
+# cd "${S}"
+ make -j1
+}
+
+src_install() {
+# cd "${S}"
+ insinto /etc/udev/rules.d/
+ newins debian/tiwlan-wl1271-dkms.udev 40-tiwlan-wl1271.rules
+
+ cd wlan/CUDK/output/
+ newbin tiwlan_loader tiwlan_loader_wl1271
+ newbin wlan_cu wlan_cu_wl1271
+ cd ../../platforms/os/linux/
+ insinto /lib/firmware/tiwlan-wl1271
+ doins tiwlan.ini tiwlan_dual.ini
+
+
+}