summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <christian@faulhammer.org>2008-03-15 15:18:01 +0100
committerCiaran McCreesh <ciaran.mccreesh@googlemail.com>2008-03-16 03:43:32 +0000
commit9e41e12724aa8209f6e1dfd955af4b9b305aa349 (patch)
tree5374ebd31246c7df0e8a35d8a6b1ae2210b9f65a
parentThose chardef commands where there to make it possible entering \, { and } wi... (diff)
downloadpms-9e41e12724aa8209f6e1dfd955af4b9b305aa349.tar.gz
pms-9e41e12724aa8209f6e1dfd955af4b9b305aa349.tar.bz2
pms-9e41e12724aa8209f6e1dfd955af4b9b305aa349.zip
exchange bulletlist with compactitem in all files
-rw-r--r--appendices.tex4
-rw-r--r--dependencies.tex16
-rw-r--r--ebuild-env-commands.tex8
-rw-r--r--ebuild-env-invariancy.tex8
-rw-r--r--ebuild-functions.tex16
-rw-r--r--eclasses.tex4
-rw-r--r--names.tex4
-rw-r--r--pms.tex3
-rw-r--r--profile-variables.tex4
-rw-r--r--profiles.tex4
-rw-r--r--tree-layout.tex12
11 files changed, 40 insertions, 43 deletions
diff --git a/appendices.tex b/appendices.tex
index bc5bb9a..d7e9e93 100644
--- a/appendices.tex
+++ b/appendices.tex
@@ -13,7 +13,7 @@ The following items are not specified by this document, and must not be relied u
This is, of course, an incomplete list---it covers only the things that the authors know have
been abused in the past.
-\begin{bulletlist}
+\begin{compactitem}
\item The \t{FEATURES} variable. This is Portage specific.
\item Similarly, any \t{PORTAGE\_} variable not explicitly listed.
\item Any Portage configuration file.
@@ -24,6 +24,6 @@ been abused in the past.
\item The \t{emerge} command.
\item Binary packages.
\item The \t{PORTDIR\_OVERLAY} variable, and overlay behaviour in general.
-\end{bulletlist}
+\end{compactitem}
% vim: set filetype=tex fileencoding=utf8 et tw=100 spell spelllang=en :
diff --git a/dependencies.tex b/dependencies.tex
index 236cc6d..2075188 100644
--- a/dependencies.tex
+++ b/dependencies.tex
@@ -5,13 +5,13 @@
There are three classes of dependencies supported by ebuilds:
-\begin{bulletlist}
+\begin{compactitem}
\item Build dependencies (\t{DEPEND}). These must be installed before the ebuild is installed.
\item Runtime dependencies (\t{RDEPEND}). These should usually be installed before the ebuild,
but may be dropped to post dependencies where necessary to resolve cycles.
\item Post dependencies (\t{PDEPEND}). These should be installed at some point, usually after
the ebuild if they are not already installed.
-\end{bulletlist}
+\end{compactitem}
In addition, \t{SRC\_URI}, \t{HOMEPAGE}, \t{PROVIDE} and \t{LICENSE} use dependency-style
specifications to specify their values.
@@ -21,7 +21,7 @@ specifications to specify their values.
The following elements are recognised in at least one class of specification. All elements must
be surrounded on both sides by whitespace, except at the start and end of the string.
-\begin{bulletlist}
+\begin{compactitem}
\item A package dependency specification. Permitted in \t{DEPEND}, \t{RDEPEND}, \t{PDEPEND}.
\item A simple qualified package name. Permitted in \t{PROVIDE} (and inside \t{DEPEND} etc
via the previous item).
@@ -44,7 +44,7 @@ be surrounded on both sides by whitespace, except at the start and end of the st
of any kind followed by whitespace), followed by a close parenthesis. More formally:
\t{use-conditional ::= '!'? flag-name '?' whitespace '(' whitespace (item whitespace)* ')'}.
Permitted in all specification style variables.
-\end{bulletlist}
+\end{compactitem}
In particular, note that whitespace is not optional.
@@ -53,11 +53,11 @@ In particular, note that whitespace is not optional.
A package dependency can be in one of the following base formats. A package manager must warn or
error on non-compliant input.
-\begin{bulletlist}
+\begin{compactitem}
\item A simple \t{category/package} name.
\item An operator, followed immediately by \t{category/package}, followed by a hyphen,
followed by a version specification.
-\end{bulletlist}
+\end{compactitem}
In EAPI 1, either of the above formats may additionally be suffixed by a \t{:slot}
restriction. A package manager must warn or error if slot dependencies are used with EAPI 0.
@@ -82,10 +82,10 @@ If the specification is prefixed with an exclamation mark, the named dependency
than a requirement---that is to say, the specified package must not be installed, except with the
following exceptions:
-\begin{bulletlist}
+\begin{compactitem}
\item Blocks on a package provided by the ebuild do not count. \label{provided-blocks}
\item Blocks on the ebuild itself do not count.
-\end{bulletlist}
+\end{compactitem}
\subsection{All-of Dependency Specifications}
diff --git a/ebuild-env-commands.tex b/ebuild-env-commands.tex
index 8a75ec7..1faf1ff 100644
--- a/ebuild-env-commands.tex
+++ b/ebuild-env-commands.tex
@@ -22,23 +22,23 @@ dependencies must be used to ensure their presence.
\label{guaranteed-system-commands}
The following commands must always be available in the ebuild environment:
-\begin{bulletlist}
+\begin{compactitem}
\item All builtin commands in GNU bash, version 3.0.
\item \t{sed} must be available, and must support all forms of invocations valid for GNU sed
version 4 or later.
\item \t{patch} must be available, and must support all inputs valid for GNU patch.
-\end{bulletlist}
+\end{compactitem}
\subsection{Commands provided by package dependencies}
In some cases a package's build process will require the availability of executables not provided by
the core system, a common example being autotools. Commands provided by dependencies are available
in the following cases:
-\begin{bulletlist}
+\begin{compactitem}
\item In the \t{src} phases, any command provided by a package listed in \t{DEPEND} is available.
\item In the \t{pkg} phases, commands provided by a package listed in both \t{DEPEND} \b{and} \t{RDEPEND} are
available, unless the package being merged is part of a circular dependency loop.
-\end{bulletlist}
+\end{compactitem}
\subsection{Ebuild-specific Commands}
\input{pkg-mgr-commands.tex}
diff --git a/ebuild-env-invariancy.tex b/ebuild-env-invariancy.tex
index 76d7a73..3871dd4 100644
--- a/ebuild-env-invariancy.tex
+++ b/ebuild-env-invariancy.tex
@@ -3,7 +3,7 @@
For the sake of this section:
-\begin{bulletlist}
+\begin{compactitem}
\item Variancy is any package manager action that modifies either
\t{ROOT} or \t{/} in any way that isn't merely a simple addition of
something that doesn't alter other packages. This includes any
@@ -12,11 +12,11 @@ For the sake of this section:
\item As an exception, changes to \t{DISTDIR} do not count as variancy.
\item The \t{pkg\_setup} function may be assumed not to introduce variancy.
Thus, ebuilds must not perform variant actions in this phase.
-\end{bulletlist}
+\end{compactitem}
The following exclusivity and invariancy requirements are mandated:
-\begin{bulletlist}
+\begin{compactitem}
\item No variancy shall be introduced at any point between a package's
\t{pkg\_setup} being started up to the point that that package is
merged, except for any variancy introduced by that package.
@@ -26,7 +26,7 @@ The following exclusivity and invariancy requirements are mandated:
\item Any non-default \t{pkg} phase function must be run exclusively.
\item Each phase function must be called at most once during the build
process for any given package.
-\end{bulletlist}
+\end{compactitem}
% vim: set filetype=tex fileencoding=utf8 et tw=100 spell spelllang=en :
diff --git a/ebuild-functions.tex b/ebuild-functions.tex
index 3b3ba7c..3fd7c69 100644
--- a/ebuild-functions.tex
+++ b/ebuild-functions.tex
@@ -174,7 +174,7 @@ source files from their respective locations, with notes concerning licensing if
The call order for installing a package is:
-\begin{bulletlist}
+\begin{compactitem}
\item \t{pkg\_setup}
\item \t{src\_unpack}
\item \t{src\_compile}
@@ -182,18 +182,18 @@ The call order for installing a package is:
\item \t{src\_install}
\item \t{pkg\_preinst}
\item \t{pkg\_postinst}
-\end{bulletlist}
+\end{compactitem}
The call order for uninstalling a package is:
-\begin{bulletlist}
+\begin{compactitem}
\item \t{pkg\_prerm}
\item \t{pkg\_postrm}
-\end{bulletlist}
+\end{compactitem}
The call order for reinstalling a package is:
-\begin{bulletlist}
+\begin{compactitem}
\item \t{pkg\_setup}
\item \t{src\_unpack}
\item \t{src\_compile}
@@ -203,11 +203,11 @@ The call order for reinstalling a package is:
\item \t{pkg\_prerm} for the package being replaced
\item \t{pkg\_postrm} for the package being replaced
\item \t{pkg\_postinst}
-\end{bulletlist}
+\end{compactitem}
The call order for upgrading or downgrading a package is:
-\begin{bulletlist}
+\begin{compactitem}
\item \t{pkg\_setup}
\item \t{src\_unpack}
\item \t{src\_compile}
@@ -217,7 +217,7 @@ The call order for upgrading or downgrading a package is:
\item \t{pkg\_postinst}
\item \t{pkg\_prerm} for the package being replaced
\item \t{pkg\_postrm} for the package being replaced
-\end{bulletlist}
+\end{compactitem}
The \t{pkg\_config}, \t{pkg\_info} and \t{pkg\_nofetch} functions are not called in a normal
sequence.
diff --git a/eclasses.tex b/eclasses.tex
index 14122b7..8e83067 100644
--- a/eclasses.tex
+++ b/eclasses.tex
@@ -25,11 +25,11 @@ Eclasses may end up being sourced multiple times.
The \t{inherit} command must also ensure that:
-\begin{bulletlist}
+\begin{compactitem}
\item The \t{ECLASS} variable is set to the name of the current eclass, when sourcing that eclass.
\item Once all inheriting has been done, the \t{INHERITED} metadata variable contains the name of
every eclass used, separated by whitespace.
-\end{bulletlist}
+\end{compactitem}
\section{Eclass-defined Metadata Keys}
diff --git a/names.tex b/names.tex
index 5be361e..dfcaf0c 100644
--- a/names.tex
+++ b/names.tex
@@ -77,13 +77,13 @@ The first component of the number part is compared using strict integer comparis
Any subsequent components of the number part are compared as follows:
-\begin{bulletlist}
+\begin{compactitem}
\item If neither component has a leading zero, components are compared using strict integer
comparison.
\item Otherwise, if a component has a leading zero, any trailing zeroes in that component
are stripped (if this makes the component empty, proceed as if it were \t{0} instead),
and the components are compared using a stringwise comparison.
-\end{bulletlist}
+\end{compactitem}
Note in particular that \t{1.0} is less than \t{1.0.0}.
diff --git a/pms.tex b/pms.tex
index aa2f668..cdbdeb2 100644
--- a/pms.tex
+++ b/pms.tex
@@ -34,9 +34,6 @@
\newcommand{\note}[1]{\paragraph{Note:} #1}
\newcommand{\TODOBUG}[2]{\fixme[inline]{(discussion on bug \##1) #2}}
\newcommand{\TODO}[1]{\fixme[inline]{#1}}
-\newenvironment{bulletlist}%
- {\begin{compactitem}}%
- {\end{compactitem}}
\hypersetup{%
urlcolor=black,
diff --git a/profile-variables.tex b/profile-variables.tex
index dc41f7e..ddbac76 100644
--- a/profile-variables.tex
+++ b/profile-variables.tex
@@ -12,14 +12,14 @@ tokens whose value is equal to $T$ with the hyphen removed, or, if $T$ is equal
all previous values. Note that because of this treatment, the order of tokens in the final result is
arbitrary, not necessarily related to the order of tokens in any given profile. The following
variables must be treated in this fashion:
-\begin{bulletlist}
+\begin{compactitem}
\item \t{USE}
\item \t{USE\_EXPAND}
\item \t{USE\_EXPAND\_HIDDEN}
\item \t{CONFIG\_PROTECT}
\item \t{CONFIG\_PROTECT\_MASK}
\item Any variable whose name is listed in \t{USE\_EXPAND}
-\end{bulletlist}
+\end{compactitem}
Other variables, except where they affect only package-manager-specific functionality (such as
Portage's \t{FEATURES} variable), must not be treated incrementally---later definitions shall
diff --git a/profiles.tex b/profiles.tex
index 1113438..5a976a1 100644
--- a/profiles.tex
+++ b/profiles.tex
@@ -45,13 +45,13 @@ entry, where the value must be double quoted. A variable name must start with on
and may contain \t{a-zA-Z0-9\_-}. Additional syntax, which is a small subset of
bash syntax, is allowed as follows:
-\begin{bulletlist}
+\begin{compactitem}
\item Variables to the right of the equals sign in the form \t{\$\{foo\}} or \t{\$foo} are recognised and
expanded from variables previously set in this or earlier \t{make.defaults} files.
\item One logical line may be continued over multiple physical lines by escaping the newline with a
backslash. This is also permitted inside quoted strings.
\item Backslashes, except for line continuations, are not allowed.
-\end{bulletlist}
+\end{compactitem}
\subsection{virtuals}
\label{profiles-virtuals}
diff --git a/tree-layout.tex b/tree-layout.tex
index d22983e..3e36426 100644
--- a/tree-layout.tex
+++ b/tree-layout.tex
@@ -8,7 +8,7 @@ differently from normal.
\section{Top Level}
An ebuild repository shall occupy one directory on disk, with the following subdirectories:
-\begin{bulletlist}
+\begin{compactitem}
\item One directory per category, whose name shall be the name of the category. The layout of
these directories shall be as described in section \ref{category-dirs}.
\item A \t{profiles} directory, described in section \ref{profiles-dir}.
@@ -19,7 +19,7 @@ An ebuild repository shall occupy one directory on disk, with the following subd
for example) may exist but are not covered by this specification. The package manager must
ignore any of these files or directories that it does not recognise.
-\end{bulletlist}
+\end{compactitem}
\section{Category Directories}
\label{category-dirs}
@@ -27,11 +27,11 @@ An ebuild repository shall occupy one directory on disk, with the following subd
Each category provided by the repository (see also: the \t{profiles/categories} file, section
\ref{profiles-categories}) shall be contained in one directory, whose name shall be that of the
category. Each category directory shall contain:
-\begin{bulletlist}
+\begin{compactitem}
\item A \t{metadata.xml} file, as described in appendix \ref{metadata-xml}\@. Optional.
\item Zero or more package directories, one for each package in the category, as described in section
\ref{package-dirs}. The name of the package directory shall be the corresponding package name.
-\end{bulletlist}
+\end{compactitem}
Category directories may contain additional files, whose purpose is not covered by this
specification. Additional directories that are not for a package may \i{not} be present, to avoid
@@ -46,14 +46,14 @@ a category that does not exist).
\label{package-dirs}
A package directory contains the following:
-\begin{bulletlist}
+\begin{compactitem}
\item One or more ebuilds. These are as described in section \ref{ebuild-format} and others.
\item A \t{metadata.xml} file, as described in appendix \ref{metadata-xml}\@. Optional only for
legacy support.
\item A \t{ChangeLog}, in a format determined by the provider of the respository. Optional.
\item A \t{Manifest} file, whose format is described in \cite{Glep44}.
\item A \t{files} directory, containing any support files needed by the ebuilds. Optional.
-\end{bulletlist}
+\end{compactitem}
Any ebuild in a package directory must be named \t{name-ver.ebuild}, where \t{name} is the
(unqualified) package name, and \t{ver} is the package's version. Package managers must ignore