aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-09-28 19:52:16 +0200
committerFabian Groffen <grobian@gentoo.org>2014-09-28 19:52:16 +0200
commit990c5f4896b309fdcaf1dbbb5779177ecfcf6e74 (patch)
treef54ebb8d5bcbfea1986b9c73eee0ec3c5b390577 /bin/clean_locks
parentinstall_qa_check_macho: introduce QA_IGNORE_INSTALL_NAME_FILES (diff)
parentUse a single grep call for gcc warning checks (diff)
downloadportage-990c5f4896b309fdcaf1dbbb5779177ecfcf6e74.tar.gz
portage-990c5f4896b309fdcaf1dbbb5779177ecfcf6e74.tar.bz2
portage-990c5f4896b309fdcaf1dbbb5779177ecfcf6e74.zip
Merge remote-tracking branch 'overlays-gentoo-org/master' into prefix
Conflicts: bin/ebuild-helpers/emake bin/misc-functions.sh bin/portageq doc/Makefile pym/_emerge/EbuildBuild.py pym/portage/const.py pym/portage/dbapi/vartree.py pym/portage/package/ebuild/doebuild.py
Diffstat (limited to 'bin/clean_locks')
-rwxr-xr-xbin/clean_locks4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/clean_locks b/bin/clean_locks
index 73213b52b..d44162075 100755
--- a/bin/clean_locks
+++ b/bin/clean_locks
@@ -6,8 +6,8 @@ from __future__ import print_function
import sys, errno
from os import path as osp
-pym_path = osp.join(osp.dirname(osp.dirname(osp.realpath(__file__))), "pym")
-sys.path.insert(0, pym_path)
+if osp.isfile(osp.join(osp.dirname(osp.dirname(osp.realpath(__file__))), ".portage_not_installed")):
+ sys.path.insert(0, osp.join(osp.dirname(osp.dirname(osp.realpath(__file__))), "pym"))
import portage
portage._internal_caller = True