aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2015-12-02 02:16:34 +0100
committerArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2015-12-02 02:16:34 +0100
commit48c2af4538d581fb2225c0ac9620b7fcfe4eae2e (patch)
treefd4a8194651f03b719bf30c8dba7aa8b9c2d9660 /pym/portage/tests/ebuild/test_ipc_daemon.py
parentportage.package.ebuild.fetch.fetch(): Clean setting of variables. (diff)
downloadportage-48c2af4538d581fb2225c0ac9620b7fcfe4eae2e.tar.gz
portage-48c2af4538d581fb2225c0ac9620b7fcfe4eae2e.tar.bz2
portage-48c2af4538d581fb2225c0ac9620b7fcfe4eae2e.zip
Respect PYTHONDONTWRITEBYTECODE in test suite.
Diffstat (limited to 'pym/portage/tests/ebuild/test_ipc_daemon.py')
-rw-r--r--pym/portage/tests/ebuild/test_ipc_daemon.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/pym/portage/tests/ebuild/test_ipc_daemon.py b/pym/portage/tests/ebuild/test_ipc_daemon.py
index a87107625..835f51f80 100644
--- a/pym/portage/tests/ebuild/test_ipc_daemon.py
+++ b/pym/portage/tests/ebuild/test_ipc_daemon.py
@@ -1,4 +1,4 @@
-# Copyright 2010-2012 Gentoo Foundation
+# Copyright 2010-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
import tempfile
@@ -51,6 +51,7 @@ class IpcDaemonTestCase(TestCase):
env['PORTAGE_BIN_PATH'] = PORTAGE_BIN_PATH
env['PORTAGE_PYM_PATH'] = PORTAGE_PYM_PATH
env['PORTAGE_BUILDDIR'] = os.path.join(tmpdir, 'cat', 'pkg-1')
+ env['PYTHONDONTWRITEBYTECODE'] = os.environ.get('PYTHONDONTWRITEBYTECODE', '')
if "__PORTAGE_TEST_HARDLINK_LOCKS" in os.environ:
env["__PORTAGE_TEST_HARDLINK_LOCKS"] = \