aboutsummaryrefslogtreecommitdiff
path: root/pym
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2012-02-17 14:16:59 -0800
committerZac Medico <zmedico@gentoo.org>2012-02-17 14:16:59 -0800
commitd6081e461bc6d14fb8d63e6346fdfda7fc0cc188 (patch)
tree20f7e5ecc12c4d9aeb62afc40ff197ee4eb70a3e /pym
parentportage.package.ebuild.fetch.fetch(): Fix ResourceWarning with Python 3.2. (diff)
downloadportage-d6081e461bc6d14fb8d63e6346fdfda7fc0cc188.tar.gz
portage-d6081e461bc6d14fb8d63e6346fdfda7fc0cc188.tar.bz2
portage-d6081e461bc6d14fb8d63e6346fdfda7fc0cc188.zip
EventLoop: fix _io_handler_class "f" attribute
Diffstat (limited to 'pym')
-rw-r--r--pym/portage/util/_eventloop/EventLoop.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/pym/portage/util/_eventloop/EventLoop.py b/pym/portage/util/_eventloop/EventLoop.py
index 475a4a9c6..9e4ac28a2 100644
--- a/pym/portage/util/_eventloop/EventLoop.py
+++ b/pym/portage/util/_eventloop/EventLoop.py
@@ -30,7 +30,7 @@ class EventLoop(object):
__slots__ = ("args", "callback", "calling", "source_id")
class _io_handler_class(SlotObject):
- __slots__ = ("args", "callback", "fd", "source_id")
+ __slots__ = ("args", "callback", "f", "source_id")
class _timeout_handler_class(SlotObject):
__slots__ = ("args", "function", "calling", "interval", "source_id",