aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-09 09:54:37 +0200
committerBrian Dolbec <dolsen@gentoo.org>2014-09-11 16:44:25 -0700
commit9fd70e67f3bc1ddae84b6097c5b651cce713b91a (patch)
tree7a2a658f691e3de7c447e00afbcea5046b0eb0a3 /runtests.sh
parentportage.const: Make PORTAGE_PYM_PATH point to the real package tree (diff)
downloadportage-9fd70e67f3bc1ddae84b6097c5b651cce713b91a.tar.gz
portage-9fd70e67f3bc1ddae84b6097c5b651cce713b91a.tar.bz2
portage-9fd70e67f3bc1ddae84b6097c5b651cce713b91a.zip
tests: Append .py to files that need to be installed
Append .py to the runTests script and __test__ files so that they could be easily picked up by setup.py.
Diffstat (limited to 'runtests.sh')
-rwxr-xr-xruntests.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/runtests.sh b/runtests.sh
index 7999220b9..599727b20 100755
--- a/runtests.sh
+++ b/runtests.sh
@@ -67,7 +67,7 @@ for version in ${PYTHON_VERSIONS}; do
fi
if [[ -x "${executable}" ]]; then
echo -e "${GOOD}Testing with Python ${version}...${NORMAL}"
- "${executable}" -b -Wd pym/portage/tests/runTests "$@"
+ "${executable}" -b -Wd pym/portage/tests/runTests.py "$@"
status=$?
status_array[${#status_array[@]}]=${status}
found_versions[${#found_versions[@]}]=${version}