aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-08-14 19:39:48 -0500
committerSam James <sam@gentoo.org>2022-12-03 01:38:22 +0000
commit88ce0e6fc46ebd3bad583790ceb19f9be218d0ca (patch)
tree59b39ce1ffa6c577a4108dac779dea9f5e41905e /setup.py
parentbintree: Fix breaking GPKG structure on updates (diff)
downloadportage-88ce0e6fc46ebd3bad583790ceb19f9be218d0ca.tar.gz
portage-88ce0e6fc46ebd3bad583790ceb19f9be218d0ca.tar.bz2
portage-88ce0e6fc46ebd3bad583790ceb19f9be218d0ca.zip
pyupgrade everything
Signed-off-by: John Helmert III <ajak@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 58823ab3b..07f72fc68 100755
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,7 @@ autodetect_pip = os.path.basename(os.environ.get("_", "")) == "pip" or os.path.b
).startswith("pip-")
venv_prefix = "" if sys.prefix == sys.base_prefix else sys.prefix
create_entry_points = bool(autodetect_pip or venv_prefix)
-with open(os.path.join(os.path.dirname(__file__), "README.md"), "rt") as f:
+with open(os.path.join(os.path.dirname(__file__), "README.md")) as f:
long_description = f.read()
# TODO:
@@ -129,7 +129,7 @@ class build_man(Command):
if not newer(source, target) and not newer(__file__, target):
continue
- print("copying and updating %s -> %s" % (source, target))
+ print("copying and updating {} -> {}".format(source, target))
with codecs.open(source, "r", "utf8") as f:
data = f.readlines()
@@ -679,7 +679,7 @@ class build_tests(x_build_scripts_custom):
)
os.unlink(conf_dir)
conf_src = os.path.relpath("cnf", self.top_dir)
- print("Symlinking %s -> %s" % (conf_dir, conf_src))
+ print("Symlinking {} -> {}".format(conf_dir, conf_src))
os.symlink(conf_src, conf_dir)
source_path = os.path.realpath(__file__)