aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRin Cat (鈴猫) <dev@rincat.ch>2022-01-23 18:23:14 -0500
committerSam James <sam@gentoo.org>2022-01-24 01:17:10 +0000
commitb094ba47368bb9b16fb17ee47a54644a09860823 (patch)
tree61f77b2130133aa9ad994e58be4eb6e1abbc13a4 /setup.py
parentAdd -X shortopt for --exclude (diff)
downloadportage-b094ba47368bb9b16fb17ee47a54644a09860823.tar.gz
portage-b094ba47368bb9b16fb17ee47a54644a09860823.tar.bz2
portage-b094ba47368bb9b16fb17ee47a54644a09860823.zip
*/*: GPKG (new binpkg format) Support (GLEP 78, provisionally)
Bug: https://bugs.gentoo.org/500630 Bug: https://bugs.gentoo.org/659864 Bug: https://bugs.gentoo.org/672672 Bug: https://bugs.gentoo.org/773259 Bug: https://bugs.gentoo.org/820578 Signed-off-by: Rin Cat (鈴猫) <dev@rincat.ch> Closes: https://github.com/gentoo/portage/pull/562 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 12 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b525454e0..9e6b4cdb2 100755
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@ try:
from setuptools.command.install_scripts import install_scripts
from setuptools.command.sdist import sdist
from setuptools.dep_util import newer
- from setuptools.dir_util import mkpath, remove_tree
+ from setuptools.dir_util import mkpath, remove_tree, copy_tree
from setuptools.util import change_root, subst_vars
except ImportError:
from distutils.core import setup, Command, Extension
@@ -28,7 +28,7 @@ except ImportError:
from distutils.command.install_scripts import install_scripts
from distutils.command.sdist import sdist
from distutils.dep_util import newer
- from distutils.dir_util import mkpath, remove_tree
+ from distutils.dir_util import mkpath, remove_tree, copy_tree
from distutils.util import change_root, subst_vars
import codecs
@@ -700,6 +700,16 @@ class test(Command):
def run(self):
self.run_command("build_tests")
+
+ # copy GPG test keys
+ copy_tree(
+ os.path.join(
+ self.build_lib, "..", "..", "lib", "portage", "tests", ".gnupg"
+ ),
+ os.path.join(self.build_lib, "portage", "tests", ".gnupg"),
+ )
+ os.chmod(os.path.join(self.build_lib, "portage", "tests", ".gnupg"), 0o700)
+
subprocess.check_call(
[
sys.executable,