aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-26 08:51:05 +0100
committerSam James <sam@gentoo.org>2023-07-26 08:58:30 +0100
commitedb9a6244be524ace95a48282e114d073ff37ad8 (patch)
tree2589c099221ddd365b59527adaf0e3685c53c8a5 /setup.py
parentdepgraph.py: fix wrong type annotations (diff)
downloadportage-edb9a6244be524ace95a48282e114d073ff37ad8.tar.gz
portage-edb9a6244be524ace95a48282e114d073ff37ad8.tar.bz2
portage-edb9a6244be524ace95a48282e114d073ff37ad8.zip
Increase minimum Python version from Python 3.6/3.7 -> Python 3.9
We don't seem to have been consistent as to whether it was 3.6 or 3.7, but we weren't testing it consistently anyway. It feels too soon to go up to 3.10 unfortunately, but 3.6/3.7 are EOL and 3.8 is EOL next year, so let's do 3.9. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3c343aabd..4525264c7 100755
--- a/setup.py
+++ b/setup.py
@@ -921,5 +921,5 @@ setup(
"Programming Language :: Python :: 3",
"Topic :: System :: Installation/Setup",
],
- python_requires=">=3.6",
+ python_requires=">=3.9",
)