aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 18:55:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 18:55:28 +0200
commit082e5794476edbf04702dbd9882332820450ecb0 (patch)
treea49afd4ac046a6ef14f7e8f53f1284a2ba97ec10 /tox.ini
parentci: Test using the newest version of PyPy3.7 (diff)
downloadportage-082e5794476edbf04702dbd9882332820450ecb0.tar.gz
portage-082e5794476edbf04702dbd9882332820450ecb0.tar.bz2
portage-082e5794476edbf04702dbd9882332820450ecb0.zip
tox: Do not run pylint on pypy3
pylint seems to be broken on PyPy3 and causes the CI to fail. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 8 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index ce43cc7fe..2281dfa24 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,25 +1,25 @@
[tox]
-envlist = py36,py37,py38,py39,py310,pypy3
+envlist = py{36,37,38,39,310}-pylint,pypy3
skipsdist = True
[gh-actions]
python =
- 3.6: py36
- 3.7: py37
- 3.8: py38
- 3.9: py39
- 3.10: py310
+ 3.6: py36-pylint
+ 3.7: py37-pylint
+ 3.8: py38-pylint
+ 3.9: py39-pylint
+ 3.10: py310-pylint
pypy-3: pypy3
[testenv]
deps =
- pylint
+ pylint: pylint
pygost
pyyaml
py36,py37,py38,py39,py310,pypy3: lxml!=4.2.0
setenv =
PYTHONPATH={toxinidir}/lib
commands =
- bash -c 'rm -rf build && PYTHONPATH=$PWD/lib:$PWD/repoman/lib pylint bin/* lib/* repoman/bin/* repoman/lib/*'
+ pylint: bash -c 'rm -rf build && PYTHONPATH=$PWD/lib:$PWD/repoman/lib pylint bin/* lib/* repoman/bin/* repoman/lib/*'
python -b -Wd setup.py test
bash -c 'if python -c "import lxml.etree"; then python -b -Wd repoman/setup.py test; else echo "repoman tests skipped due to lxml breakage"; fi'