aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-03-22 00:50:39 -0500
committerSam James <sam@gentoo.org>2023-03-23 06:59:11 +0000
commit8003c8acb8e0a73387535c338ee2d112781fe9fd (patch)
tree3a34fb9defacd111c9de49ad7482a8ccc53b0034 /tox.ini
parentactions: rename black.yml to lint.yml (diff)
downloadportage-8003c8acb8e0a73387535c338ee2d112781fe9fd.tar.gz
portage-8003c8acb8e0a73387535c338ee2d112781fe9fd.tar.bz2
portage-8003c8acb8e0a73387535c338ee2d112781fe9fd.zip
actions: move pylint job into lint.yml
Enable running the pylint job outside of just pushes or PR's to master. Don't run pylint as part of the CI/build job. Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Closes: https://github.com/gentoo/portage/pull/1014 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini24
1 files changed, 15 insertions, 9 deletions
diff --git a/tox.ini b/tox.ini
index 6760bde03..d8b84c80a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,24 +1,30 @@
[tox]
-envlist = py{37,38,39,310}-pylint,py311,pypy3
+envlist = py{37,38,39,310,311,312}-{pylint,test},pypy3-test
skipsdist = True
[gh-actions]
python =
- 3.7: py37-pylint
- 3.8: py38-pylint
- 3.9: py39-pylint
- 3.10: py310-pylint
- 3.11: py311
- pypy-3: pypy3
+ 3.7: py37
+ 3.8: py38
+ 3.9: py39
+ 3.10: py310
+ 3.11: py311
+ 3.12: py312
+ pypy-3: pypy3
+
+[gh-actions:env]
+TARGET =
+ pylint: pylint
+ test: test
[testenv]
deps =
pylint: pylint
- pyyaml
+ test: pyyaml
setenv =
PYTHONPATH={toxinidir}/lib
allowlist_externals =
./run-pylint
commands =
pylint: ./run-pylint
- python -b -Wd setup.py test
+ test: python -b -Wd setup.py test