aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xbin/repoman5
-rw-r--r--man/repoman.13
2 files changed, 8 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index f3956d68c..c89f2b8d4 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -366,6 +366,7 @@ qahelp={
"metadata.bad":"Bad metadata.xml files",
"metadata.warning":"Warnings in metadata.xml files",
"portage.internal":"The ebuild uses an internal Portage function",
+ "virtual.oldstyle":"The ebuild PROVIDEs an old-style virtual (see GLEP 37)",
"virtual.versioned":"PROVIDE contains virtuals with versions",
"virtual.exists":"PROVIDE contains existing package names",
"virtual.unavailable":"PROVIDE contains a virtual which contains no profile default",
@@ -1548,6 +1549,10 @@ for x in scanlist:
stats["virtual.exists"]+=1
fails["virtual.exists"].append(x+"/"+y+".ebuild: "+prov_cp)
+ if myaux.get("PROVIDE"):
+ stats["virtual.oldstyle"]+=1
+ fails["virtual.oldstyle"].append(relative_path)
+
for pos, missing_var in enumerate(missingvars):
if not myaux.get(missing_var):
if catdir == "virtual" and \
diff --git a/man/repoman.1 b/man/repoman.1
index 162b62b45..7c3402448 100644
--- a/man/repoman.1
+++ b/man/repoman.1
@@ -353,6 +353,9 @@ Ebuild uses D, ROOT, ED, EROOT or EPREFIX with helpers
.B virtual.exists
PROVIDE contains existing package names
.TP
+.B virtual.oldstyle
+The ebuild PROVIDEs an old-style virtual (see GLEP 37)
+.TP
.B virtual.unavailable
PROVIDE contains a virtual which contains no profile default
.TP