aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-21 20:21:35 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-21 22:49:28 +0300
commit719826e6e7f8eeb4795606a4341985fffe9a4a95 (patch)
tree34856e17213ae880d655f414cfb6328c2c7bc4a1
parentx11-themes/lxqt-themes: add 2.0.0 (diff)
downloadqt-719826e6e7f8eeb4795606a4341985fffe9a4a95.tar.gz
qt-719826e6e7f8eeb4795606a4341985fffe9a4a95.tar.bz2
qt-719826e6e7f8eeb4795606a4341985fffe9a4a95.zip
x11-libs/libfm-qt: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--x11-libs/libfm-qt/Manifest1
-rw-r--r--x11-libs/libfm-qt/libfm-qt-2.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-libs/libfm-qt/Manifest b/x11-libs/libfm-qt/Manifest
new file mode 100644
index 00000000..ad297a6d
--- /dev/null
+++ b/x11-libs/libfm-qt/Manifest
@@ -0,0 +1 @@
+DIST libfm-qt-2.0.0.tar.xz 411852 BLAKE2B 8873cb32181e64efd867df831d67bc39f5913f20ba3883cf7d4d20e0a4ef5ef2a262de43035506cc99377f163c82387cd8edfa1325d74c8c4aceeea19b77a0cc SHA512 0f58a144ec8bcebfabef2bd083a08f04d6832cc16ec0d1093bda72495def64da3172292934aa561cda88ddc289e29d9ee13e3582a8a5a48ac20cbcf3fee57524
diff --git a/x11-libs/libfm-qt/libfm-qt-2.0.0.ebuild b/x11-libs/libfm-qt/libfm-qt-2.0.0.ebuild
new file mode 100644
index 00000000..9ce51ecd
--- /dev/null
+++ b/x11-libs/libfm-qt/libfm-qt-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt Library for Building File Managers"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD GPL-2+ LGPL-2.1+"
+SLOT="0/7"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtbase-6.6:6[gui,widgets]
+ >=lxde-base/menu-cache-1.1.0:=
+ >=lxqt-base/lxqt-menu-data-2.0.0
+ media-libs/libexif
+ x11-libs/libxcb:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}