aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-21 20:21:49 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-21 22:49:28 +0300
commite3ca37595f0e454b6c49a1354f84e6eced05d88f (patch)
treefebbbdc5ec9933edd0655bcbfaeff72cb1dbcda5
parentmedia-gfx/lximage-qt: add 2.0.0 (diff)
downloadqt-e3ca37595f0e454b6c49a1354f84e6eced05d88f.tar.gz
qt-e3ca37595f0e454b6c49a1354f84e6eced05d88f.tar.bz2
qt-e3ca37595f0e454b6c49a1354f84e6eced05d88f.zip
app-arch/lxqt-archiver: add 1.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--app-arch/lxqt-archiver/Manifest1
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
new file mode 100644
index 00000000..b3f942fb
--- /dev/null
+++ b/app-arch/lxqt-archiver/Manifest
@@ -0,0 +1 @@
+DIST lxqt-archiver-1.0.0.tar.xz 187944 BLAKE2B c28e0c7c5a41fa5a1e2d417239e5de0b33d3a84a2833fab7239f50ae1b7f426c2b7fd630a09cea24f2032183e2bdcc037276462fdab3719fb709fd9f51ea8afd SHA512 12552539cb7601c3c1422ed00d6fa8ed0ebed744ce8b7b4a3e3cc8bd59bf8df165008fa63b0ce173b58309001f35c33a219cd80e7568acf12c4c896320fc5061
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild
new file mode 100644
index 00000000..6013e544
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=dev-qt/qtbase-6.6:6[gui,widgets]
+ >=x11-libs/libfm-qt-2.0:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}