aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-03-27 14:25:06 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-03-27 14:25:06 +0100
commit9b41e1a51292a264959347d35ec1b35f7b1dd03f (patch)
treee50694ceb97f1789805ec113a7d876e61139d74c
parentMark s390x specs as such, prepare for 32bit addition (diff)
downloadreleng-9b41e1a51292a264959347d35ec1b35f7b1dd03f.tar.gz
releng-9b41e1a51292a264959347d35ec1b35f7b1dd03f.tar.bz2
releng-9b41e1a51292a264959347d35ec1b35f7b1dd03f.zip
Integrate 32bit stuff into s390x builder
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--tools/catalyst-auto-s390x.conf30
1 files changed, 28 insertions, 2 deletions
diff --git a/tools/catalyst-auto-s390x.conf b/tools/catalyst-auto-s390x.conf
index 355c7d82..dc4104de 100644
--- a/tools/catalyst-auto-s390x.conf
+++ b/tools/catalyst-auto-s390x.conf
@@ -4,12 +4,14 @@
UPLOAD_USER=s390
UPLOAD_KEY=/root/.ssh/id_rsa
SPECS_DIR=${REPO_DIR}/releases/specs/s390
-SUBARCH=s390x
SETS="
openrc_64_23
systemd_64_23
+ openrc_32_23
+ systemd_32_23
openrc_64
+ openrc_32
"
SET_openrc_64_SPECS="s390x/stage1-openrc.spec s390x/stage3-openrc.spec"
@@ -19,16 +21,24 @@ SET_openrc_64_23_SPECS="s390x/stage1-openrc-23.spec s390x/stage3-openrc-23.spec"
SET_systemd_64_23_SPECS="s390x/stage1-systemd-23.spec s390x/stage3-systemd-23.spec"
+SET_openrc_32_SPECS="s390/stage1-openrc.spec s390/stage3-openrc.spec"
+SET_openrc_32_OPTIONAL_SPECS="s390/netboot/netboot.spec"
+
+SET_openrc_32_23_SPECS="s390/stage1-openrc-23.spec s390/stage3-openrc-23.spec"
+
+SET_systemd_32_23_SPECS="s390/stage1-systemd-23.spec s390/stage3-systemd-23.spec"
+
KCONFIG_DIR=${REPO_DIR}/releases/kconfig/s390
+
update_symlinks() {
# Symlink the latest stages3 to build from
local d f
for d in "${BUILD_SRCDIR_BASE}/builds"/* ; do
mkdir -p "${d}"
pushd "${d}" >/dev/null
- for f in $(ls stage3-${SUBARCH}-*xz | grep -v latest | give_latest_from_dates) ; do
+ for f in $(ls stage3-s390*xz | grep -v latest | give_latest_from_dates) ; do
local of=$(echo "${f}" | convert_filename)
ln -sf "${f}" "${of}"
done
@@ -47,9 +57,18 @@ post_build() {
mv -v netboot-s390x-${TIMESTAMP}/kernels/misc/netboot64.igz netboot-s390x-${TIMESTAMP}/netboot-s390x-initramfs-${TIMESTAMP}
upload netboot-s390x-${TIMESTAMP}/netboot*
;;
+ s390/netboot/netboot.spec)
+ ls -l netboot-s390-${TIMESTAMP}/kernels/
+ mv -v netboot-s390-${TIMESTAMP}/kernels/netboot netboot-s390-${TIMESTAMP}/netboot-s390-kernel-${TIMESTAMP}
+ mv -v netboot-s390-${TIMESTAMP}/kernels/misc/netboot.igz netboot-s390-${TIMESTAMP}/netboot-s390-initramfs-${TIMESTAMP}
+ upload netboot-s390-${TIMESTAMP}/netboot*
+ ;;
s390x/stage3-openrc.spec)
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-s390x" s390/17.0/s390x
;;
+ s390/stage3-openrc.spec)
+ upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/default/stage3-s390" s390/17.0/s390
+ ;;
esac
popd >/dev/null
@@ -62,6 +81,13 @@ post_build() {
upload stage3-s390x-systemd-${TIMESTAMP}.tar.xz*
upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/23.0-default/stage3-s390x" s390/23.0/s390x
;;
+ s390/stage3-openrc-23.spec)
+ upload stage3-s390-openrc-${TIMESTAMP}.tar.xz*
+ ;;
+ s390/stage3-systemd-23.spec)
+ upload stage3-s390-systemd-${TIMESTAMP}.tar.xz*
+ upsync_binpackages "${BUILD_SRCDIR_BASE}/packages/23.0-default/stage3-s390" s390/23.0/s390
+ ;;
esac
popd >/dev/null
}