aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-29 13:14:29 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-29 13:14:29 +0200
commit7057468421337302f4dd9f9086c501496474402e (patch)
tree71423d0a00176ce15fec101f6411aa727f6aaaf7
parentdev-python/vector: add 1.4.0 (diff)
downloadsci-master.tar.gz
sci-master.tar.bz2
sci-master.zip
sci-physics/pyhf: add 0.7.5HEADmaster
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/pyhf/Manifest1
-rw-r--r--sci-physics/pyhf/pyhf-0.7.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-physics/pyhf/Manifest b/sci-physics/pyhf/Manifest
index 756bfb423..3155872d4 100644
--- a/sci-physics/pyhf/Manifest
+++ b/sci-physics/pyhf/Manifest
@@ -1 +1,2 @@
DIST pyhf-0.7.3.tar.gz 113423 BLAKE2B 216ef186c539481e2819e3f3a198203f085aa99652ab335b1153309a780857c5ad53bc848bb1b12615cfa9b8ee97a67553cef5a0f899bbcf178bfea1b2ca11c5 SHA512 904491f9c161f0231d1e109cfa3a12b31a31b1aa7477752e1eafd1e6c4cec75551e53ce1f6d447bed8f295371dc20b032888a5175af0f2eb808e03c0a8993930
+DIST pyhf-0.7.5.tar.gz 113812 BLAKE2B 747dc59de4e80d883145dd6b5643507c6faca2c1cb53b2aaea93cfcf31ed474ed3807f9f5a79d45f49a330f9c6260d5373e8134be814b07e1a1ae161844ad960 SHA512 83a5e02d7278e3e835ecf49d5b01fd6614923bf5e80d58ec2a96da89a67ad80bcdad4be90b598d314caf83a293c3bb69c3e995c292c0b62ef109662c061d91e8
diff --git a/sci-physics/pyhf/pyhf-0.7.5.ebuild b/sci-physics/pyhf/pyhf-0.7.5.ebuild
new file mode 100644
index 000000000..22a36af7f
--- /dev/null
+++ b/sci-physics/pyhf/pyhf-0.7.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pure-python fitting/limit-setting/interval estimation HistFactory-style"
+HOMEPAGE="
+ https://github.com/scikit-hep/pyhf
+ https://doi.org/10.5281/zenodo.1169739
+ https://zenodo.org/record/8256635
+ https://doi.org/10.21105/joss.02823
+ https://inspirehep.net/literature/2598491
+ https://arxiv.org/abs/2211.15838
+ https://doi.org/10.22323/1.414.0245
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# test needs missing scrapbook papermill pydocstyle ...
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonpatch-1.15[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.15.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.56.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"