aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-05-06 11:10:45 -0400
committerHorea Christian <chr@chymera.eu>2024-05-06 11:10:45 -0400
commita713b317a1e583b970f6382a464603f100f269b8 (patch)
tree48c22fb46480d07f2ee55ee289214e0608376063
parentdev-python/linesep: new package, add 0.5.0 (diff)
downloadsci-a713b317a1e583b970f6382a464603f100f269b8.tar.gz
sci-a713b317a1e583b970f6382a464603f100f269b8.tar.bz2
sci-a713b317a1e583b970f6382a464603f100f269b8.zip
dev-python/wirerope: new package, add 0.4.7
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/wirerope/Manifest1
-rw-r--r--dev-python/wirerope/files/wirerope-0.4.7-nocov.patch10
-rw-r--r--dev-python/wirerope/metadata.xml16
-rw-r--r--dev-python/wirerope/wirerope-0.4.7.ebuild26
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/wirerope/Manifest b/dev-python/wirerope/Manifest
new file mode 100644
index 000000000..ae2ee16cb
--- /dev/null
+++ b/dev-python/wirerope/Manifest
@@ -0,0 +1 @@
+DIST wirerope-0.4.7.gh.tar.gz 12220 BLAKE2B 1ed861b71cfbfb4c0d18a2c09f6cf96f545d9a88617e7618053c4e5459317532e12195a02e3f3d99a0cc91bf0601c39404b80e4e631a86b24a5926718b4cb287 SHA512 cfa7222503a9c03f9afe6cab9acc45d7115795169325692c5c519913406f8abc4d78d84769d24ff123ca47333f7ea8dde3a8a7961d34d0e20aebc02e0a420aaf
diff --git a/dev-python/wirerope/files/wirerope-0.4.7-nocov.patch b/dev-python/wirerope/files/wirerope-0.4.7-nocov.patch
new file mode 100644
index 000000000..64d47d0b7
--- /dev/null
+++ b/dev-python/wirerope/files/wirerope-0.4.7-nocov.patch
@@ -0,0 +1,10 @@
+--- a/setup.cfg 2023-02-05 08:00:42.000000000 -0500
++++ b/setup.cfg 2024-05-06 11:01:02.896234948 -0400
+@@ -33,7 +33,6 @@
+ sphinx
+
+ [tool:pytest]
+-addopts=--verbose --cov-config .coveragerc --cov wirerope
+ python_files = tests/test_*.py
+ norecursedirs=.git py ci
+ [flake8]
diff --git a/dev-python/wirerope/metadata.xml b/dev-python/wirerope/metadata.xml
new file mode 100644
index 000000000..6e39bae5d
--- /dev/null
+++ b/dev-python/wirerope/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">youknowone/wirerope</remote-id>
+ <remote-id type="pypi">wirerope</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wirerope/wirerope-0.4.7.ebuild b/dev-python/wirerope/wirerope-0.4.7.ebuild
new file mode 100644
index 000000000..74e7f40bd
--- /dev/null
+++ b/dev-python/wirerope/wirerope-0.4.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A wrapper interface for python callables"
+HOMEPAGE="https://github.com/youknowone/wirerope"
+# Not using PyPI archive because it misses test files:
+# https://github.com/youknowone/wirerope/issues/20
+SRC_URI="https://github.com/youknowone/wirerope/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}/${P}-nocov.patch" )
+
+distutils_enable_tests pytest