aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-06-08 11:59:33 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-06-08 11:59:33 +0200
commit2bdd97faa1c9f57f3d8d9d91fc6c439f260d809e (patch)
treefc363a9fddb9efa01920803d14fc6f43a495a14b /sci-chemistry/coot/files
parentpymol live ebuild added (diff)
downloadsci-2bdd97faa1c9f57f3d8d9d91fc6c439f260d809e.tar.gz
sci-2bdd97faa1c9f57f3d8d9d91fc6c439f260d809e.tar.bz2
sci-2bdd97faa1c9f57f3d8d9d91fc6c439f260d809e.zip
live coot added
Diffstat (limited to 'sci-chemistry/coot/files')
-rw-r--r--sci-chemistry/coot/files/9999-as-needed.patch485
1 files changed, 485 insertions, 0 deletions
diff --git a/sci-chemistry/coot/files/9999-as-needed.patch b/sci-chemistry/coot/files/9999-as-needed.patch
new file mode 100644
index 000000000..6d45efac3
--- /dev/null
+++ b/sci-chemistry/coot/files/9999-as-needed.patch
@@ -0,0 +1,485 @@
+diff -ur analysis/Makefile.am analysis/Makefile.am
+--- analysis/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ analysis/Makefile.am 2008-07-13 16:40:40.000000000 -0700
+@@ -9,6 +9,7 @@
+ $(MMDB_CXXFLAGS)
+
+ libcoot_analysis_la_SOURCES = bfkurt.cc
++libcoot_analysis_la_LIBADD = $(top_builddir)/coot-utils/libcoot-coord-utils.la
+
+ bin_PROGRAMS = bfactan
+
+@@ -16,7 +17,6 @@
+
+ bfactan_LDADD = \
+ libcoot-analysis.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(CLIPPER_LIBS) \
+diff -ur coords/Makefile.am coords/Makefile.am
+--- coords/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ coords/Makefile.am 2008-07-13 16:40:40.000000000 -0700
+@@ -37,4 +37,6 @@
+ libcoot_coords_la_SOURCES = Bond_lines.cc Cartesian.cc cos-sin.cc \
+ mmdb-extras.cc utils.cc mmdb.cc mmdb-crystal.cc \
+ Bond_lines_ext.cc coot-close.cc
+-
++libcoot_coords_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/mini-mol/libcoot-mini-mol.la
+diff -ur cootaneer/Makefile.am cootaneer/Makefile.am
+--- cootaneer/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ cootaneer/Makefile.am 2008-07-13 16:40:40.000000000 -0700
+@@ -34,6 +34,7 @@
+ buccaneer-sequence.cpp cootaneer-sequence.cpp \
+ buccaneer-lib.h buccaneer-prot.h \
+ buccaneer-sequence.h cootaneer-sequence.h
++libcootaneer_la_LIBADD = $(CLIPPER_LIBS)
+
+ subpkgdatadir = $(pkgdatadir)
+ subpkgdata_DATA = cootaneer-llk-2.40.dat
+diff -ur coot-surface/Makefile.am coot-surface/Makefile.am
+--- coot-surface/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ coot-surface/Makefile.am 2008-07-13 16:40:40.000000000 -0700
+@@ -25,3 +25,4 @@
+
+ libcoot_surface_la_SOURCES = \
+ coot-surface.cc coot-surface.hh rgbreps.cc rgbreps.h
++libcoot_surface_la_LIBADD = $(top_builddir)/surface/libccp4mg-surface.la
+diff -ur coot-utils/Makefile.am coot-utils/Makefile.am
+--- coot-utils/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ coot-utils/Makefile.am 2008-07-13 16:40:40.000000000 -0700
+@@ -51,9 +51,11 @@
+ # for pure coordinates (mmdb) things
+ libcoot_coord_utils_la_SOURCES = coot-coord-utils.cc \
+ coot-coord-utils-nucleotides.cc coot-rama.cc
++libcoot_coord_utils_la_LIBADD = $(CLIPPER_LIBS) libcoot-utils.la
+
+ # shelx
+ libcoot_shelx_la_SOURCES = coot-shelx-ins.cc
++libcoot_shelx_la_LIBADD = $(MMDB_LIBS) libcoot-coord-utils.la
+
+ # for non-simple coordinates things
+ libcoot_coord_extras_la_SOURCES = coot-coord-extras.cc coot-coord-lsq.cc
+@@ -63,21 +65,20 @@
+
+ # for map things that need mmdb, clipper, gsl and other things
+ libcoot_map_heavy_la_SOURCES = coot-map-heavy.cc coot-fffear.cc
++libcoot_map_heavy_la_LIBADD = $(GSL_LIBS)
+
+ noinst_PROGRAMS = testshelxreader testcootutils
+
+ testshelxreader_SOURCES = test-shelx-reader.cc
+ testshelxreader_LDADD = \
+ ./libcoot-shelx.la \
+- ./libcoot-coord-utils.la \
+- ./libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ ./libcoot-utils.la
+
+ testcootutils_SOURCES = test-utils.cc
+ testcootutils_LDADD = \
+ ./libcoot-shelx.la \
+ ./libcoot-coord-utils.la \
+ ./libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(MMDB_LIBS)
+
+
+--- geometry/Makefile.am 2008-09-08 15:22:01.000000000 +0200
++++ geometry/Makefile.am.new 2008-11-20 12:01:08.000000000 +0100
+@@ -35,6 +35,10 @@
+
+ libcoot_geometry_la_SOURCES = protein-geometry.cc protein-geometry-mmdb.cc
+
++libcoot_geometry_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-utils.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
++
+ # libcoot_geometry_la_CXXFLAGS = -g -O1
+
+ noinst_PROGRAMS = test-geometry test-read-components
+@@ -43,12 +47,6 @@
+
+ test_read_components_SOURCES = test-read-components.cc test-read-components.hh
+
+-test_geometry_LDADD = ./libcoot-geometry.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
+-
+-test_read_components_LDADD = \
+- ./libcoot-geometry.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++test_geometry_LDADD = ./libcoot-geometry.la
+
++test_read_components_LDADD = ./libcoot-geometry.la
+
+diff -ur ideal/Makefile.am ideal/Makefile.am
+--- ideal/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ ideal/Makefile.am 2008-07-13 16:41:14.000000000 -0700
+@@ -44,6 +44,12 @@
+ AM_CXXFLAGS = $(COOT_GSL_FLAGS) $(GSL_CFLAGS)
+
+ libcoot_ideal_la_SOURCES = simple-restraint.cc pepflip.cc regularize-minimol.cc lograma.cpp
++libcoot_ideal_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-utils.la \
++ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
++ $(GSL_LIBS)
+
+ noinst_PROGRAMS = test-indexing with-geometry with-map logramatest
+ # bin_PROGRAMS =
+@@ -63,36 +69,25 @@
+ with_geometry_LDADD = \
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ # add libcoot-map-utils for the debugging density_around_point function
+ with_map_LDADD = \
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/compat/libcoot-compat.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(top_builddir)/compat/libcoot-compat.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ test_indexing_LDADD = \
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ # Why do I need all these libraries to simply link a trivial test program?
+ # Badness....
+diff -ur mini-mol/Makefile.am mini-mol/Makefile.am
+--- mini-mol/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ mini-mol/Makefile.am 2008-07-13 16:40:40.000000000 -0700
+@@ -32,8 +32,9 @@
+ testminimol_SOURCES = testminimol.cc
+
+ libcoot_mini_mol_la_SOURCES = mini-mol.cc mini-mol-utils.cc
++libcoot_mini_mol_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(CLIPPER_LIBS)
+
+ testminimol_LDADD = libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(MMDB_LIBS)
+diff -ur skeleton/Makefile.am skeleton/Makefile.am
+--- skeleton/Makefile.am 2008-07-13 16:40:27.000000000 -0700
++++ skeleton/Makefile.am 2008-07-13 16:40:40.000000000 -0700
+@@ -36,7 +36,7 @@
+
+
+ libcoot_skeleton_la_SOURCES = $(libskeleton_a_sources)
+-
++libcoot_skeleton_la_LIBADD = ../atom-utils/libcoot-atomutils.la
+
+ # bin_PROGRAMS = ncssearch test_various test_torsion test_theta_2
+
+--- high-res/Makefile.am 2009-01-06 20:19:20.000000000 +0100
++++ high-res/Makefile.am.new 2009-06-03 10:13:35.000000000 +0200
+@@ -39,13 +39,17 @@
+
+ libcoot_high_res_la_SOURCES = high-res.cc coot-atom-graph.cc residue-distortions.cc \
+ sequence-assignment.cc
++libcoot_high_res_la_LIBADD = \
++ $(top_builddir)/ligand/libcoot-ligand.la \
++ $(top_builddir)/coot-utils/libcoot-map-utils.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
++
+
+ check_PROGRAMS = testatomgraph tracehighres testseqalign testseqassignment globularize_protein
+
+ testatomgraph_SOURCES = test-atom-graph.cc
+
+ testatomgraph_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+@@ -53,71 +57,60 @@
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
++ $(GSL_LIBS)
+
+ testseqassignment_SOURCES = testseqassignment.cc
+ testseqassignment_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
++ $(GSL_LIBS)
+
+ # tracehighres_LDFLAGS = -static
+ tracehighres_SOURCES = trace-high-res.cc
+ tracehighres_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
++ $(GSL_LIBS)
+
+
+ testseqalign_SOURCES = testseqalign.cc
+
+ # why do we need to link with all this (junk)?
+ testseqalign_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
++ $(GSL_LIBS)
+
+
+ globularize_protein_SOURCES = globularize.cc
+--- ligand/Makefile.am 2009-02-06 00:50:01.000000000 +0100
++++ ligand/Makefile.am.new 2009-06-03 10:29:30.000000000 +0200
+@@ -50,6 +50,18 @@
+ torsion-general.cc rotamer-tables.cc primitive-chi-angles.cc dipole.cc\
+ base-pairing.cc
+
++libcoot_ligand_la_LIBADD = \
++ $(top_builddir)/ideal/libcoot-ideal.la \
++ $(top_builddir)/coords/libcoot-coords.la \
++ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
++ $(top_builddir)/coot-utils/libcoot-map-utils.la \
++ $(top_builddir)/db-main/libcoot-db-main.la \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/geometry/libcoot-geometry.la \
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la
++
++
+ AM_CXXFLAGS = \
+ -DPKGDATADIR='"$(pkgdatadir)"' \
+ $(COOT_WINDOWS_CFLAGS)
+@@ -69,52 +81,25 @@
+
+ test_random_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+ test_ligand_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+ test_helix_placement_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+@@ -122,19 +107,10 @@
+
+ test_fffear_in_coot_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-map-heavy.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+@@ -146,23 +122,13 @@
+
+ findligand_real_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+ findwaters_real_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+@@ -193,17 +159,8 @@
+ testdunbrack_SOURCES = testdunbrack.cc
+
+ testdunbrack_LDADD = ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+ # lib coot-coords depends on mmdb, even though Cartesian doesn't
+--- tw/Makefile.am 2007-04-20 16:12:16.000000000 +0200
++++ tw/Makefile.am.new 2009-06-03 10:31:17.000000000 +0200
+@@ -39,14 +39,16 @@
+ include_HEADERS = coot-tw.hh
+
+ libcoot_tw_la_SOURCES = tw.cc
++libcoot_tw_la_LIBADD = \
++ $(GTKCANVAS_LIBS) \
++ @GTK_LIBS@
++
+
+ noinst_PROGRAMS = coot-tiddly
+
+ coot_tiddly_SOURCES = tiddly.cc
+
+-coot_tiddly_LDADD = libcoot-tw.la \
+- $(GTKCANVAS_LIBS) \
+- @GTK_LIBS@
++coot_tiddly_LDADD = libcoot-tw.la
+
+
+ # cootsound_LDADD = -L/sw/lib -lvorbisfile -logg -lao
+--- Makefile.am 2009-01-06 15:50:23.000000000 +0100
++++ Makefile.am.new 2009-06-03 10:35:59.000000000 +0200
+@@ -25,10 +25,10 @@
+
+ # see configure.in for po intl
+ SUBDIRS = auxil scheme python macros compat coot-utils surface coot-surface \
+- skeleton ccp4mg-utils density-contour coords angles \
+- mini-mol db-main geometry \
++ atom-utils skeleton ccp4mg-utils density-contour mini-mol coords angles \
++ db-main geometry \
+ ideal ligand high-res build greg-tests python-tests \
+- analysis sequence-view tw atom-utils cootaneer src rama-data doc
++ analysis sequence-view tw cootaneer src rama-data doc
+
+ # po, no po today.
+
+--- coot-utils/Makefile.am.orig 2009-06-07 17:40:00.000000000 -0700
++++ coot-utils/Makefile.am 2009-06-07 17:39:07.000000000 -0700
+@@ -63,6 +63,7 @@
+
+ # for (map) things that need to link mmdb and clipper:
+ libcoot_map_utils_la_SOURCES = coot-map-utils.cc peak-search.cc trim.cc xmap-stats.cc
++libcoot_map_utils_la_LIBADD = $(CLIPPER_LIBS)
+
+ # for map things that need mmdb, clipper, gsl and other things
+ libcoot_map_heavy_la_SOURCES = coot-map-heavy.cc coot-fffear.cc