aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-12 17:21:42 +0100
committerJustin Lecher <jlec@gentoo.org>2011-01-12 17:21:42 +0100
commitbb9486ef452c39c8390d8913c3121014136c48aa (patch)
treea6e56b6e2e67cc86c30f36a6c1313315fa68449a /sci-chemistry/coot/files
parentmore cleaning (diff)
downloadsci-bb9486ef452c39c8390d8913c3121014136c48aa.tar.gz
sci-bb9486ef452c39c8390d8913c3121014136c48aa.tar.bz2
sci-bb9486ef452c39c8390d8913c3121014136c48aa.zip
Correctly manage openmp and otehr linking
(Portage version: 2.2.0_alpha14/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/coot/files')
-rw-r--r--sci-chemistry/coot/files/9999-clipper.patch9
-rw-r--r--sci-chemistry/coot/files/9999-goocanvas.patch26
-rw-r--r--sci-chemistry/coot/files/9999-gsl.patch14
-rw-r--r--sci-chemistry/coot/files/9999-lidia.patch16
-rw-r--r--sci-chemistry/coot/files/9999-openmp.patch17
5 files changed, 63 insertions, 19 deletions
diff --git a/sci-chemistry/coot/files/9999-clipper.patch b/sci-chemistry/coot/files/9999-clipper.patch
new file mode 100644
index 000000000..e3f028f98
--- /dev/null
+++ b/sci-chemistry/coot/files/9999-clipper.patch
@@ -0,0 +1,9 @@
+Index: lidia-core/Makefile.am
+===================================================================
+--- lidia-core/Makefile.am (revision 3299)
++++ lidia-core/Makefile.am (working copy)
+@@ -23,3 +23,4 @@
+
+ libcoot_lidia_core_la_SOURCES = lbg-molfile.cc lig-build.cc
+
++libcoot_lidia_core_la_LIBADD = $(CLIPPER_LIBS)
diff --git a/sci-chemistry/coot/files/9999-goocanvas.patch b/sci-chemistry/coot/files/9999-goocanvas.patch
index 0a8d3f3ed..ce0d4a00a 100644
--- a/sci-chemistry/coot/files/9999-goocanvas.patch
+++ b/sci-chemistry/coot/files/9999-goocanvas.patch
@@ -1,30 +1,20 @@
-Index: trunk/macros/goo-canvas.m4
+Index: macros/goo-canvas.m4
===================================================================
---- trunk/macros/goo-canvas.m4 (revision 3249)
-+++ trunk/macros/goo-canvas.m4 (working copy)
-@@ -28,15 +28,15 @@
- # GCC c++ does not.
- #
- GOOCANVAS_LDOPTS="$goocanvas_prefix/lib/libgoocanvas.la"
-+
-+ # PKG_CHECK_MODULES has a AC_MSG itself
-+ AC_MSG_CHECKING([for Goocanvas])
-+
- else
-- # the compiler looks in the "standard" places for GOOCANVAS.
-- GOOCANVAS_CFLAGS="-I/usr/include/goocanvas-1.0"
-- GOOCANVAS_LDOPTS="libgoocanvas.la"
-+ PKG_CHECK_MODULES(GOOCANVAS, goocanvas)
+--- macros/goo-canvas.m4 (revision 3307)
++++ macros/goo-canvas.m4 (working copy)
+@@ -56,9 +56,9 @@
+ fi
fi
-AC_MSG_CHECKING([for Goocanvas])
--
++PKG_CHECK_MODULES(GOOCANVAS, goocanvas)
+
-LIBS="$saved_LIBS $GOOCANVAS_LDOPTS $GTK_LIBS"
+LIBS="$saved_LIBS $GOOCANVAS_LIBS $GTK_LIBS"
CXXFLAGS="$saved_CXXFLAGS $GOOCANVAS_CFLAGS $GTK_CFLAGS"
#
# AC_TRY_LINK uses the c compiler (set by AC_LANG), so we will
-@@ -54,7 +54,7 @@
+@@ -76,7 +76,7 @@
if test x$have_goocanvas = xyes; then
GOOCANVAS_CFLAGS="$GOOCANVAS_CFLAGS"
diff --git a/sci-chemistry/coot/files/9999-gsl.patch b/sci-chemistry/coot/files/9999-gsl.patch
new file mode 100644
index 000000000..af7a405f8
--- /dev/null
+++ b/sci-chemistry/coot/files/9999-gsl.patch
@@ -0,0 +1,14 @@
+Index: coot-utils/Makefile.am
+===================================================================
+--- coot-utils/Makefile.am (revision 3299)
++++ coot-utils/Makefile.am (working copy)
+@@ -90,7 +90,8 @@
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ libcoot-map-utils.la \
+ libcoot-coord-utils.la \
+- $(top_builddir)/utils/libcoot-utils.la
++ $(top_builddir)/utils/libcoot-utils.la \
++ $(GSL_LIBS)
+
+
+ noinst_PROGRAMS = test-h-bonds testshelxreader testcootutils
diff --git a/sci-chemistry/coot/files/9999-lidia.patch b/sci-chemistry/coot/files/9999-lidia.patch
new file mode 100644
index 000000000..2ac3fccb9
--- /dev/null
+++ b/sci-chemistry/coot/files/9999-lidia.patch
@@ -0,0 +1,16 @@
+Index: lbg/Makefile.am
+===================================================================
+--- lbg/Makefile.am (revision 3299)
++++ lbg/Makefile.am (working copy)
+@@ -24,6 +24,11 @@
+ lbg-search.cc some-coot-utils.cc residue-circles.cc rdkit-interface.cc \
+ flev-annotations.cc
+
++libcoot_lidia_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(top_builddir)/lidia-core/libcoot-lidia-core.la \
++ $(GSL_LIBS) $(GTK_LIBS) $(GOOCANVAS_LIBS)
++
+ lidia_SOURCES = lidia-main.cc
+
+ # some-coot-utils.hh needed?
diff --git a/sci-chemistry/coot/files/9999-openmp.patch b/sci-chemistry/coot/files/9999-openmp.patch
index 3cc9501a8..a239c1fe5 100644
--- a/sci-chemistry/coot/files/9999-openmp.patch
+++ b/sci-chemistry/coot/files/9999-openmp.patch
@@ -7,7 +7,22 @@ Index: surface/Makefile.am
INCLUDES = -I$(top_srcdir)/coot-utils $(MMDB_CXXFLAGS) $(CLIPPER_CXXFLAGS) $(FFTW_CXXFLAGS)
-AM_CPPFLAGS = $(OPENMP_CFLAGS)
-+AM_CPPFLAGS = $(OPENMP_CXXFLAGS)
++AM_CXXFLAGS = $(OPENMP_CFLAGS)
lib_LTLIBRARIES = libccp4mg-surface.la
+Index: src/Makefile.am
+===================================================================
+--- src/Makefile.am (revision 3299)
++++ src/Makefile.am (working copy)
+@@ -417,8 +417,8 @@
+ # coot_real_LDFLAGS = -static -lstdc++
+ coot_real_LDFLAGS =
+
+-coot_real_LDADD = $(OPENMP_CFLAGS) \
+- $(COOT_EXTRA_LIBS) \
++coot_real_LDADD = \
++ $(COOT_EXTRA_LIBS) \
+ $(GUILE_GTK_LIBS) \
+ $(GUILE_LDFLAGS) \
+ $(CLIPPER_LIBS) \