aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-09-16 08:23:50 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-09-16 08:24:14 +0200
commite5b2292ed4362b48000b35c3fbe4ded18f3476bc (patch)
treedf7305eafaf1e498141d9df3d936abc1296723ee /sci-chemistry/coot/files
parentfix for bug 285068 (diff)
downloadsci-e5b2292ed4362b48000b35c3fbe4ded18f3476bc.tar.gz
sci-e5b2292ed4362b48000b35c3fbe4ded18f3476bc.tar.bz2
sci-e5b2292ed4362b48000b35c3fbe4ded18f3476bc.zip
HOMEPAGE corrected bug 285068
bumped prerelease to r2312 which will be the version of the second prerelease Included src_test in prerelease
Diffstat (limited to 'sci-chemistry/coot/files')
-rw-r--r--sci-chemistry/coot/files/0.6_pre1-as-needed.patch624
-rw-r--r--sci-chemistry/coot/files/0.6_pre1-gcc4.4.patch15
-rw-r--r--sci-chemistry/coot/files/0.6_pre1-test-rama.patch15
3 files changed, 332 insertions, 322 deletions
diff --git a/sci-chemistry/coot/files/0.6_pre1-as-needed.patch b/sci-chemistry/coot/files/0.6_pre1-as-needed.patch
index 6d45efac3..0cfce54dd 100644
--- a/sci-chemistry/coot/files/0.6_pre1-as-needed.patch
+++ b/sci-chemistry/coot/files/0.6_pre1-as-needed.patch
@@ -1,210 +1,202 @@
-diff -ur analysis/Makefile.am analysis/Makefile.am
---- analysis/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ analysis/Makefile.am 2008-07-13 16:40:40.000000000 -0700
-@@ -9,6 +9,7 @@
- $(MMDB_CXXFLAGS)
-
- libcoot_analysis_la_SOURCES = bfkurt.cc
-+libcoot_analysis_la_LIBADD = $(top_builddir)/coot-utils/libcoot-coord-utils.la
-
- bin_PROGRAMS = bfactan
+Index: mini-mol/Makefile.am
+===================================================================
+--- mini-mol/Makefile.am (revision 2293)
++++ mini-mol/Makefile.am (working copy)
+@@ -35,8 +35,9 @@
+ testminimol_SOURCES = testminimol.cc
-@@ -16,7 +17,6 @@
+ libcoot_mini_mol_la_SOURCES = mini-mol.cc mini-mol-utils.cc atom-quads.cc
++libcoot_mini_mol_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(CLIPPER_LIBS)
- bfactan_LDADD = \
- libcoot-analysis.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
- $(top_builddir)/coot-utils/libcoot-utils.la \
- $(top_builddir)/geometry/libcoot-geometry.la \
- $(CLIPPER_LIBS) \
-diff -ur coords/Makefile.am coords/Makefile.am
---- coords/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ coords/Makefile.am 2008-07-13 16:40:40.000000000 -0700
-@@ -37,4 +37,6 @@
- libcoot_coords_la_SOURCES = Bond_lines.cc Cartesian.cc cos-sin.cc \
+ testminimol_LDADD = libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(MMDB_LIBS)
+Index: coords/Makefile.am
+===================================================================
+--- coords/Makefile.am (revision 2293)
++++ coords/Makefile.am (working copy)
+@@ -40,3 +40,7 @@
mmdb-extras.cc utils.cc mmdb.cc mmdb-crystal.cc \
Bond_lines_ext.cc coot-close.cc
--
+
+libcoot_coords_la_LIBADD = \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la
-diff -ur cootaneer/Makefile.am cootaneer/Makefile.am
---- cootaneer/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ cootaneer/Makefile.am 2008-07-13 16:40:40.000000000 -0700
-@@ -34,6 +34,7 @@
- buccaneer-sequence.cpp cootaneer-sequence.cpp \
- buccaneer-lib.h buccaneer-prot.h \
- buccaneer-sequence.h cootaneer-sequence.h
-+libcootaneer_la_LIBADD = $(CLIPPER_LIBS)
-
- subpkgdatadir = $(pkgdatadir)
- subpkgdata_DATA = cootaneer-llk-2.40.dat
-diff -ur coot-surface/Makefile.am coot-surface/Makefile.am
---- coot-surface/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ coot-surface/Makefile.am 2008-07-13 16:40:40.000000000 -0700
-@@ -25,3 +25,4 @@
-
- libcoot_surface_la_SOURCES = \
- coot-surface.cc coot-surface.hh rgbreps.cc rgbreps.h
-+libcoot_surface_la_LIBADD = $(top_builddir)/surface/libccp4mg-surface.la
-diff -ur coot-utils/Makefile.am coot-utils/Makefile.am
---- coot-utils/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ coot-utils/Makefile.am 2008-07-13 16:40:40.000000000 -0700
-@@ -51,9 +51,11 @@
- # for pure coordinates (mmdb) things
- libcoot_coord_utils_la_SOURCES = coot-coord-utils.cc \
- coot-coord-utils-nucleotides.cc coot-rama.cc
-+libcoot_coord_utils_la_LIBADD = $(CLIPPER_LIBS) libcoot-utils.la
-
- # shelx
- libcoot_shelx_la_SOURCES = coot-shelx-ins.cc
-+libcoot_shelx_la_LIBADD = $(MMDB_LIBS) libcoot-coord-utils.la
-
- # for non-simple coordinates things
- libcoot_coord_extras_la_SOURCES = coot-coord-extras.cc coot-coord-lsq.cc
-@@ -63,21 +65,20 @@
-
- # for map things that need mmdb, clipper, gsl and other things
- libcoot_map_heavy_la_SOURCES = coot-map-heavy.cc coot-fffear.cc
-+libcoot_map_heavy_la_LIBADD = $(GSL_LIBS)
-
- noinst_PROGRAMS = testshelxreader testcootutils
-
- testshelxreader_SOURCES = test-shelx-reader.cc
- testshelxreader_LDADD = \
- ./libcoot-shelx.la \
-- ./libcoot-coord-utils.la \
-- ./libcoot-utils.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS)
-+ ./libcoot-utils.la
-
- testcootutils_SOURCES = test-utils.cc
- testcootutils_LDADD = \
- ./libcoot-shelx.la \
- ./libcoot-coord-utils.la \
- ./libcoot-utils.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS)
-+ $(MMDB_LIBS)
-
-
---- geometry/Makefile.am 2008-09-08 15:22:01.000000000 +0200
-+++ geometry/Makefile.am.new 2008-11-20 12:01:08.000000000 +0100
-@@ -35,6 +35,10 @@
-
- libcoot_geometry_la_SOURCES = protein-geometry.cc protein-geometry-mmdb.cc
++
+Index: ligand/Makefile.am
+===================================================================
+--- ligand/Makefile.am (revision 2293)
++++ ligand/Makefile.am (working copy)
+@@ -49,6 +49,17 @@
+ torsion-general.cc rotamer-tables.cc primitive-chi-angles.cc dipole.cc\
+ base-pairing.cc backrub-rotamer.cc
-+libcoot_geometry_la_LIBADD = \
-+ $(top_builddir)/coot-utils/libcoot-utils.la \
-+ $(CLIPPER_LIBS) $(MMDB_LIBS)
++libcoot_ligand_la_LIBADD = \
++ $(top_builddir)/ideal/libcoot-ideal.la \
++ $(top_builddir)/coords/libcoot-coords.la \
++ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
++ $(top_builddir)/coot-utils/libcoot-map-utils.la \
++ $(top_builddir)/db-main/libcoot-db-main.la \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/geometry/libcoot-geometry.la \
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la
+
- # libcoot_geometry_la_CXXFLAGS = -g -O1
+ AM_CXXFLAGS = \
+ -DPKGDATADIR='"$(pkgdatadir)"' \
+ $(COOT_WINDOWS_CFLAGS)
+@@ -68,7 +79,6 @@
- noinst_PROGRAMS = test-geometry test-read-components
-@@ -43,12 +47,6 @@
+ test_random_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-map-utils.la \
+@@ -85,31 +95,14 @@
- test_read_components_SOURCES = test-read-components.cc test-read-components.hh
+ test_ligand_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
--test_geometry_LDADD = ./libcoot-geometry.la \
-- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS)
--
--test_read_components_LDADD = \
-- ./libcoot-geometry.la \
-- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS)
-+test_geometry_LDADD = ./libcoot-geometry.la
+ test_helix_placement_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+@@ -120,18 +113,9 @@
-+test_read_components_LDADD = ./libcoot-geometry.la
-
-diff -ur ideal/Makefile.am ideal/Makefile.am
---- ideal/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ ideal/Makefile.am 2008-07-13 16:41:14.000000000 -0700
-@@ -44,6 +44,12 @@
- AM_CXXFLAGS = $(COOT_GSL_FLAGS) $(GSL_CFLAGS)
+ test_fffear_in_coot_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coot-utils/libcoot-map-heavy.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
- libcoot_ideal_la_SOURCES = simple-restraint.cc pepflip.cc regularize-minimol.cc lograma.cpp
-+libcoot_ideal_la_LIBADD = \
-+ $(top_builddir)/coot-utils/libcoot-utils.la \
-+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-+ $(top_builddir)/coot-utils/libcoot-shelx.la \
-+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-+ $(GSL_LIBS)
+@@ -143,23 +127,13 @@
- noinst_PROGRAMS = test-indexing with-geometry with-map logramatest
- # bin_PROGRAMS =
-@@ -63,36 +69,25 @@
- with_geometry_LDADD = \
- ./libcoot-ideal.la \
- $(top_builddir)/geometry/libcoot-geometry.la \
-- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
- $(top_builddir)/coords/libcoot-coords.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ findligand_real_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
-- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
-+ $(CLIPPER_LIBS) $(MMDB_LIBS)
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
- # add libcoot-map-utils for the debugging density_around_point function
- with_map_LDADD = \
- ./libcoot-ideal.la \
+ findwaters_real_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
$(top_builddir)/geometry/libcoot-geometry.la \
-- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
$(top_builddir)/coords/libcoot-coords.la \
- $(top_builddir)/coot-utils/libcoot-map-utils.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+@@ -190,16 +164,7 @@
+ testdunbrack_SOURCES = testdunbrack.cc
+
+ testdunbrack_LDADD = ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
-- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(top_builddir)/compat/libcoot-compat.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
-+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
-+ $(top_builddir)/compat/libcoot-compat.la \
-+ $(CLIPPER_LIBS) $(MMDB_LIBS)
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
- test_indexing_LDADD = \
- ./libcoot-ideal.la \
- $(top_builddir)/geometry/libcoot-geometry.la \
-- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
-- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
-+ $(CLIPPER_LIBS) $(MMDB_LIBS)
+Index: analysis/Makefile.am
+===================================================================
+--- analysis/Makefile.am (revision 2293)
++++ analysis/Makefile.am (working copy)
+@@ -9,6 +9,7 @@
+ $(MMDB_CXXFLAGS)
- # Why do I need all these libraries to simply link a trivial test program?
- # Badness....
-diff -ur mini-mol/Makefile.am mini-mol/Makefile.am
---- mini-mol/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ mini-mol/Makefile.am 2008-07-13 16:40:40.000000000 -0700
-@@ -32,8 +32,9 @@
- testminimol_SOURCES = testminimol.cc
+ libcoot_analysis_la_SOURCES = bfkurt.cc
++libcoot_analysis_la_LIBADD = $(top_builddir)/coot-utils/libcoot-coord-utils.la
- libcoot_mini_mol_la_SOURCES = mini-mol.cc mini-mol-utils.cc
-+libcoot_mini_mol_la_LIBADD = \
-+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
-+ $(CLIPPER_LIBS)
+ bin_PROGRAMS = bfactan
- testminimol_LDADD = libcoot-mini-mol.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
-- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(CLIPPER_LIBS) $(MMDB_LIBS)
-+ $(MMDB_LIBS)
-diff -ur skeleton/Makefile.am skeleton/Makefile.am
---- skeleton/Makefile.am 2008-07-13 16:40:27.000000000 -0700
-+++ skeleton/Makefile.am 2008-07-13 16:40:40.000000000 -0700
-@@ -36,7 +36,7 @@
+@@ -16,7 +17,6 @@
+
+ bfactan_LDADD = \
+ libcoot-analysis.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(CLIPPER_LIBS) \
+Index: skeleton/Makefile.am
+===================================================================
+--- skeleton/Makefile.am (revision 2293)
++++ skeleton/Makefile.am (working copy)
+@@ -39,8 +39,8 @@
libcoot_skeleton_la_SOURCES = $(libskeleton_a_sources)
--
+libcoot_skeleton_la_LIBADD = ../atom-utils/libcoot-atomutils.la
+-
# bin_PROGRAMS = ncssearch test_various test_torsion test_theta_2
---- high-res/Makefile.am 2009-01-06 20:19:20.000000000 +0100
-+++ high-res/Makefile.am.new 2009-06-03 10:13:35.000000000 +0200
-@@ -39,13 +39,17 @@
+ # ncssearch_SOURCES = ncs-search.cc ncs-search.h
+Index: coot-surface/Makefile.am
+===================================================================
+--- coot-surface/Makefile.am (revision 2293)
++++ coot-surface/Makefile.am (working copy)
+@@ -25,3 +25,4 @@
+
+ libcoot_surface_la_SOURCES = \
+ coot-surface.cc coot-surface.hh rgbreps.cc rgbreps.h
++libcoot_surface_la_LIBADD = $(top_builddir)/surface/libccp4mg-surface.la
+Index: high-res/Makefile.am
+===================================================================
+--- high-res/Makefile.am (revision 2293)
++++ high-res/Makefile.am (working copy)
+@@ -39,13 +39,16 @@
libcoot_high_res_la_SOURCES = high-res.cc coot-atom-graph.cc residue-distortions.cc \
sequence-assignment.cc
@@ -212,7 +204,6 @@ diff -ur skeleton/Makefile.am skeleton/Makefile.am
+ $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS)
-+
check_PROGRAMS = testatomgraph tracehighres testseqalign testseqassignment globularize_protein
@@ -223,7 +214,7 @@ diff -ur skeleton/Makefile.am skeleton/Makefile.am
$(top_builddir)/db-main/libcoot-db-main.la \
$(top_builddir)/ideal/libcoot-ideal.la \
$(top_builddir)/geometry/libcoot-geometry.la \
-@@ -53,71 +57,60 @@
+@@ -53,71 +56,60 @@
$(top_builddir)/mini-mol/libcoot-mini-mol.la \
$(top_builddir)/coot-utils/libcoot-coord-extras.la \
$(top_builddir)/coot-utils/libcoot-coord-utils.la \
@@ -299,152 +290,116 @@ diff -ur skeleton/Makefile.am skeleton/Makefile.am
globularize_protein_SOURCES = globularize.cc
---- ligand/Makefile.am 2009-02-06 00:50:01.000000000 +0100
-+++ ligand/Makefile.am.new 2009-06-03 10:29:30.000000000 +0200
-@@ -50,6 +50,18 @@
- torsion-general.cc rotamer-tables.cc primitive-chi-angles.cc dipole.cc\
- base-pairing.cc
+Index: cootaneer/Makefile.am
+===================================================================
+--- cootaneer/Makefile.am (revision 2293)
++++ cootaneer/Makefile.am (working copy)
+@@ -34,6 +34,7 @@
+ buccaneer-sequence.cpp cootaneer-sequence.cpp \
+ buccaneer-lib.h buccaneer-prot.h \
+ buccaneer-sequence.h cootaneer-sequence.h
++libcootaneer_la_LIBADD = $(CLIPPER_LIBS)
-+libcoot_ligand_la_LIBADD = \
-+ $(top_builddir)/ideal/libcoot-ideal.la \
-+ $(top_builddir)/coords/libcoot-coords.la \
-+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-+ $(top_builddir)/coot-utils/libcoot-map-utils.la \
-+ $(top_builddir)/db-main/libcoot-db-main.la \
-+ $(top_builddir)/coot-utils/libcoot-shelx.la \
-+ $(top_builddir)/geometry/libcoot-geometry.la \
-+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
-+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la
-+
-+
- AM_CXXFLAGS = \
- -DPKGDATADIR='"$(pkgdatadir)"' \
- $(COOT_WINDOWS_CFLAGS)
-@@ -69,52 +81,25 @@
+ subpkgdatadir = $(pkgdatadir)
+ subpkgdata_DATA = cootaneer-llk-2.40.dat
+Index: geometry/Makefile.am
+===================================================================
+--- geometry/Makefile.am (revision 2293)
++++ geometry/Makefile.am (working copy)
+@@ -35,6 +35,9 @@
+ # -DHAVE_SYS_STDTYPES_H
- test_random_LDADD = \
- ./libcoot-ligand.la \
-- $(top_builddir)/ideal/libcoot-ideal.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coords/libcoot-coords.la \
-- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-- $(top_builddir)/coot-utils/libcoot-map-utils.la \
-- $(top_builddir)/db-main/libcoot-db-main.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
-- $(top_builddir)/geometry/libcoot-geometry.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
- $(top_builddir)/compat/libcoot-compat.la \
- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+ libcoot_geometry_la_SOURCES = protein-geometry.cc protein-geometry-mmdb.cc
++libcoot_geometry_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-utils.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
- test_ligand_LDADD = \
- ./libcoot-ligand.la \
-- $(top_builddir)/ideal/libcoot-ideal.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coords/libcoot-coords.la \
-- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-- $(top_builddir)/coot-utils/libcoot-map-utils.la \
-- $(top_builddir)/db-main/libcoot-db-main.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
-- $(top_builddir)/geometry/libcoot-geometry.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
- $(top_builddir)/compat/libcoot-compat.la \
- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+ # libcoot_geometry_la_CXXFLAGS = -g -O1
- test_helix_placement_LDADD = \
- ./libcoot-ligand.la \
-- $(top_builddir)/ideal/libcoot-ideal.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coords/libcoot-coords.la \
-- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-- $(top_builddir)/coot-utils/libcoot-map-utils.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
-- $(top_builddir)/geometry/libcoot-geometry.la \
-- $(top_builddir)/db-main/libcoot-db-main.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
- $(top_builddir)/compat/libcoot-compat.la \
- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+@@ -44,12 +47,7 @@
-@@ -122,19 +107,10 @@
+ test_read_components_SOURCES = test-read-components.cc test-read-components.hh
- test_fffear_in_coot_LDADD = \
- ./libcoot-ligand.la \
-- $(top_builddir)/ideal/libcoot-ideal.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-- $(top_builddir)/coords/libcoot-coords.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
-- $(top_builddir)/geometry/libcoot-geometry.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
- $(top_builddir)/coot-utils/libcoot-map-heavy.la \
-- $(top_builddir)/db-main/libcoot-db-main.la \
-- $(top_builddir)/coot-utils/libcoot-map-utils.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
- $(top_builddir)/compat/libcoot-compat.la \
- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+-test_geometry_LDADD = ./libcoot-geometry.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++test_geometry_LDADD = ./libcoot-geometry.la
++
++test_read_components_LDADD = ./libcoot-geometry.la
-@@ -146,23 +122,13 @@
+-test_read_components_LDADD = \
+- ./libcoot-geometry.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
+-
+Index: ideal/Makefile.am
+===================================================================
+--- ideal/Makefile.am (revision 2293)
++++ ideal/Makefile.am (working copy)
+@@ -54,6 +54,12 @@
- findligand_real_LDADD = \
- ./libcoot-ligand.la \
-- $(top_builddir)/ideal/libcoot-ideal.la \
-- $(top_builddir)/geometry/libcoot-geometry.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/coords/libcoot-coords.la \
-- $(top_builddir)/db-main/libcoot-db-main.la \
-- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
-- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+
+ libcoot_ideal_la_SOURCES = simple-restraint.cc pepflip.cc regularize-minimol.cc lograma.cpp
++libcoot_ideal_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-utils.la \
++ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
++ $(GSL_LIBS)
+
+
+ noinst_PROGRAMS = test-indexing with-geometry with-map logramatest
+@@ -75,12 +81,8 @@
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
- $(top_builddir)/coot-utils/libcoot-utils.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
- $(top_builddir)/compat/libcoot-compat.la \
- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
- findwaters_real_LDADD = \
- ./libcoot-ligand.la \
-- $(top_builddir)/ideal/libcoot-ideal.la \
+ # add libcoot-map-utils for the debugging density_around_point function
+ with_map_LDADD = \
+@@ -88,22 +90,16 @@
$(top_builddir)/geometry/libcoot-geometry.la \
$(top_builddir)/coords/libcoot-coords.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-@@ -193,17 +159,8 @@
- testdunbrack_SOURCES = testdunbrack.cc
-
- testdunbrack_LDADD = ./libcoot-ligand.la \
-- $(top_builddir)/ideal/libcoot-ideal.la \
- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
-- $(top_builddir)/geometry/libcoot-geometry.la \
-- $(top_builddir)/coords/libcoot-coords.la \
-- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
-- $(top_builddir)/coot-utils/libcoot-map-utils.la \
-- $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
-- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
$(top_builddir)/coot-utils/libcoot-utils.la \
-- $(top_builddir)/coot-utils/libcoot-shelx.la \
- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+- $(top_builddir)/compat/libcoot-compat.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(top_builddir)/compat/libcoot-compat.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
- # lib coot-coords depends on mmdb, even though Cartesian doesn't
---- tw/Makefile.am 2007-04-20 16:12:16.000000000 +0200
-+++ tw/Makefile.am.new 2009-06-03 10:31:17.000000000 +0200
-@@ -39,14 +39,16 @@
+ test_indexing_LDADD = \
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ # Why do I need all these libraries to simply link a trivial test program?
+ # Badness....
+Index: tw/Makefile.am
+===================================================================
+--- tw/Makefile.am (revision 2293)
++++ tw/Makefile.am (working copy)
+@@ -39,14 +39,15 @@
include_HEADERS = coot-tw.hh
libcoot_tw_la_SOURCES = tw.cc
+libcoot_tw_la_LIBADD = \
+ $(GTKCANVAS_LIBS) \
+ @GTK_LIBS@
-+
noinst_PROGRAMS = coot-tiddly
@@ -457,8 +412,59 @@ diff -ur skeleton/Makefile.am skeleton/Makefile.am
# cootsound_LDADD = -L/sw/lib -lvorbisfile -logg -lao
---- Makefile.am 2009-01-06 15:50:23.000000000 +0100
-+++ Makefile.am.new 2009-06-03 10:35:59.000000000 +0200
+Index: coot-utils/Makefile.am
+===================================================================
+--- coot-utils/Makefile.am (revision 2293)
++++ coot-utils/Makefile.am (working copy)
+@@ -49,6 +49,7 @@
+ # for simple things:
+ libcoot_utils_la_SOURCES = coot-utils.cc coot-fasta.cc atomic-numbers.cc \
+ gdk-keysyms.cc
++libcoot_coord_utils_la_LIBADD = $(CLIPPER_LIBS) libcoot-utils.la
+
+ # for pure coordinates (mmdb) things
+ libcoot_coord_utils_la_SOURCES = coot-coord-utils.cc \
+@@ -56,6 +57,7 @@
+
+ # shelx
+ libcoot_shelx_la_SOURCES = coot-shelx-ins.cc
++libcoot_shelx_la_LIBADD = $(MMDB_LIBS) libcoot-coord-utils.la
+
+ # for non-simple coordinates things
+ libcoot_coord_extras_la_SOURCES = coot-coord-extras.cc coot-coord-lsq.cc \
+@@ -63,24 +65,23 @@
+
+ # for (map) things that need to link mmdb and clipper:
+ libcoot_map_utils_la_SOURCES = coot-map-utils.cc peak-search.cc trim.cc xmap-stats.cc
++libcoot_map_utils_la_LIBADD = $(CLIPPER_LIBS)
+
+ # for map things that need mmdb, clipper, gsl and other things
+ libcoot_map_heavy_la_SOURCES = coot-map-heavy.cc coot-fffear.cc
++libcoot_map_heavy_la_LIBADD = $(GSL_LIBS)
+
+ noinst_PROGRAMS = testshelxreader testcootutils
+
+ testshelxreader_SOURCES = test-shelx-reader.cc
+ testshelxreader_LDADD = \
+ ./libcoot-shelx.la \
+- ./libcoot-coord-utils.la \
+ ./libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(MMDB_LIBS)
+
+ testcootutils_SOURCES = test-utils.cc
+ testcootutils_LDADD = \
+ ./libcoot-shelx.la \
+- ./libcoot-coord-utils.la \
+ ./libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(MMDB_LIBS)
+
+-
+Index: Makefile.am
+===================================================================
+--- Makefile.am (revision 2293)
++++ Makefile.am (working copy)
@@ -25,10 +25,10 @@
# see configure.in for po intl
@@ -473,13 +479,3 @@ diff -ur skeleton/Makefile.am skeleton/Makefile.am
# po, no po today.
---- coot-utils/Makefile.am.orig 2009-06-07 17:40:00.000000000 -0700
-+++ coot-utils/Makefile.am 2009-06-07 17:39:07.000000000 -0700
-@@ -63,6 +63,7 @@
-
- # for (map) things that need to link mmdb and clipper:
- libcoot_map_utils_la_SOURCES = coot-map-utils.cc peak-search.cc trim.cc xmap-stats.cc
-+libcoot_map_utils_la_LIBADD = $(CLIPPER_LIBS)
-
- # for map things that need mmdb, clipper, gsl and other things
- libcoot_map_heavy_la_SOURCES = coot-map-heavy.cc coot-fffear.cc
diff --git a/sci-chemistry/coot/files/0.6_pre1-gcc4.4.patch b/sci-chemistry/coot/files/0.6_pre1-gcc4.4.patch
index d754a519c..b7cd75662 100644
--- a/sci-chemistry/coot/files/0.6_pre1-gcc4.4.patch
+++ b/sci-chemistry/coot/files/0.6_pre1-gcc4.4.patch
@@ -1,11 +1,10 @@
---- coot-utils/coot-utils.cc 2008-12-10 01:22:01.000000000 +0100
-+++ coot-utils/coot-utils.cc.new 2009-08-06 00:31:18.000000000 +0200
-@@ -47,7 +47,7 @@
+--- coot-utils/coot-utils.cc 2009-08-06 00:02:51.000000000 +0200
++++ coot-utils/coot-utils.cc.new 2009-08-06 00:06:13.000000000 +0200
+@@ -25,6 +25,7 @@
- #include "clipper/core/hkl_compute.h"
- #include "coot-utils.hh"
--
+ #include <stdexcept> // for string_to_int.
+ #include <sstream> // ditto.
+#include <cstdio>
-
- std::string
+ #include "coot-sysdep.h"
+ #if defined _MSC_VER
diff --git a/sci-chemistry/coot/files/0.6_pre1-test-rama.patch b/sci-chemistry/coot/files/0.6_pre1-test-rama.patch
new file mode 100644
index 000000000..96bfbf60c
--- /dev/null
+++ b/sci-chemistry/coot/files/0.6_pre1-test-rama.patch
@@ -0,0 +1,15 @@
+--- src/graphics-info.h (revision 2296)
++++ src/graphics-info.h (working copy)
+@@ -798,12 +798,10 @@
+ // guess we shall rather use COOT_DATA_DIR and only as fallback PKGDATADIR?!
+ // maybe only for windows!?
+ std::string tables_dir = PKGDATADIR;
+-#ifdef WINDOWS_MINGW
+ char *data_dir = getenv("COOT_DATA_DIR");
+ if (data_dir) {
+ tables_dir = data_dir;
+ }
+-#endif // MINGW
+ tables_dir += "/rama-data";
+ rot_prob_tables.set_tables_dir(tables_dir);
+