aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-28 10:39:59 +0200
committerJustin Lecher <jlec@gentoo.org>2011-04-28 10:39:59 +0200
commitf0c8b800774b3d554c462bd55f2901734108277a (patch)
tree17f7bb270ada42b487e85524335ec68320458e79 /sci-chemistry/coot/files
parentCleaned old patches (diff)
downloadsci-f0c8b800774b3d554c462bd55f2901734108277a.tar.gz
sci-f0c8b800774b3d554c462bd55f2901734108277a.tar.bz2
sci-f0c8b800774b3d554c462bd55f2901734108277a.zip
Fixed underlinking problems
(Portage version: 2.2.0_alpha30/git/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/coot/files')
-rw-r--r--sci-chemistry/coot/files/9999-gl.patch10
-rw-r--r--sci-chemistry/coot/files/9999-lidia.patch19
2 files changed, 25 insertions, 4 deletions
diff --git a/sci-chemistry/coot/files/9999-gl.patch b/sci-chemistry/coot/files/9999-gl.patch
new file mode 100644
index 000000000..bbd858c64
--- /dev/null
+++ b/sci-chemistry/coot/files/9999-gl.patch
@@ -0,0 +1,10 @@
+Index: coot-surface/Makefile.am
+===================================================================
+--- coot-surface/Makefile.am (revision 3478)
++++ coot-surface/Makefile.am (working copy)
+@@ -29,4 +29,4 @@
+
+ libcoot_surface_la_LIBADD = \
+ $(top_builddir)/surface/libccp4mg-surface.la \
+- $(GLUT_LIBS) $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(GLUT_LIBS) $(CLIPPER_LIBS) $(MMDB_LIBS) -lGL
diff --git a/sci-chemistry/coot/files/9999-lidia.patch b/sci-chemistry/coot/files/9999-lidia.patch
index 5b5039c47..0ca154c96 100644
--- a/sci-chemistry/coot/files/9999-lidia.patch
+++ b/sci-chemistry/coot/files/9999-lidia.patch
@@ -1,10 +1,10 @@
Index: lbg/Makefile.am
===================================================================
---- lbg/Makefile.am (revision 3406)
+--- lbg/Makefile.am (revision 3478)
+++ lbg/Makefile.am (working copy)
-@@ -25,6 +25,12 @@
- lbg-search.cc residue-circles.cc rdkit-interface.cc \
- flev-annotations.cc
+@@ -32,6 +32,12 @@
+ $(top_builddir)/utils/libcoot-utils.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS) $(RDKIT_LIBS) $(GOOCANVAS_LIBS) $(GTK_LIBS)
+libcoot_lidia_la_LIBADD = \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
@@ -15,3 +15,14 @@ Index: lbg/Makefile.am
lidia_SOURCES = lidia-main.cc lbg-callbacks-outer.cc
include_HEADERS = lbg.hh wmolecule.hh rdkit-interface.hh flev-annotations.hh
+Index: lidia-core/Makefile.am
+===================================================================
+--- lidia-core/Makefile.am (revision 3478)
++++ lidia-core/Makefile.am (working copy)
+@@ -29,3 +29,6 @@
+
+ libcoot_lidia_core_la_SOURCES = lbg-molfile.cc lig-build.cc
+
++libcoot_lidia_core_la_LIBADD = \
++ $(top_builddir)/geometry/libcoot-geometry.la \
++ $(MMDB_LIBS)