aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-27 23:09:53 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-27 23:10:05 +0200
commitacae1324e8adeca79d423cf0c18d41f05791150d (patch)
treeda3991d28679e775e3f12c9f4f9cb959d09aeb39 /sci-chemistry/mgltools-support
parentFix for Python ABIs (diff)
downloadsci-acae1324e8adeca79d423cf0c18d41f05791150d.tar.gz
sci-acae1324e8adeca79d423cf0c18d41f05791150d.tar.bz2
sci-acae1324e8adeca79d423cf0c18d41f05791150d.zip
Fix for Python ABIs
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'sci-chemistry/mgltools-support')
-rw-r--r--sci-chemistry/mgltools-support/ChangeLog8
-rw-r--r--sci-chemistry/mgltools-support/Manifest14
-rw-r--r--sci-chemistry/mgltools-support/mgltools-support-1.5.4-r1.ebuild (renamed from sci-chemistry/mgltools-support/mgltools-support-1.5.4.ebuild)29
3 files changed, 38 insertions, 13 deletions
diff --git a/sci-chemistry/mgltools-support/ChangeLog b/sci-chemistry/mgltools-support/ChangeLog
index bfcbe5bec..257e82e01 100644
--- a/sci-chemistry/mgltools-support/ChangeLog
+++ b/sci-chemistry/mgltools-support/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-chemistry/mgltools-support
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mgltools-support-1.5.4-r1 (27 Jun 2010)
+
+ 27 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ -mgltools-support-1.5.4.ebuild, +mgltools-support-1.5.4-r1.ebuild:
+ Python ABI fixes
+
*mgltools-support-1.5.4 (17 May 2009)
17 May 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
diff --git a/sci-chemistry/mgltools-support/Manifest b/sci-chemistry/mgltools-support/Manifest
index 531e71c12..654b82193 100644
--- a/sci-chemistry/mgltools-support/Manifest
+++ b/sci-chemistry/mgltools-support/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST mgltools_source_1.5.4.tar.gz 21591865 RMD160 faa158477c4e9156ee5fd23b89251e5bedbd689d SHA1 3b3056a75cd944a4aa46771e09916a4e85052b88 SHA256 d0c614e167512bd19127c741cb2d9860443c097f7ccf0bbe244c0b155e59a9c2
-EBUILD mgltools-support-1.5.4.ebuild 1162 RMD160 569d77f429ce1c2b31c8cef9c8035a0ae626df21 SHA1 171069bfdeae87303ac2b4b07c0a3f0479647e96 SHA256 390d3b606f2e3f7a9de4cfdf723da1fd331445399fae8a9be2c1cb07332c3316
-MISC ChangeLog 295 RMD160 0f0bbfc2b8a53cef42a107a89b839b973d7abf8d SHA1 87c7d11c5beacf5065fd75d6e71d23a558f119eb SHA256 ad660d5c5a2992414be12fa5442be06b6ebefbc8ee9d685a8a0a8241da5e4b74
+EBUILD mgltools-support-1.5.4-r1.ebuild 1215 RMD160 4c50741381b4969973008779f074a3d114b1f702 SHA1 f4554462562720fa0557342efa0337b6a0195fd3 SHA256 a61fba80535933069416b2cbc09d0a742b2788e78fb519e925431309eb9f7600
+MISC ChangeLog 473 RMD160 168608a834d01cfdd77e51cd82ae5f5af1ad2256 SHA1 5d57963ee4e73e0477bc020daf525da79ce2da8c SHA256 7419bea218f9b935c91b10310c37d003bf9284eb92e8dbcdf18f241a136627f1
MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwnviEACgkQgAnW8HDreRaqVgCgiF+762nue63/gg0OPUM7wMxd
+ID4An1P/vhpICfZU97QEodvaNrHsfkBL
+=vUBy
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/mgltools-support/mgltools-support-1.5.4.ebuild b/sci-chemistry/mgltools-support/mgltools-support-1.5.4-r1.ebuild
index 2c29db8f9..0406798f2 100644
--- a/sci-chemistry/mgltools-support/mgltools-support-1.5.4.ebuild
+++ b/sci-chemistry/mgltools-support/mgltools-support-1.5.4-r1.ebuild
@@ -1,12 +1,19 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="true"
+
inherit distutils
-MY_P="${P/mgltools-s/S}"
+MY_PN="Support"
+MY_P="${MY_PN}-${PV}"
-DESCRIPTION="mgltools plugin -- support"
+DESCRIPTION="mgltools plugin -- Support"
HOMEPAGE="http://mgltools.scripps.edu"
#SRC_URI="http://mgltools.scripps.edu/downloads/tars/releases/REL${PV}/mgltools_source_${PV}.tar.gz"
SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/mgltools_source_${PV}.tar.gz"
@@ -20,12 +27,15 @@ RDEPEND=""
DEPEND="${RDEPEND}
dev-lang/swig"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}"/${MY_P}
src_unpack() {
tar xzpf "${DISTDIR}"/${A} mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
tar xzpf mgltools_source_${PV}/MGLPACKS/${MY_P}.tar.gz
+}
+src_prepare() {
find "${S}" -name CVS -type d -exec rm -rf '{}' \; >& /dev/null
find "${S}" -name LICENSE -type f -exec rm -f '{}' \; >& /dev/null
@@ -34,14 +44,13 @@ src_unpack() {
-e 's:^.*LICENSE:#&1:g' \
-i "${S}"/MANIFEST.in
- sed \
- -e "1s:^.*$:mglroot = \'$(python_get_sitedir)/MGLToolsPckgs/\':g" \
- -i Support-1.5.4/Support/sitecustomize.py
+ distutils_src_prepare
}
-src_install() {
- distutils_src_install
+pkg_postinst() {
+ python_mod_optimize ${MY_PN}
+}
- insinto $(python_get_sitedir)
- doins Support/sitecustomize.py
+pkg_postrm() {
+ python_mod_cleanup ${MY_PN}
}