aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-16 12:14:24 +0100
committerJustin Lecher <jlec@gentoo.org>2014-01-16 12:14:24 +0100
commit4eeff26c63fd4d2742af14a3bccb0d8cb3204159 (patch)
tree673674bff15b69ca1b3930e59bc8b7d6463a9e27 /sci-chemistry/unio
parentsci-chemistry/chimera-bin: Version BUmp, #498154 (diff)
downloadsci-4eeff26c63fd4d2742af14a3bccb0d8cb3204159.tar.gz
sci-4eeff26c63fd4d2742af14a3bccb0d8cb3204159.tar.bz2
sci-4eeff26c63fd4d2742af14a3bccb0d8cb3204159.zip
sci-chemistry/unio: Version BUmp
Package-Manager: portage-2.2.8 RepoMan-Options: --force
Diffstat (limited to 'sci-chemistry/unio')
-rw-r--r--sci-chemistry/unio/ChangeLog7
-rw-r--r--sci-chemistry/unio/Manifest1
-rw-r--r--sci-chemistry/unio/unio-2.0.3.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/sci-chemistry/unio/ChangeLog b/sci-chemistry/unio/ChangeLog
index a0753f4e8..b40047e3d 100644
--- a/sci-chemistry/unio/ChangeLog
+++ b/sci-chemistry/unio/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-chemistry/unio
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*unio-2.0.3 (16 Jan 2014)
+
+ 16 Jan 2014; Justin Lecher <jlec@gentoo.org> +unio-2.0.3.ebuild:
+ Version BUmp
+
08 Nov 2013; Justin Lecher <jlec@gentoo.org> unio-2.0.2-r1.ebuild:
Allow emul packages
diff --git a/sci-chemistry/unio/Manifest b/sci-chemistry/unio/Manifest
index 8ec1fa0ee..8daa30d4c 100644
--- a/sci-chemistry/unio/Manifest
+++ b/sci-chemistry/unio/Manifest
@@ -1 +1,2 @@
+DIST UNIO10-Distribution19Dec2013.tar.gz 57868953 SHA256 ccde9f3eb6e94b591e398390547d0813be64687191833051fa5d557af6fb7fba SHA512 92b2c747997cd012429768f677ab8c603ce678ebddf362c38c91c325e4ba01ca0ee7e763efa10a42cbbd1d7c13929d9af7adba128691780e3e0fc121c95d1d84 WHIRLPOOL 3616ac14bd33c6dc69bd91c295f6b6b1b330199036ae1f5fcd46aad6d01ab7df6f79a027851163b030523435876fccd3d155c34c3e4f99aaaab7c10221c0e1d3
DIST UNIO10-Distribution21Dec2011.tar.gz 57917250 SHA256 3f80de8c4ba147283903a8629251bcfc3518402f3cd9ca422e436a57555e90e2 SHA512 6add4d641aa69036e0ee53874785c1fb73037543c02da76a45e1c7d25eeceaa3001d2ed190ca6415d01a27e08edbf88627b4be06ccec681ebec617c0cf97a77d WHIRLPOOL e7fd7af9273d60b4227e33c1638107b59ba3d04d165d546f6be680a9c2a024e9b09d85b7324acc989f08911cbf65c8889356973a46bc18a1c9623d53ed2d264b
diff --git a/sci-chemistry/unio/unio-2.0.3.ebuild b/sci-chemistry/unio/unio-2.0.3.ebuild
new file mode 100644
index 000000000..f123c5c2e
--- /dev/null
+++ b/sci-chemistry/unio/unio-2.0.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+MY_P="UNIO10-Distribution19Dec2013"
+
+DESCRIPTION="Automated NMR Data Analysis"
+HOMEPAGE="http://perso.ens-lyon.fr/torsten.herrmann/Herrmann/Software.html"
+#SRC_URI="http://perso.ens-lyon.fr/torsten.herrmann/Academic//Academic_Download_files/${MY_P}.tar.gz"
+SRC_URI="${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="unio"
+IUSE=""
+
+RDEPEND="
+ app-shells/ksh
+ || (
+ (
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]
+ )
+ app-emulation/emul-linux-x86-xlibs
+ )"
+DEPEND=""
+
+S="${WORKDIR}/UNIO_10"
+RESTRICT="fetch"
+
+QA_PREBUILT="opt/unio/*"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE}"
+ einfo "and fetch ${A}"
+ einfo "into ${DISTDIR}"
+}
+
+src_install() {
+ mv Unio\'10 Unio10 || die
+ mv Unio10/Linux/{Unio\'10,Unio10} || die
+ rm -rf \
+ Unio10/MacOSX \
+ UnioAlgorithms/.DS_Store \
+ UnioAlgorithms/unio-2.0.2/src/unio/unioexe.Darwin* \
+ UnioAlgorithms/unio-2.0.2/src/echo/libEcho.a \
+ UnioAlgorithms/unio-2.0.2/License.pdf || die
+
+ insinto /opt/${PN}
+ doins -r Unio10 UnioAlgorithms UnioDocumentations
+ fperms 755 \
+ /opt/${PN}/Unio10/Linux/Unio10 \
+ /opt/${PN}/Unio10/Linux/Externals/revzip.so
+ chmod 755 \
+ "${ED}"/opt/${PN}/UnioAlgorithms/${PN}-2.0.2/bin/* \
+ "${ED}"/opt/${PN}/UnioAlgorithms/${PN}-2.0.2/src/${PN}/* || die
+
+ cat >> "${T}/${PN}" <<- EOF
+ #!${EPREFIX}/bin/bash
+ cd "${EPREFIX}/opt/${PN}"
+ exec Unio10/Linux/Unio10 \$@
+ EOF
+
+ dobin "${T}/${PN}"
+}