aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-10 22:23:32 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-12-10 22:23:32 +0100
commit209ce6a29ab5582fc245438614f32999f713604e (patch)
tree23a39b99504fdef70193954883d7c760f5507e76 /sys-devel/ittapi
parentsci-libs/oneMKL: new package, add 0.2_p20221201 (diff)
downloadsci-209ce6a29ab5582fc245438614f32999f713604e.tar.gz
sci-209ce6a29ab5582fc245438614f32999f713604e.tar.bz2
sci-209ce6a29ab5582fc245438614f32999f713604e.zip
sys-devel/ittapi: new package, add 3.23.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-devel/ittapi')
-rw-r--r--sys-devel/ittapi/Manifest1
-rw-r--r--sys-devel/ittapi/ittapi-3.23.0.ebuild26
-rw-r--r--sys-devel/ittapi/metadata.xml11
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-devel/ittapi/Manifest b/sys-devel/ittapi/Manifest
new file mode 100644
index 000000000..674ca7b92
--- /dev/null
+++ b/sys-devel/ittapi/Manifest
@@ -0,0 +1 @@
+DIST ittapi-3.23.0.tar.gz 132481 BLAKE2B c1caf9755e3f0dfa0de2d3e1bca29f3596b68669d8b119822ab23617fdfc33df8d049ed9e8fd66b0865abd311a72b8362e9f26ff45875880cedd1d545f475500 SHA512 2e4aae2e3867588d38734f4425e416fb1ee6fd7df64c72823b481256cf9b7c18a50b6dba22727e16ada9ba0ac10ad0a96fc0d7c6d68edd2b64a899ea047651b5
diff --git a/sys-devel/ittapi/ittapi-3.23.0.ebuild b/sys-devel/ittapi/ittapi-3.23.0.ebuild
new file mode 100644
index 000000000..38ae1b432
--- /dev/null
+++ b/sys-devel/ittapi/ittapi-3.23.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Intel Instrumentation and Tracing Technology and Just-In-Time API "
+HOMEPAGE="https://github.com/intel/ittapi"
+SRC_URI="https://github.com/intel/ittapi/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ # Make it a shared library
+ sed -i -e 's/STATIC/SHARED/g' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_install() {
+ dolib.so "${BUILD_DIR}/bin/"*.so
+ doheader -r "${S}/include/"*
+ einstalldocs
+}
diff --git a/sys-devel/ittapi/metadata.xml b/sys-devel/ittapi/metadata.xml
new file mode 100644
index 000000000..f71d530b0
--- /dev/null
+++ b/sys-devel/ittapi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intel/ittapi</remote-id>
+ </upstream>
+</pkgmetadata>