aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild')
-rw-r--r--sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild b/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild
index 7b00f46d5..4b277862d 100644
--- a/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild
+++ b/sci-chemistry/chimera-bin/chimera-bin-1.14.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop xdg python-any-r1
DESCRIPTION="An extensible Molecular Modelling System"
-HOMEPAGE="http://www.cgl.ucsf.edu/chimera"
+HOMEPAGE="https://www.cgl.ucsf.edu/chimera/"
SRC_URI="chimera-${PV}-linux_x86_64.bin"
SLOT="0"
@@ -42,19 +44,21 @@ RDEPEND="
x11-libs/libXrender
x11-libs/libSM
x11-libs/libXt
- x11-libs/libGLw"
+ x11-libs/libGLw
+ ${PYTHON_DEPS}
+"
S="${WORKDIR}"
-RESTRICT="fetch strip"
+RESTRICT="fetch mirror strip"
QA_PREBUILT="opt/.*"
pkg_nofetch() {
elog "Please visit"
- elog "http://www.cgl.ucsf.edu/chimera/download.html"
+ elog "https://www.cgl.ucsf.edu/chimera/download.html"
elog "or"
- elog "http://www.cgl.ucsf.edu/chimera/olddownload.html"
+ elog "https://www.cgl.ucsf.edu/chimera/olddownload.html"
elog "and download ${A} into your DISTDIR"
}
@@ -80,6 +84,10 @@ src_install() {
exeinto /opt/bin/
doexe "${T}"/chimera
+ # point the symlink to the correct location
+ rm "${ED}/opt/chimera-bin/include/ft2build.h"
+ dosym ../../../usr/include/freetype2/ft2build.h opt/chimera-bin/include/ft2build.h
+
make_desktop_entry "${EPREFIX}/opt/bin/chimera" Chimera chimeraIcon
if use prefix; then