aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/root/files')
-rw-r--r--sci-physics/root/files/olbd.confd9
-rw-r--r--sci-physics/root/files/olbd.initd26
-rw-r--r--sci-physics/root/files/root-5.26.00e-libpng15.patch33
-rw-r--r--sci-physics/root/files/root-5.26.00g-explicit-functions.patch12
-rw-r--r--sci-physics/root/files/root-5.28.00b-nobyte-compile.patch138
-rw-r--r--sci-physics/root/files/root-5.28.00h-explicit-functions.patch12
-rw-r--r--sci-physics/root/files/root-5.32.00-explicit-functions.patch18
-rw-r--r--sci-physics/root/files/xrootd.confd8
-rw-r--r--sci-physics/root/files/xrootd.initd26
9 files changed, 282 insertions, 0 deletions
diff --git a/sci-physics/root/files/olbd.confd b/sci-physics/root/files/olbd.confd
new file mode 100644
index 000000000..848f4d7ba
--- /dev/null
+++ b/sci-physics/root/files/olbd.confd
@@ -0,0 +1,9 @@
+# conf.d file for olbd daemon
+
+# User to run as (default is `xrootd')
+OLBD_USER="root"
+
+#
+# Please refer to the olbd(1) man(1) page for more
+# information on command line parameters.
+OLBD_OPTS=""
diff --git a/sci-physics/root/files/olbd.initd b/sci-physics/root/files/olbd.initd
new file mode 100644
index 000000000..179330040
--- /dev/null
+++ b/sci-physics/root/files/olbd.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/files/olbd.initd,v 1.1 2008/12/18 18:10:18 bicatali Exp $
+
+depend() {
+ need net
+ use dns logger
+ provide root-file-server
+}
+
+start() {
+ ebegin "Starting ROOT open load balancer server"
+ start-stop-daemon --start --quiet --user=${OLBD_USER} \
+ --make-pidfile --pidfile=/var/run/olbd.pid \
+ --exec /usr/bin/olbd --background -- ${OLBD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ROOT open load balancer server"
+ start-stop-daemon --stop --quiet \
+ --pidfile=/var/run/olbd.pid \
+ --exec /usr/bin/olbd
+ eend $?
+}
diff --git a/sci-physics/root/files/root-5.26.00e-libpng15.patch b/sci-physics/root/files/root-5.26.00e-libpng15.patch
new file mode 100644
index 000000000..91ed9c428
--- /dev/null
+++ b/sci-physics/root/files/root-5.26.00e-libpng15.patch
@@ -0,0 +1,33 @@
+This patch is a copy from media-libs/libafterimage.
+
+--- graf2d/asimage/src/libAfterImage/export.c
++++ graf2d/asimage/src/libAfterImage/export.c
+@@ -496,7 +496,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
+--- graf2d/asimage/src/libAfterImage/import.c
++++ graf2d/asimage/src/libAfterImage/import.c
+@@ -1251,7 +1251,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+
+@@ -1468,7 +1468,7 @@
+
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
+ memcpy(data, buf->buffer, length);
+ buf->buffer += length;
+ }
diff --git a/sci-physics/root/files/root-5.26.00g-explicit-functions.patch b/sci-physics/root/files/root-5.26.00g-explicit-functions.patch
new file mode 100644
index 000000000..16a720696
--- /dev/null
+++ b/sci-physics/root/files/root-5.26.00g-explicit-functions.patch
@@ -0,0 +1,12 @@
+--- root/io/io/Module.mk.orig 2011-09-29 13:49:50.000000000 +0400
++++ root/io/io/Module.mk 2012-03-09 02:57:20.518370595 +0400
+@@ -66,9 +66,4 @@
+ distclean:: distclean-$(MODNAME)
+
+ ##### extra rules ######
+-#ifeq ($(GCC_VERS_FULL),gcc-4.4.0)
+-ifeq ($(GCC_VERS),gcc-4.4)
+-ifneq ($(filter -O%,$(OPT)),)
+ $(IODIRS)/TStreamerInfoReadBuffer.o: CXXFLAGS += -DR__EXPLICIT_FUNCTION_INSTANTIATION
+-endif
+-endif
diff --git a/sci-physics/root/files/root-5.28.00b-nobyte-compile.patch b/sci-physics/root/files/root-5.28.00b-nobyte-compile.patch
new file mode 100644
index 000000000..7029bf169
--- /dev/null
+++ b/sci-physics/root/files/root-5.28.00b-nobyte-compile.patch
@@ -0,0 +1,138 @@
+diff -Naur root.orig/Makefile root/Makefile
+--- root.orig/Makefile 2010-12-17 22:48:40.577775091 +0300
++++ root/Makefile 2010-12-17 22:49:27.902497903 +0300
+@@ -1148,10 +1148,7 @@
+ if test "x$(RFLX_GRFLXPY)" != "x"; then \
+ rm -f $(DESTDIR)$(LIBDIR)/$(RFLX_GRFLXPY); \
+ fi; \
+- if test "x$(RFLX_GRFLXPYC)" != "x"; then \
+- rm -f $(DESTDIR)$(LIBDIR)/$(RFLX_GRFLXPYC); \
+- fi; \
+- if test "x$(RFLX_GRFLXPY)$(RFLX_GRFLXPYC)" != "x"; then \
++ if test "x$(RFLX_GRFLXPY)" != "x"; then \
+ dir=$(RFLX_GRFLXDD:lib/=); \
+ while test "x$${dir}" != "x" && \
+ test -d $(DESTDIR)$(LIBDIR)/$${dir} && \
+diff -Naur root.orig/bindings/pyroot/Module.mk root/bindings/pyroot/Module.mk
+--- root.orig/bindings/pyroot/Module.mk 2010-12-17 22:48:39.941179413 +0300
++++ root/bindings/pyroot/Module.mk 2010-12-17 22:49:27.899164943 +0300
+@@ -48,8 +48,6 @@
+ ROOTPY := $(subst $(MODDIR),$(LPATH),$(ROOTPYS))
+ $(LPATH)/%.py: $(MODDIR)/%.py; cp $< $@
+ endif
+-ROOTPYC := $(ROOTPY:.py=.pyc)
+-ROOTPYO := $(ROOTPY:.py=.pyo)
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/%.h,include/%.h,$(PYROOTH))
+@@ -68,10 +66,8 @@
+ include/%.h: $(PYROOTDIRI)/%.h
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+-$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) $(ROOTPYC) $(ROOTPYO) \
++$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) \
+ $(ROOTLIBSDEP) $(PYTHONLIBDEP)
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libPyROOT.$(SOEXT) $@ \
+@@ -113,7 +109,7 @@
+
+ distclean-$(MODNAME): clean-$(MODNAME)
+ @rm -f $(PYROOTDEP) $(PYROOTDS) $(PYROOTDH) $(PYROOTLIB) \
+- $(ROOTPY) $(ROOTPYC) $(ROOTPYO) $(PYROOTMAP) \
++ $(ROOTPY) $(PYROOTMAP) \
+ $(PYROOTPYD) $(PYTHON64DEP) $(PYTHON64)
+
+ distclean:: distclean-$(MODNAME)
+diff -Naur root.orig/build/package/debian/rules root/build/package/debian/rules
+--- root.orig/build/package/debian/rules 2010-12-17 22:48:40.197817461 +0300
++++ root/build/package/debian/rules 2010-12-17 22:49:27.902497903 +0300
+@@ -623,10 +623,6 @@
+ -X$(SYSCONFDIR)/root/system.rootauthrc \
+ -X$(SYSCONFDIR)/root/system.rootdaemonrc \
+ -X$(PREFIX)/lib/root/$(SOVERS)/libAfterImage.a \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyo \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyo
+ # $(foreach i, \
+ # $(wildcard $(DTMP)/$(PREFIX)/lib/root/lib*.so.$(SOVERS)), \
+ # -X$(i:$(DTMP)/%=%) )
+diff -Naur root.orig/cint/cintex/Module.mk root/cint/cintex/Module.mk
+--- root.orig/cint/cintex/Module.mk 2010-12-17 22:48:40.057833071 +0300
++++ root/cint/cintex/Module.mk 2010-12-17 22:49:27.902497903 +0300
+@@ -31,10 +31,6 @@
+ CINTEXPY := $(subst $(MODDIR)/python,$(LPATH),$(CINTEXPYS))
+ $(LPATH)/%.py: $(MODDIR)/python/%.py; cp $< $@
+ endif
+-ifneq ($(BUILDPYTHON),no)
+-CINTEXPYC := $(CINTEXPY:.py=.pyc)
+-CINTEXPYO := $(CINTEXPY:.py=.pyo)
+-endif
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/Cintex/%.h,include/Cintex/%.h,$(CINTEXH))
+@@ -86,8 +82,6 @@
+ fi)
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(CINTEXLIB): $(CINTEXO) $(CINTEXPY) $(CINTEXPYC) $(CINTEXPYO) \
+ $(ORDER_) $(subst $(CINTEXLIB),,$(MAINLIBS)) $(CINTEXLIBDEP)
+diff -Naur root.orig/cint/reflex/Module.mk root/cint/reflex/Module.mk
+--- root.orig/cint/reflex/Module.mk 2010-12-17 22:48:40.037835301 +0300
++++ root/cint/reflex/Module.mk 2010-12-17 22:51:36.871451359 +0300
+@@ -48,9 +48,6 @@
+ RFLX_GRFLXS := $(wildcard $(RFLX_GRFLXSD)/*.py)
+ RFLX_GRFLXPY := $(patsubst $(RFLX_GRFLXSD)/%.py,$(RFLX_GRFLXDD)/%.py,$(RFLX_GRFLXS))
+ RFLX_GRFLXPY += $(RFLX_GCCXMLPATHPY)
+-ifneq ($(BUILDPYTHON),no)
+-RFLX_GRFLXPYC := $(subst .py,.pyc,$(RFLX_GRFLXPY))
+-endif
+
+ RFLX_LIBDIR = $(LIBDIR)
+
+@@ -92,7 +89,7 @@
+
+ ALLEXECS += $(RFLX_GENMAPX)
+
+-POSTBIN += $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++POSTBIN += $(RFLX_GRFLXPY)
+
+ ##### local rules #####
+ .PHONY: all-$(MODNAME) clean-$(MODNAME) distclean-$(MODNAME) \
+@@ -122,8 +119,6 @@
+ mkdir -p lib/python/genreflex; fi )
+ cp $< $@
+
+-$(RFLX_GRFLXDD)/%.pyc: $(RFLX_GRFLXDD)/%.py
+- @python -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(RFLX_GENMAPO) : CXXFLAGS += -I$(REFLEXDIRS)/genmap
+
+@@ -149,7 +144,7 @@
+ $(RLIBMAP) -o $@ -l $(REFLEXDICTLIB) \
+ -d $(REFLEXDICTLIBDEPM) -c $(REFLEXL)
+
+-all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPY)
+
+ clean-genreflex:
+ @rm -rf lib/python/genreflex
+diff -Naur root.orig/cint/reflex/python/CMakeLists.txt root/cint/reflex/python/CMakeLists.txt
+--- root.orig/cint/reflex/python/CMakeLists.txt 2010-12-17 22:48:40.037835301 +0300
++++ root/cint/reflex/python/CMakeLists.txt 2010-12-17 22:49:27.902497903 +0300
+@@ -15,7 +15,7 @@
+ ##################### sources ####################
+
+ FILE(GLOB_RECURSE GENREFLEX_SRCS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} genreflex/*.py)
+-SET(GENREFLEX_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/genreflex/genreflex.pyc PARENT_SCOPE)
++SET(GENREFLEX_SCRIPT PARENT_SCOPE)
+
+ ##################### gccxmlpath ####################
+
+
diff --git a/sci-physics/root/files/root-5.28.00h-explicit-functions.patch b/sci-physics/root/files/root-5.28.00h-explicit-functions.patch
new file mode 100644
index 000000000..918b696cb
--- /dev/null
+++ b/sci-physics/root/files/root-5.28.00h-explicit-functions.patch
@@ -0,0 +1,12 @@
+--- root/io/io/Module.mk.orig 2011-11-24 20:12:56.000000000 +0400
++++ root/io/io/Module.mk 2012-03-09 03:45:42.850549826 +0400
+@@ -67,9 +67,4 @@
+ distclean:: distclean-$(MODNAME)
+
+ ##### extra rules ######
+-#ifeq ($(GCC_VERS_FULL),gcc-4.4.0)
+-ifeq ($(GCC_VERS),gcc-4.4)
+-ifneq ($(filter -O%,$(OPT)),)
+ $(call stripsrc,$(IODIRS)/TStreamerInfoReadBuffer.o): CXXFLAGS += -DR__EXPLICIT_FUNCTION_INSTANTIATION
+-endif
+-endif
diff --git a/sci-physics/root/files/root-5.32.00-explicit-functions.patch b/sci-physics/root/files/root-5.32.00-explicit-functions.patch
new file mode 100644
index 000000000..570d61e68
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-explicit-functions.patch
@@ -0,0 +1,18 @@
+--- root/io/io/Module.mk.orig 2012-02-29 19:46:38.000000000 +0400
++++ root/io/io/Module.mk 2012-03-09 02:29:19.905665572 +0400
+@@ -67,15 +67,5 @@
+ distclean:: distclean-$(MODNAME)
+
+ ##### extra rules ######
+-#ifeq ($(GCC_VERS_FULL),gcc-4.4.0)
+-ifeq ($(GCC_VERS),gcc-4.4)
+-ifneq ($(filter -O%,$(OPT)),)
+ $(call stripsrc,$(IODIRS)/TStreamerInfoReadBuffer.o): CXXFLAGS += -DR__EXPLICIT_FUNCTION_INSTANTIATION
+-endif
+-endif
+-ifeq ($(GCC_VERS),gcc-4.5)
+-ifneq ($(filter -O%,$(OPT)),)
+ $(call stripsrc,$(IODIRS)/TStreamerInfoReadBuffer.o): CXXFLAGS += -DR__EXPLICIT_FUNCTION_INSTANTIATION
+-endif
+-endif
+-
diff --git a/sci-physics/root/files/xrootd.confd b/sci-physics/root/files/xrootd.confd
new file mode 100644
index 000000000..e725cd1e7
--- /dev/null
+++ b/sci-physics/root/files/xrootd.confd
@@ -0,0 +1,8 @@
+# conf.d file for xroot daemon
+
+# User to run as (default is `root')
+XROOTD_USER="root"
+
+# Please refer to the xrootd(1) man(1) page for more
+# information on command line parameters.
+XROOTD_OPTS=""
diff --git a/sci-physics/root/files/xrootd.initd b/sci-physics/root/files/xrootd.initd
new file mode 100644
index 000000000..28dd8a511
--- /dev/null
+++ b/sci-physics/root/files/xrootd.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/files/xrootd.initd,v 1.2 2009/01/20 18:04:09 bicatali Exp $
+
+depend() {
+ need net
+ use logger dns
+ provide root-file-server
+}
+
+start() {
+ ebegin "Starting extended ROOTD file server"
+ start-stop-daemon --start --quiet --user ${XROOTD_USER} \
+ --make-pidfile --pidfile /var/run/xrootd.pid \
+ --exec /usr/bin/xrootd --background -- ${XROOTD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping extended ROOTD file server"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/xrootd.pid \
+ --exec /usr/bin/xrootd
+ eend $?
+}