aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/maui/files')
-rw-r--r--sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch11
-rw-r--r--sys-cluster/maui/files/maui.initd24
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch b/sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch
new file mode 100644
index 000000000..9b77a27f8
--- /dev/null
+++ b/sys-cluster/maui/files/3.2.6_p21-autoconf-2.60-compat.patch
@@ -0,0 +1,11 @@
+--- maui-3.2.6p21.orig/Makefile.in 2006-05-23 15:20:49.000000000 -0700
++++ maui-3.2.6p21/Makefile.in 2006-09-25 20:42:24.000000000 -0700
+@@ -18,7 +18,7 @@
+ # ============================
+ # Resource Manager section
+ # ============================
+-@ll_definitions@@sdr_definitions@@pbs_definitions@@sge_definitions@@lsf_definitions@@mx_definitions@@pcre_definitions@
++@pbs_definitions@
+
+ # ============================
+ # Master Makefile for @PACKAGE_NAME@-@PACKAGE_VERSION@
diff --git a/sys-cluster/maui/files/maui.initd b/sys-cluster/maui/files/maui.initd
new file mode 100644
index 000000000..03d654fe8
--- /dev/null
+++ b/sys-cluster/maui/files/maui.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/files/maui.initd,v 1.2 2011/06/29 16:15:04 alexxy Exp $
+
+depend() {
+ need net
+ after pbs_server slurmctld
+ before pbs_mom slurmd
+ after logger
+}
+
+start() {
+ ebegin "Starting Maui scheduler"
+ start-stop-daemon --start --exec /usr/sbin/maui
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Maui scheduler"
+ start-stop-daemon --stop -p /var/spool/maui/maui.pid
+ eend ${?}
+}
+# vim:ts=4