summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-29 08:54:24 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-29 08:54:24 +0000
commit732b8cc896de442e977f7fc2a8cbfa8b9614fa57 (patch)
tree113696350699238132ac8776ca94784fbc175906 /sci-mathematics
parentwww-client/ttb: Corrected for multiple PyABI installation, added ~amd64 (diff)
downloadsunrise-reviewed-732b8cc896de442e977f7fc2a8cbfa8b9614fa57.tar.gz
sunrise-reviewed-732b8cc896de442e977f7fc2a8cbfa8b9614fa57.tar.bz2
sunrise-reviewed-732b8cc896de442e977f7fc2a8cbfa8b9614fa57.zip
sci-mathematics/pyquante: Corrected for multiple PyABI installation, added ~amd64
svn path=/sunrise/; revision=11920
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pyquante/ChangeLog5
-rw-r--r--sci-mathematics/pyquante/Manifest4
-rw-r--r--sci-mathematics/pyquante/pyquante-1.5.1.ebuild17
3 files changed, 17 insertions, 9 deletions
diff --git a/sci-mathematics/pyquante/ChangeLog b/sci-mathematics/pyquante/ChangeLog
index d2ce65cb3..2df4e3e69 100644
--- a/sci-mathematics/pyquante/ChangeLog
+++ b/sci-mathematics/pyquante/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-mathematics/pyquante
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Apr 2011; Justin Lecher <jlec@gentoo.org> pyquante-1.5.1.ebuild:
+ Corrected for multiple PyABI installation, added ~amd64
+
03 Apr 2007; Markus Ullmann <jokey@gentoo.org> -pyquante-1.5.0.ebuild:
Drop old
diff --git a/sci-mathematics/pyquante/Manifest b/sci-mathematics/pyquante/Manifest
index acce0a77d..ef9560670 100644
--- a/sci-mathematics/pyquante/Manifest
+++ b/sci-mathematics/pyquante/Manifest
@@ -1,4 +1,4 @@
DIST PyQuante-1.5.1.tar.gz 247354 RMD160 457d7d520a7d45c151016e04629f93d86dd8d4aa SHA1 d8cdfb1d0e7f614255b7a0a54797f95598a670b0 SHA256 72f8c4d98ebebb8502c2fc2377a330e0fb3d4ec9e74872a2fe4e8ff6e1d81616
-EBUILD pyquante-1.5.1.ebuild 433 RMD160 c46b1a7def226299c11c5c332765a618fd1ff5a0 SHA1 aa5c601e1bdb860a761173c201a1524fc2495c49 SHA256 719520c60801a5608f1bb5115f86e4cdc13fb6b1821c84b3e56b08a9ee46e80c
-MISC ChangeLog 603 RMD160 b596b1f62e224389cccb53a88744b6f86fa51fbb SHA1 9c66e9266eedd3745f3e81427d96c7efda6910fd SHA256 18822ad6d22acd9338991cd70a33a983cbc950a146d46ef9d3bc13d3837e97c5
+EBUILD pyquante-1.5.1.ebuild 522 RMD160 b307ba99c2a36d031038cb57bbc63f88001ba511 SHA1 edf4dc3aafcd71d2ab4e2cd9b4f3faadc233d0ed SHA256 a909be7e25449dfdae47314a3cd9c192b40510f748421557d5610d00990369c3
+MISC ChangeLog 732 RMD160 a5e3e09cb542ce2ffece25820b0e45c25b616171 SHA1 3351a916e14a03d12f932e6b5d758b4faedf1502 SHA256 491d8826ee8d4ee881daa21c4f4f19f53961962afdc0e36cc09abcf4b0278b3b
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/sci-mathematics/pyquante/pyquante-1.5.1.ebuild b/sci-mathematics/pyquante/pyquante-1.5.1.ebuild
index 31efe7897..36fc33da2 100644
--- a/sci-mathematics/pyquante/pyquante-1.5.1.ebuild
+++ b/sci-mathematics/pyquante/pyquante-1.5.1.ebuild
@@ -1,22 +1,27 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
MY_PN="PyQuante"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="a quantum chemistry package written in Python."
+DESCRIPTION="Quantum chemistry package written in Python"
HOMEPAGE="http://pyquante.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"