summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2009-11-21 10:18:30 +0000
committerJustin Lecher <jlec@gentoo.org>2009-11-21 10:18:30 +0000
commitb7009b0e59989e5c2301c1f3a830f6ffa3ffd494 (patch)
tree0f8d6c5ac950694e0019b7eaaaebdae2898cba28 /x11-terms
parentDrop more (diff)
downloadsunrise-reviewed-b7009b0e59989e5c2301c1f3a830f6ffa3ffd494.tar.gz
sunrise-reviewed-b7009b0e59989e5c2301c1f3a830f6ffa3ffd494.tar.bz2
sunrise-reviewed-b7009b0e59989e5c2301c1f3a830f6ffa3ffd494.zip
x11-terms/terminator: Added patch to respect libnotify USE
svn path=/sunrise/; revision=9570
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminator/ChangeLog4
-rw-r--r--x11-terms/terminator/Manifest5
-rw-r--r--x11-terms/terminator/files/0.13-libnotify.patch19
-rw-r--r--x11-terms/terminator/terminator-0.13.ebuild1
4 files changed, 27 insertions, 2 deletions
diff --git a/x11-terms/terminator/ChangeLog b/x11-terms/terminator/ChangeLog
index d86803b4d..e5644dd99 100644
--- a/x11-terms/terminator/ChangeLog
+++ b/x11-terms/terminator/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 21 Nov 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +files/0.13-libnotify.patch, terminator-0.13.ebuild:
+ Added patch to respect libnotify USE
+
13 Nov 2009; Justin Riley <justin.t.riley@gmail.com>
terminator-0.13.ebuild, +files/terminator-0.13-without-icon-cache.patch,
metadata.xml:
diff --git a/x11-terms/terminator/Manifest b/x11-terms/terminator/Manifest
index 1c9b09c86..a88644ecf 100644
--- a/x11-terms/terminator/Manifest
+++ b/x11-terms/terminator/Manifest
@@ -1,5 +1,6 @@
+AUX 0.13-libnotify.patch 535 RMD160 2f20e819a8e0c1b948ecd6bd2ea7c70d7df3e760 SHA1 aa5aa8c7ff62b356c2cd260080d03d437d8a829c SHA256 b51b6f9afa0274b61aa32d0c4f7138ed356fcbc4543539b3ffcf54e99699af44
AUX terminator-0.13-without-icon-cache.patch 305 RMD160 281f8a8ae23a67f802fd2b001021a921cf9473bf SHA1 29efc6db37579c263629a4f5df9e24b97b7fe88a SHA256 b20fe414e6a443c0cb52c4da0da4be5c5f8ac8af90d5e9763b43c5383623978b
DIST terminator_0.13.tar.gz 2253315 RMD160 aa488cc6dd4f6fcc103b1d2f7092d804474e0173 SHA1 685d54ac62210b6ef056e77a2bd16d7dc6dd77b2 SHA256 5f8e8ec8ba1add72fd71974fa85c66bba1b0ee671771fe7b8aa636d7e574cd9e
-EBUILD terminator-0.13.ebuild 627 RMD160 92d43a60fb6cfb04aab2c17a4e28592f4e4bbf20 SHA1 9b3077e6e36bdda9fb3559776db585f0f5ed82fb SHA256 91505eaf6825ea85db436642b45807ccfdf884e37cbefa0500e7dd40a4665092
-MISC ChangeLog 1418 RMD160 a3a4c93b930fec3d637d2c64501d16fa1f4b9ccc SHA1 724e3c49654259e2ff5777ff55a354ac4ca2a6f9 SHA256 8d5e495528243a7a4f04a12463e6707cad41472c6dd3be2681cf041870c1164f
+EBUILD terminator-0.13.ebuild 688 RMD160 f882f266850f5daa11236896420c95fa92b202be SHA1 bb7626a5ce58af3affc05e92cb1189f650d097b3 SHA256 f0432f6f302b3b9bf9df0f2a61a14b165965d204698908b030d039033fc8850b
+MISC ChangeLog 1570 RMD160 757af37e8545d1306ecbf52e964cf323823fd021 SHA1 f9b4e2ec2925d14e43fec7af9cd87f48b5c90f95 SHA256 0007f04c484457d2dfb5f0ff8b9f00a32af889dbb321fbbba399aec36e9f7d48
MISC metadata.xml 244 RMD160 3d91fe41482efa93d0fa13a0a1078f991e373964 SHA1 b91243411d89b3b5874d7a5da45ff3fc92cb8d01 SHA256 745d279ac21231c8136938854d2e5716341568ad614891280769c00ac391be56
diff --git a/x11-terms/terminator/files/0.13-libnotify.patch b/x11-terms/terminator/files/0.13-libnotify.patch
new file mode 100644
index 000000000..5566a18a6
--- /dev/null
+++ b/x11-terms/terminator/files/0.13-libnotify.patch
@@ -0,0 +1,19 @@
+diff --git a/terminator b/terminator
+index 5d449e6..3ffb1a0 100755
+--- a/terminator
++++ b/terminator
+@@ -174,14 +174,3 @@ See the following bug report for more details:
+
+ gtk.main()
+
+- try:
+- import pynotify
+- pynotify.init(APP_NAME.capitalize())
+- icontheme = gtk.IconTheme()
+- icon = icontheme.lookup_icon(APP_NAME, 48, 0)
+- notification = pynotify.Notification('Terminator', "I'll be back", icon.get_filename())
+- notification.set_urgency(pynotify.URGENCY_LOW)
+- notification.show()
+- except:
+- pass
+-
diff --git a/x11-terms/terminator/terminator-0.13.ebuild b/x11-terms/terminator/terminator-0.13.ebuild
index 6c93247db..5720c36be 100644
--- a/x11-terms/terminator/terminator-0.13.ebuild
+++ b/x11-terms/terminator/terminator-0.13.ebuild
@@ -22,5 +22,6 @@ S=${WORKDIR}/${PV}
src_prepare() {
epatch "${FILESDIR}"/${P}-without-icon-cache.patch
+ use libnotify || epatch "${FILESDIR}"/${PV}-libnotify.patch
distutils_src_prepare
}