summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/dhex/dhex-0.55.ebuild')
-rw-r--r--app-editors/dhex/dhex-0.55.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/dhex/dhex-0.55.ebuild b/app-editors/dhex/dhex-0.55.ebuild
new file mode 100644
index 000000000..ad94e91e9
--- /dev/null
+++ b/app-editors/dhex/dhex-0.55.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="An ncurses hex-editor with diff mode"
+HOMEPAGE="http://www.dettus.net/dhex/"
+SRC_URI="http://www.dettus.net/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS} -DLINUX=1" || die
+}
+
+src_install() {
+ dobin dhex || die
+ dodoc README || die
+}