summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gummi/gummi-0.4.8.ebuild')
-rw-r--r--app-editors/gummi/gummi-0.4.8.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-editors/gummi/gummi-0.4.8.ebuild b/app-editors/gummi/gummi-0.4.8.ebuild
index a14c3839d..f37e66c99 100644
--- a/app-editors/gummi/gummi-0.4.8.ebuild
+++ b/app-editors/gummi/gummi-0.4.8.ebuild
@@ -2,7 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=1
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
DESCRIPTION="Simple LaTeX editor for GTK+ users"
@@ -14,7 +19,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=dev-python/pygtksourceview-2.4.0:2
+RDEPEND="
+ >=dev-python/pygtksourceview-2.4.0:2
dev-python/python-poppler
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
@@ -26,4 +32,5 @@ pkg_postinst() {
elog "required to have dev-python/gtkspell-python installed to use this"
elog "feature. Support for additional languages can be enabled by"
elog "installing myspell-** packages for your language of choice."
+ distutils_pkg_postinst
}